Page 5 of 18

Posted: Fri Dec 17, 2004 7:03 pm
by Merri
Lacks support for scandinavian alphabets: [hide=tästä] doesn't work, for example. Pretty nasty, because most "click here" variation texts in Finnish use the Ä letter in one of the words.

Posted: Wed Jan 05, 2005 8:04 am
by Achirio
Hello.
Well, I tried installing this cool mod on a forum I work on but, for some reason, the mod will not work.
Here you can see the test topic I made:
Click here
I reviewed the installation step by step and all seems to be in the correct place. Also, notice that these forums have TONS of mods in it (including a center bbcode and a slap bbcode... the later one I was mad when they added it), so I was wondering if anyone here could pinpoint the problem, and hopefully, help me out a bit.
Thanks in advance.

Posted: Wed Jan 05, 2005 3:40 pm
by EGIS

Code: Select all

<!##
//Rain/Snow effect- By Craig Blanchette Craiga.topcities.com
//Script featured on Dynamic Drive
//Visit http://www.dynamicdrive.com for this script and more
Remove this line in overall_header.tpl.

Posted: Wed Jan 05, 2005 4:57 pm
by Achirio
That worked like a charm, MANY thanks ^^

Posted: Thu Jan 06, 2005 8:42 pm
by /Freya
Hmm... I tried to install this but it didn't work for me. The hidden text just showed up, and no link or anything. Just thought I'd say it. I uninstalled it now, it's not such a big deal... I did think it was a cool idea =D

Posted: Wed Jan 12, 2005 12:41 am
by [omega]
I got the mod installed and thik its great but I was wondering if there was a way to make the txt visable only if a person responds to the topic insted of just clicking some text.

Posted: Wed Jan 12, 2005 1:38 am
by mkot

Posted: Wed Jan 12, 2005 3:21 am
by [omega]
to bad the author's site is dead and so is the download link. PLuss from reading the post replied in the topics seemed to be a lot of bugs found in the mod. Is there another mod that is the same or some alteration to this mod???

Posted: Thu Jan 13, 2005 4:23 pm
by ripthesystem
Any way to remove the extra line break?

I'm not exactly sure where the problem is. I've installed this mod and it works perfectly and as it should so thx in advance. My problem comes with the output.

For example:
Welcome to the board [hide=click here for more]hidden content[/hide]


Shows:
Welcome to the board
click here for more


and it works on my board. It hides the content, shows it when clicked etc.. however I don't want the line break that it puts in. How do I get rid of that?

Posted: Thu Jan 13, 2005 4:46 pm
by EGIS
Open:
templates/hidebbcode.js

Find:

Code: Select all

s += '<div><a class="postlink" href="javascript:hideBBCode.showHide(\'' + randomId + '\');" onmouseover="top.status=\'\';" onfocus="this.blur();">' + l_hide + '</a><div>';
Replace with:

Code: Select all

s += '<a class="postlink" href="javascript:hideBBCode.showHide(\'' + randomId + '\');" onmouseover="top.status=\'\';" onfocus="this.blur();">' + l_hide + '</a>';

Posted: Thu Jan 13, 2005 5:44 pm
by ripthesystem
Rockin! Thanks for the awesome quick support!

Posted: Fri Jan 14, 2005 9:49 am
by Joe Belmaati
EGIS,
is there a simple way to strip special characters, so that when people post something like

[hide="uncle Ned's camping trip"]text about camping trip here[/hide]

The Hide link text will just say
uncle Neds camping trip
and still work as intended..?

I was trying to simply add to your patterns and replace arrays in bbcode.php but I couldn't make it work properly....

Posted: Fri Jan 14, 2005 3:45 pm
by EGIS
You can't use single quotes in the tag because of the security risk with javascript. ([hide=');alert('I can execute JavaScript !!!');document.write('test])

Posted: Fri Jan 14, 2005 4:09 pm
by Joe Belmaati
Howabout colon and other special characters..?

Posted: Fri Jan 14, 2005 4:35 pm
by EGIS
Colons are possible, but at the time I wrote the mod I forgot to add many characters, and my knowledge of php was not very good.