[2.0.10] Topic Search

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
10
56%
Very Good
6
33%
Good
1
6%
Fair
0
No votes
Poor
1
6%
 
Total votes: 18

User avatar
TKF2
Registered User
Posts: 37
Joined: Thu Feb 17, 2005 2:42 pm
Location: Leerbroek (near Gorinchem), The Netherlands
Contact:

Post by TKF2 » Mon Mar 21, 2005 10:00 am


darakhshan
Registered User
Posts: 794
Joined: Fri Apr 30, 2004 7:18 pm

Post by darakhshan » Fri May 06, 2005 6:45 am

Hi

I have an introduction forum where users need to introduce themselves before they can be allowed to use my whole forum.

in one page they reply and introduce themselves , there are 140 replies and 14 pages , some times when I click on the last page it says not posting available, why is that? the post is there but on the 13th page then why the 14th page was created?

confused here :roll:

I suppose after installing your mod this is happening please guide me :cry:

agoeliitb
Registered User
Posts: 19
Joined: Sun May 08, 2005 7:48 am
Contact:

Not working

Post by agoeliitb » Wed May 25, 2005 3:01 pm

Hi All,

I installed this mode as per instructions in phpBB v 2.0.15 but it doesnt seem to work. I got the topic search box added below but when i try to search any topic it says not found. Can someone help me in this regard.

Thanks,
-Ankur

mattbugz
Registered User
Posts: 97
Joined: Wed Jun 30, 2004 2:24 pm

Post by mattbugz » Thu Jun 16, 2005 3:06 pm

Good MOD, but I was wondering if anybody knows of a Forum Search MOD?
--
Regards,
Matt

bratzbert
Registered User
Posts: 78
Joined: Sun Feb 01, 2004 8:58 pm

Post by bratzbert » Mon Jun 27, 2005 5:01 am

onetimer wrote:
JRSweets wrote:
open viewtopic_body.tpl, go down to the place where you pasted the code for search in topic and then find in that line "name='post'" change that to "name='post2'" that should fix it


I found the fix. It was posted by MightyY on portedmods.com.


Ehm.. so could you post the fix in here or at least provide us with a link?


Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/viewtopic_body.tpl

#
#-----[ FIND ]------------------------------------------
#
	  {S_TOPIC_ADMIN}</td>
	<td align="right" valign="top

#
#-----[ IN-LINE FIND ]------------------------------------------ 
#

<form action="{U_TOPIC_SEARCH}" name="post"

#
#-----[ IN-LINE REPLACE WITH ]------------------------------------------ 
#

<form action="{U_TOPIC_SEARCH}" name="topic_search_post" 

mattbugz wrote: Good MOD, but I was wondering if anybody knows of a Forum Search MOD?

There was a link posted on the previous page.

User avatar
onigumo
Registered User
Posts: 1755
Joined: Fri Oct 31, 2003 2:32 am
Contact:

Post by onigumo » Mon Jun 27, 2005 6:04 am

Darkmonkey wrote: Yes, the language variable goes in the lang_main.php


You weren't referring to me, were you? My question was if there is "a way to make the box say "Enter Keywords" and it disappears when you click it, just like with IPB? I'd love to have this addition."
I write articles on community building
@ The Infinity Program.

User avatar
eek-1
Registered User
Posts: 8
Joined: Mon Jun 20, 2005 8:23 am

Post by eek-1 » Sat Aug 27, 2005 9:58 am

onigumo wrote: My question was if there is "a way to make the box say "Enter Keywords" and it disappears when you click it, just like with IPB? I'd love to have this addition."


<input type="text" name="search_keywords" class="post" size="21" value="Enter Keywords Here" onfocus="this.value = '';" />

User avatar
onigumo
Registered User
Posts: 1755
Joined: Fri Oct 31, 2003 2:32 am
Contact:

Post by onigumo » Sat Aug 27, 2005 10:14 am

Ooh. Much thanks.

Here's what code I implemented (bolded) in viewtopic_body.tpl, and where:
<td align="right" valign="top" nowrap="nowrap"><form action="{U_TOPIC_SEARCH}" name="post" method="POST" target="_top"><input type="hidden" name="search_terms" value="any" /><input type="hidden" name="return_chars" value="100" /><input type="hidden" name="show_results" value="posts" /><input type="hidden" name="sort_dir" value="ASC" /><input type="hidden" name="mode" value="topic_search" /><input type="hidden" name="topic_id" value="{TOPIC_ID}" /><input type="text" name="search_keywords" size="20" value="Enter Keywords Here" onfocus="this.value = '';" maxlength="250" value="" /> <input type="submit" name="search_submit" value="{L_SEARCH_TOPIC}" class="liteoption" /></form>{JUMPBOX}<span class="gensmall">{S_AUTH_LIST}</span></td>
I write articles on community building
@ The Infinity Program.

User avatar
onigumo
Registered User
Posts: 1755
Joined: Fri Oct 31, 2003 2:32 am
Contact:

Post by onigumo » Sat Aug 27, 2005 10:24 am

New question:

How does one make it so that the input field (the part of topic search where you can enter your keywords) is a more desirable color? To allow me to further explain what I mean, please take a look at the following screen shot. The first arrow (the top one) points to the topic search field -- it's the white portion I want to change, as it looks fine on subSilver, but it's inconsistent on the Boyz template. The second arrow (the bottom one) points to the jump box. Notice the color of the drop-down field on the jump box. That's the color I want to make the topic search box. I also want to take the same action (changing the topic search box color to that of the jump box color) on the one other template I have in addition to Boyz and subSilver: subBleak.
I write articles on community building
@ The Infinity Program.

User avatar
eek-1
Registered User
Posts: 8
Joined: Mon Jun 20, 2005 8:23 am

Post by eek-1 » Sun Aug 28, 2005 6:02 pm

onigumo wrote: How does one make it so that the input field is a more desirable color?

You have to include the class and/or id attribute along its proper value into that input tag so it would follow the forum colours. It should be something like class="post". Just refer from the other input tags in your template file.

PencilWarrior
Registered User
Posts: 16
Joined: Tue Aug 23, 2005 12:47 am

Post by PencilWarrior » Tue Sep 27, 2005 11:40 am

Anyone know if this mod will work with a really simple Quick Reply mod?

(like this one) http://www.phpbb.com/phpBB/viewtopic.php?t=287126

ajp
Registered User
Posts: 158
Joined: Thu Apr 21, 2005 7:47 pm
Location: Kansas
Contact:

Post by ajp » Sat Oct 15, 2005 4:34 pm

PencilWarrior wrote: Anyone know if this mod will work with a really simple Quick Reply mod?

(like this one) http://www.phpbb.com/phpBB/viewtopic.php?t=287126


I just installed it on my board with a quick reply and now when I attempt to use the quick reply I get the error that says you must type a mesage. So I guess it doesnt work. To bad this is a great idea for a mod.
Extended Reply Notification the only mod I have written.

kieranmullen3
Registered User
Posts: 7
Joined: Tue Dec 20, 2005 12:06 am
Contact:

Post by kieranmullen3 » Tue Dec 20, 2005 5:57 am

Does anyone have any new screenshots?

Does this allow to search by topic/subject?
Thanks

KM

mrhyena
Registered User
Posts: 1
Joined: Wed Dec 28, 2005 10:10 am

Has anyone gotten this to work with 2.0.18 using EZMod?

Post by mrhyena » Wed Dec 28, 2005 10:12 am

I tried installing this last night using EZMod and I didn't see any change whatsoever in the forum. Very strange. EZMod didn't have any complaints. Does anyone have any screenshots of what it should look like? Has anyone successfully installed this with 2.0.18?

Thanks,
Dave

da_badtz_one
Registered User
Posts: 376
Joined: Thu Jan 29, 2004 8:25 pm

Post by da_badtz_one » Wed Dec 28, 2005 9:16 pm

I would have wished this mod to have been much more efficient. Currenctly it takes 17 seconds to search through a topic which has over 400 replies and over 3500 queries.

Post Reply

Return to “[2.0.x] MOD Database Cleanup”

Who is online

Users browsing this forum: No registered users and 5 guests