[2.0.10] Moderator CP

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
95
65%
Very Good
27
18%
Good
13
9%
Fair
3
2%
Poor
9
6%
 
Total votes: 147

BTC
Registered User
Posts: 23
Joined: Wed Nov 23, 2005 1:31 am

Post by BTC »

Code: Select all

SQL PROCESSING HALTED

An error was encountered while processing the SQL commands. Further SQL processing has been halted. You may choose to complete the MOD installation anyway and perform the SQL commands manually yourself. However, at this point EM cannot guarantee the MOD will work correctly so you are best off seeking support from the Author before continuing further.

The failed line was:
INSERT INTO phpbb_config(config_name,config_value) VALUES('modcp_levels_used','');;
 

SQL ERROR: 1062
Duplicate entry 'modcp_levels_used' for key 1
how do I get by this?

~BTC
dickibobboy
Registered User
Posts: 83
Joined: Wed Mar 08, 2006 6:30 pm
Contact:

Post by dickibobboy »

still no reply about mine and other people problems
dickibobboy
Registered User
Posts: 83
Joined: Wed Mar 08, 2006 6:30 pm
Contact:

Post by dickibobboy »

well i realised that it is the aphrodite style i am using, as when i change the forum theme to subsilver it works fine, not im not too sure what to do
justbishop
Registered User
Posts: 182
Joined: Mon Sep 15, 2003 2:57 am
Location: Greenville, SC
Contact:

Post by justbishop »

Yeah, I just realised that it could be a skin issue as well (I'm using NoseBleed), but I switched over to sS while logged in under a moderator's account, and I still have nothing.
User avatar
bshadow1
Registered User
Posts: 436
Joined: Thu Jun 02, 2005 12:45 pm

Post by bshadow1 »

i changed my skin to fisubice, and now my mods get a black mod cp screen?
how i fix it?
thanks alot...
plus how i add more modules from the normal acp to the mod cp?

thanks
Image
dickibobboy
Registered User
Posts: 83
Joined: Wed Mar 08, 2006 6:30 pm
Contact:

Post by dickibobboy »

thats the same as i get, if you change your forum theme to subsilver then go into the modcp you will see everything, its the theme that makes it do that
User avatar
ZombieSlayer
Registered User
Posts: 951
Joined: Sun May 02, 2004 3:18 am
Location: California
Contact:

Post by ZombieSlayer »

That's because you have to make the template changes manually to each template you use except for subSilver.

This is true for all MODS that require template editing. Easymod doesn't always make the changes due to slight differences in the language used in the code for the templates.
justbishop
Registered User
Posts: 182
Joined: Mon Sep 15, 2003 2:57 am
Location: Greenville, SC
Contact:

Post by justbishop »

Ok, so I overlooked that one small detail. Still doesn't explain why I don't see anything in NoseBleed when I did make the template modifications to NoseBleed :?
Colin Unger
Registered User
Posts: 21
Joined: Fri Jul 14, 2006 11:29 pm

Post by Colin Unger »

I have installed this but cannot find a link to my moderator cp login. Is there a manual way to enter this link into a page? In my source code my admin link shows up as {ADMIN_LINK}.


Thanks!
Colin Unger
Registered User
Posts: 21
Joined: Fri Jul 14, 2006 11:29 pm

Post by Colin Unger »

I have installed this but cannot find a link to my moderator cp login. Is there a manual way to enter this link into a page? In my source code my admin link shows up as {ADMIN_LINK}.


Thanks!
Colin Unger
Registered User
Posts: 21
Joined: Fri Jul 14, 2006 11:29 pm

Post by Colin Unger »

I have installed this but cannot find a link to my moderator cp login. Is there a manual way to enter this link into a page? In my source code my admin link shows up as {ADMIN_LINK}.


Thanks!

DELTE THIS IT POSTED TWICE BY MISTAKE!
dickibobboy
Registered User
Posts: 83
Joined: Wed Mar 08, 2006 6:30 pm
Contact:

Post by dickibobboy »

you posted 3times!

if you are an admin you cannot see the mod cp you will have to make another account and make it a mod and login, it will be in the same place at the admin cp link
eLeMeNtZ
Registered User
Posts: 7
Joined: Thu Jul 27, 2006 11:41 am
Location: Canberra, Australia
Contact:

Post by eLeMeNtZ »

Famitsu wrote: Thanks to darkmonkey and the MOD team for their hard work
Aiencran wrote:It's an excellent MOD... I installed it and integrated with Smilies Upload MOD... now moderators can upload smilies without having a FTP access... moreover they can ban users, delete them... it's very useful!!!
No they can't delete users :roll: but you can allow them if you remove this <!-- ..... --> in templates/xxxx/modpc/user_edit_body.tpl :)


Untrue because <!-- ..... --> means comment in HTML so it is just a harmless comment. It would be best to leave this there when installing mods.
eLeMeNtZ
Registered User
Posts: 7
Joined: Thu Jul 27, 2006 11:41 am
Location: Canberra, Australia
Contact:

Post by eLeMeNtZ »

I solved the bug for the mod cp being black when on any other theme than SubSilver. This is what you do :D

<- Open modcp/page_header_mod.php ->
Delete all contents in this file.
<- Save modcp/page_header_mod.php ->

<- Open modcp/page_header_mod.php ->
Insert the following:

Code: Select all

<?php
/***************************************************************************
 *                           page_header_admin.php
 *                            -------------------
 *   begin                : Saturday, Feb 13, 2001
 *   copyright            : (C) 2001 The phpBB Group
 *   email                : support@phpbb.com
 *
 *   $Id: page_header_admin.php,v 1.12.2.7 2006/01/29 21:19:02 grahamje Exp $
 *
 *
 ***************************************************************************/

/***************************************************************************
 *
 *   This program is free software; you can redistribute it and/or modify
 *   it under the terms of the GNU General Public License as published by
 *   the Free Software Foundation; either version 2 of the License, or
 *   (at your option) any later version.
 *
 ***************************************************************************/

if ( !defined('IN_PHPBB') )
{
	die("Hacking attempt");
}

define('HEADER_INC', true);

//
// gzip_compression
//
$do_gzip_compress = FALSE;
if ( $board_config['gzip_compress'] )
{
	$phpver = phpversion();

	$useragent = (isset($HTTP_SERVER_VARS['HTTP_USER_AGENT'])) ? $HTTP_SERVER_VARS['HTTP_USER_AGENT'] : getenv('HTTP_USER_AGENT');

	if ( $phpver >= '4.0.4pl1' && ( strstr($useragent,'compatible') || strstr($useragent,'Gecko') ) )
	{
		if ( extension_loaded('zlib') )
		{
			ob_start('ob_gzhandler');
		}
	}
	else if ( $phpver > '4.0' )
	{
		if ( strstr($HTTP_SERVER_VARS['HTTP_ACCEPT_ENCODING'], 'gzip') )
		{
			if ( extension_loaded('zlib') )
			{
				$do_gzip_compress = TRUE;
				ob_start();
				ob_implicit_flush(0);

				header('Content-Encoding: gzip');
			}
		}
	}
}

$template->set_filenames(array(
	'header' => 'admin/page_header.tpl')
);

// Format Timezone. We are unable to use array_pop here, because of PHP3 compatibility
$l_timezone = explode('.', $board_config['board_timezone']);
$l_timezone = (count($l_timezone) > 1 && $l_timezone[count($l_timezone)-1] != 0) ? $lang[sprintf('%.1f', $board_config['board_timezone'])] : $lang[number_format($board_config['board_timezone'])];

//
// The following assigns all _common_ variables that may be used at any point
// in a template. Note that all URL's should be wrapped in append_sid, as
// should all S_x_ACTIONS for forms.
//
$template->assign_vars(array(
	'SITENAME' => $board_config['sitename'],
	'PAGE_TITLE' => $page_title,

	'L_ADMIN' => $lang['Admin'], 
	'L_INDEX' => sprintf($lang['Forum_Index'], $board_config['sitename']),
	'L_FAQ' => $lang['FAQ'],

	'U_INDEX' => append_sid('../index.'.$phpEx),

	'S_TIMEZONE' => sprintf($lang['All_times'], $l_timezone),
	'S_LOGIN_ACTION' => append_sid('../login.'.$phpEx),
	'S_JUMPBOX_ACTION' => append_sid('../viewforum.'.$phpEx),
	'S_CURRENT_TIME' => sprintf($lang['Current_time'], create_date($board_config['default_dateformat'], time(), $board_config['board_timezone'])), 
	'S_CONTENT_DIRECTION' => $lang['DIRECTION'], 
	'S_CONTENT_ENCODING' => $lang['ENCODING'], 
	'S_CONTENT_DIR_LEFT' => $lang['LEFT'], 
	'S_CONTENT_DIR_RIGHT' => $lang['RIGHT'], 

	'T_HEAD_STYLESHEET' => $theme['head_stylesheet'],
	'T_BODY_BACKGROUND' => $theme['body_background'],
	'T_BODY_BGCOLOR' => '#'.$theme['body_bgcolor'],
	'T_BODY_TEXT' => '#'.$theme['body_text'],
	'T_BODY_LINK' => '#'.$theme['body_link'],
	'T_BODY_VLINK' => '#'.$theme['body_vlink'],
	'T_BODY_ALINK' => '#'.$theme['body_alink'],
	'T_BODY_HLINK' => '#'.$theme['body_hlink'],
	'T_TR_COLOR1' => '#'.$theme['tr_color1'],
	'T_TR_COLOR2' => '#'.$theme['tr_color2'],
	'T_TR_COLOR3' => '#'.$theme['tr_color3'],
	'T_TR_CLASS1' => $theme['tr_class1'],
	'T_TR_CLASS2' => $theme['tr_class2'],
	'T_TR_CLASS3' => $theme['tr_class3'],
	'T_TH_COLOR1' => '#'.$theme['th_color1'],
	'T_TH_COLOR2' => '#'.$theme['th_color2'],
	'T_TH_COLOR3' => '#'.$theme['th_color3'],
	'T_TH_CLASS1' => $theme['th_class1'],
	'T_TH_CLASS2' => $theme['th_class2'],
	'T_TH_CLASS3' => $theme['th_class3'],
	'T_TD_COLOR1' => '#'.$theme['td_color1'],
	'T_TD_COLOR2' => '#'.$theme['td_color2'],
	'T_TD_COLOR3' => '#'.$theme['td_color3'],
	'T_TD_CLASS1' => $theme['td_class1'],
	'T_TD_CLASS2' => $theme['td_class2'],
	'T_TD_CLASS3' => $theme['td_class3'],
	'T_FONTFACE1' => $theme['fontface1'],
	'T_FONTFACE2' => $theme['fontface2'],
	'T_FONTFACE3' => $theme['fontface3'],
	'T_FONTSIZE1' => $theme['fontsize1'],
	'T_FONTSIZE2' => $theme['fontsize2'],
	'T_FONTSIZE3' => $theme['fontsize3'],
	'T_FONTCOLOR1' => '#'.$theme['fontcolor1'],
	'T_FONTCOLOR2' => '#'.$theme['fontcolor2'],
	'T_FONTCOLOR3' => '#'.$theme['fontcolor3'],
	'T_SPAN_CLASS1' => $theme['span_class1'],
	'T_SPAN_CLASS2' => $theme['span_class2'],
	'T_SPAN_CLASS3' => $theme['span_class3'])
);

// Work around for "current" Apache 2 + PHP module which seems to not
// cope with private cache control setting
if (!empty($HTTP_SERVER_VARS['SERVER_SOFTWARE']) && strstr($HTTP_SERVER_VARS['SERVER_SOFTWARE'], 'Apache/2'))
{
	header ('Cache-Control: no-cache, pre-check=0, post-check=0');
}
else
{
	header ('Cache-Control: private, pre-check=0, post-check=0, max-age=0');
}
header ('Expires: 0');
header ('Pragma: no-cache');

$template->pparse('header');

?>
<- Save modcp/page_header_mod.php ->

All should work now. If you have any other problems then I am here to help. Just PM for help with problems that you encounter with PHPBB.

Thankyou,
Luke
connan
Registered User
Posts: 24
Joined: Tue Jun 28, 2005 9:09 pm
Location: Croatia

Post by connan »

Great MOD :lol:

On my forum I have 10 moderator's, but I don't want that all have CP.
Is their posebilty that CP have's only moderator what I chose???

Thanks
Post Reply

Return to “[2.0.x] MOD Database Cleanup”