[2.0.10] Moderator CP

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
95
65%
Very Good
27
18%
Good
13
9%
Fair
3
2%
Poor
9
6%
 
Total votes: 147

vdf_belial
Registered User
Posts: 10
Joined: Sat Jan 20, 2007 5:10 pm

Post by vdf_belial »

Hi there. I'm having this sort of issue:
I have a group of site admin and moderators. In the cpanel the moderators can modify the cpanel of users, EVEN of admins. I want the moderators to have only this:
User is active Yes No
User can post Yes No
in their management section in their cpanel.
Of course, the site admin group, i want them to have all the options in their management section.
Thank you.

murnauvsbuñuel
Registered User
Posts: 177
Joined: Mon Jun 20, 2005 9:49 am

Post by murnauvsbuñuel »

Thanks for this great MOD! is fantastic

TheHackMan
Registered User
Posts: 31
Joined: Sun Nov 19, 2006 4:05 am
Location: ......do you wana know?
Contact:

Post by TheHackMan »

Phobos11 wrote:
lifehacker wrote:Im having a problem with this mod: after installing it and trying to enter the modcp I just get redirected to the forum's index....


I'm having the same problem, when trying to access the modcp I get to the forum's index... what should I do?

Yah, its nothing but redirect to the forum page after redirect. I really would like to be able to have and use this mod but for some reason I dont know why I cant get it to work =/ Anybody had this problem and fix it?

User avatar
Sr X
Registered User
Posts: 202
Joined: Wed Feb 07, 2007 9:25 am

Moderator CP v1.1.2

Post by Sr X »

Hi, i have install the last version from the author site HERE
I have a doubt when i read the install.txt, it say:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
login.php

#
#-----[ FIND ]------------------------------------------
#
	if( !$userdata['session_logged_in'] || (isset($HTTP_GET_VARS['admin'])
#
#-----[ IN-LINE FIND ]------------------------------------------
#
&& $userdata['user_level'] == ADMIN
#
#-----[ IN-LINE REPLACE WITH ]------------------------------------------
#
&& ($userdata['user_level'] == ADMIN || in_array($userdata['user_level'], explode(',', $board_config['modcp_levels_used'])))
after, must thus be? with these ")" to the end. it is right:

Code: Select all

if( !$userdata['session_logged_in'] || (isset($HTTP_GET_VARS['admin']) && $userdata['session_logged_in'] && ($userdata['user_level'] == ADMIN || in_array($userdata['user_level'], explode(',', $board_config['modcp_levels_used'])))))
please answer to me, thanks

Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Group access

Post by Pit$Bull »

MOD works fine for me with one exception :(

When a user group is designated as a moderator all the users in that group can completely control all users of that group. I didn't think mods were allowed to modify other mods.

Thanks.

Met-Monkey
Registered User
Posts: 28
Joined: Wed Feb 07, 2007 8:39 am

Post by Met-Monkey »

Hi, please help. Just tried installing this mod. I get the error

Code: Select all

Template->make_filename(): Error - file modcp/index_frameset.tpl does not exist
Why could this be.

Met-Monkey
Registered User
Posts: 28
Joined: Wed Feb 07, 2007 8:39 am

Post by Met-Monkey »

Met-Monkey wrote: Hi, please help. Just tried installing this mod. I get the error

Code: Select all

Template->make_filename(): Error - file modcp/index_frameset.tpl does not exist
Why could this be.


Incidentally i'm trying to log into my admin panel to re-instate the board, i closed the board before making the mod, now i can't get into my admin. HELP PLEASE! :cry:

Xcetera
Registered User
Posts: 11
Joined: Sat Feb 10, 2007 3:30 am

Post by Xcetera »

I realize this is an old post, however; perhaps someone will answer. I installed this mod without problems yet when I click on Mod Control Panel I get this:

Code: Select all

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@webgroups.us and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. 


--------------------------------------------------------------------------------

Apache/1.3.36 Server at www.webgroups.us Port 80

Blueprins
Registered User
Posts: 557
Joined: Thu Feb 13, 2003 2:16 pm
Contact:

Post by Blueprins »

Good Mod, Thank you

sakm
Registered User
Posts: 612
Joined: Sun Jan 21, 2007 8:14 pm
Location: Hull, uk
Name: Stu
Contact:

Post by sakm »

i installed this mod some time ago and was working fine

i have now installed some other mods after it and now im getting this when trying to access the mod cp
Template->make_filename(): Error - file modcp/index_frameset.tpl does not exist


the index_frameset file is there if that helps :?

any ideas anyone ?

sakm
Registered User
Posts: 612
Joined: Sun Jan 21, 2007 8:14 pm
Location: Hull, uk
Name: Stu
Contact:

Post by sakm »

sakm wrote: i installed this mod some time ago and was working fine

i have now installed some other mods after it and now im getting this when trying to access the mod cp
Template->make_filename(): Error - file modcp/index_frameset.tpl does not exist


the index_frameset file is there if that helps :?

any ideas anyone ?


its ok sorted it somehow the file permisions where set wrong :?

User avatar
Sr X
Registered User
Posts: 202
Joined: Wed Feb 07, 2007 9:25 am

Post by Sr X »

i am a problem with the file named: - user_ban_body.tpl for styles morpheus and morpheusx
the box dont show fine

Image
<tr>
<th class="thHead" colspan="2">{L_UNBAN_USER}</th>
</tr>
<tr>
<td class="row1">
<span class="gen">{L_USERNAME}:</span><br />
<span class="gensmall">{L_UNBAN_USER_EXPLAIN}</span></span>
</td>
<td class="row2">{S_UNBAN_USERLIST_SELECT}</td>
</tr>


please, any ideas?

Krank
Registered User
Posts: 179
Joined: Wed Sep 06, 2006 4:50 pm

Post by Krank »

how can i make this work based on usergroups? like i choose which usergroups gets access to the modules?

Liquinn
Registered User
Posts: 296
Joined: Sun Nov 12, 2006 1:14 pm

Post by Liquinn »

Dear maker,

This is one nice mod you made, thanks man. Good that the mods cant do anything to the other mods and admins, just more control they have.

Nice mod you made,

Liquinn.

squeek
Registered User
Posts: 173
Joined: Sat Jan 20, 2007 12:43 am

Post by squeek »

don't know if this MOD is still active but ive installed it and all works fine eccept for one thing.
when a moderator tries to change the password for another registered user (lower rank) it will change the password fine but at the top of the page just above the conplete box there is an error message...

Warning: Missing argument 10 for validate_optional_fields() in c:\program files\easyphp1-8\www\test\includes\functions_validate.php on line 297

strange thing is the functions_validate.php wasnt edited by the MOD also moderators are able to change the rank of the site admin.

Post Reply

Return to “[2.0.x] MOD Database Cleanup”