[2.0.10] Moderator CP

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
95
65%
Very Good
27
18%
Good
13
9%
Fair
3
2%
Poor
9
6%
 
Total votes: 147

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu » Tue Oct 26, 2004 6:26 pm

Flossie wrote: Some of the instructions below are not clear to me. Apologies if I am being stupid.
there is no stupid person in the place
we are all an eternal newbie :D

if HTML looks like an alien for you, i can understand it's hard

Did you understand the first step?
You just need to copy your original tpl files from your template/xxxx/admin directory to a new directory called "modcp" (in the same template/xxxx/ directory)

Second step is hard because it requires HTML knowledge (or understanding)
Flossie wrote: Ok I think I can do that. The instructions seem to be: Reproduce the changes Neils made to "subSilver/modcp/user_edit_body.tpl" in "<your_template>/modcp/user_edit_body.tpl"?
Niels made nothing here ;)

{DISABLE_CHANGE} variable is not necessary, it's only a second security field to check, there is never enough security :)


so you can try yourself, user_select_body.tpl is easy to edit
compare your original user_edit_body.tpl with the one included in the ModCP
or send me your user_edit_body.tpl into a ZIP archive


PS: if you are using subSilver or a template based on subSilver's tree, just copy the modcp directory into your template
you don't need to do all steps above
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -&gt; see my signature to contact me
Contact:

Post by Famitsu » Tue Oct 26, 2004 6:30 pm

[mez] wrote:
Famitsu wrote:it looks weird because i used your templates files with no error, except a problem with template (no colors)
but links worked

Here is how works the admin_auth_ug in the ModCP
-> admincp -> user management -> users permissions -> choose your user -> list all groups he is member of
if you click on one usergroup, you are redirecting to the select page
therefore you cannot edit usergroups permissions, only users permissions per forum

Use ModCP's files, if you have others mods installed on similar files, edit these files

You can try some tests on a demo board (local server = your HDD), for example with EasyPHP http://www.easyphp.org/?lang=en


I have no other mods... and when i use the normal MODCP files as from the Zip it shows that black colours.
in your fisubtext/modcp directory open page_header.tpl
search for

Code: Select all

<!-- link rel="stylesheet" href="../templates/subSilver/{T_HEAD_STYLESHEET}" type="text/css" -->
Replace with

Code: Select all

<link rel="stylesheet" href="../templates/YOUR_THEME_NAME/{T_HEAD_STYLESHEET}" type="text/css" />
a better way should be to replace this file with your page_header.tpl from your admin directory ;)
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

[mez]
Registered User
Posts: 76
Joined: Sun Jun 20, 2004 12:50 pm
Location: Australia
Contact:

Post by [mez] » Wed Oct 27, 2004 4:14 am

I tried changing the code on the modcp page_headr.tpl file and used that file and i had the same black screen colour problem again...

When i use the page_header.tpl file from the fi subtext/admin directory and put that in the modcp directory i get that problem with the permissions again...

CLICK HERE FOR EXAMPLE

Could you please send me a working set of files for the fi subtext theme seeing as you are able to get the to work but no matter what i try it still wont work for me.

Thanks in advance.

Flossie
Registered User
Posts: 23
Joined: Sun May 02, 2004 11:18 am

Post by Flossie » Wed Oct 27, 2004 9:35 am

Famitsu wrote:
Flossie wrote:Some of the instructions below are not clear to me. Apologies if I am being stupid.
there is no stupid person in the place
we are all an eternal newbie :D

if HTML looks like an alien for you, i can understand it's hard

Did you understand the first step?
You just need to copy your original tpl files from your template/xxxx/admin directory to a new directory called "modcp" (in the same template/xxxx/ directory)


I said above "I think I can do that", and indeed I have done it. No problem.
Second step is hard because it requires HTML knowledge (or understanding)


I do know quite a bit of HTML
Flossie wrote:Ok I think I can do that. The instructions seem to be: Reproduce the changes Neils made to "subSilver/modcp/user_edit_body.tpl" in "<your_template>/modcp/user_edit_body.tpl"?
Niels made nothing here ;)

{DISABLE_CHANGE} variable is not necessary, it's only a second security field to check, there is never enough security :)


So what do I do?
so you can try yourself, user_select_body.tpl is easy to edit
compare your original user_edit_body.tpl with the one included in the ModCP


Ok I will do that now
or send me your user_edit_body.tpl into a ZIP archive

PS: if you are using subSilver or a template based on subSilver's tree, just copy the modcp directory into your template
you don't need to do all steps above


Thanks for the offer I will see how I get on.

But as I said above I still don't understand instructions 1) and 3)

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -&gt; see my signature to contact me
Contact:

Post by Famitsu » Wed Oct 27, 2004 3:38 pm

[mez] wrote: I tried changing the code on the modcp page_headr.tpl file and used that file and i had the same black screen colour problem again...

When i use the page_header.tpl file from the fi subtext/admin directory and put that in the modcp directory i get that problem with the permissions again...

CLICK HERE FOR EXAMPLE

Could you please send me a working set of files for the fi subtext theme seeing as you are able to get the to work but no matter what i try it still wont work for me.

Thanks in advance.
OK now i understand

Group Admin->Permissions should not be there or readable

Are you sure you are using the admin_ug_auth.php included in the contrib dir of the ModCP?
because this file remove this link
open your modcp/admin_ug_auth.php at the top
do you have this line:

Code: Select all

	$module['Groups']['Permissions'] = $filename . "?mode=group";
if yes, remove it
otherwise you should not have this link :?



@ Flossie
About instruction 1
{DISABLE_CHANGE} is a variable defined in admin_users.php
it disables all input field <input ................ />
looks like <input type="password"..............{DISABLE_CHANGE} /> password field will be locked
open default file included, search for {DISABLE_CHANGE} (some...) and do the same to your own user_edit_body.tpl


About instruction 2: it's more difficult
here we keep original code but we use a "switch" to enable/disable" profile edition by a certain type of user

first switch (= disable profile editon)

Code: Select all

<!-- BEGIN switch_change_allowed -->
... (each input will be hidden and variable shown as text = no value)
example with username:
<input type="hidden" name="username" value="{USERNAME}"{DISABLE_CHANGE} /><b><span class="genmed">{USERNAME}</span></b>

type="hidden" = hidden field but always save :)
<span class="XX">Your text</span> to display the value of your hidden field

example with password:
<input type="hidden" name="password" value=""{DISABLE_CHANGE} /><span class="genmed"></span>
-> here no text for value, i'm sure you don't want to show you password to your moderators :)

<!-- END switch_change_allowed -->
second switch

Code: Select all

<!-- BEGIN switch_change_disallowed -->
... (= original code, no change except {DISABLE_CHANGE} for each input)
<!-- END switch_change_disallowed -->
this is the exact same code you have in your file
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

User avatar
C-3PO
Registered User
Posts: 264
Joined: Tue Jun 25, 2002 8:28 am
Location: Belgium

Post by C-3PO » Wed Oct 27, 2004 9:16 pm

I've had a look into the extra files inside this mod, but I can't get a clue on how to start and add another admin part. I want to make a mod admin panel for the smartor photo album, so mod's can add categories to the photoalbum and set their permissions.
Last edited by C-3PO on Thu Oct 28, 2004 7:37 am, edited 1 time in total.
My best friends: Knowledge Base & Search

[mez]
Registered User
Posts: 76
Joined: Sun Jun 20, 2004 12:50 pm
Location: Australia
Contact:

Post by [mez] » Wed Oct 27, 2004 9:52 pm

Famitsu: I have done what you said... "use the admin_ug_auth from MOD CP contrib folder and removed the line of code" then overwritten the old fil on my webspace and still no change.

User avatar
GurlzLubme
Registered User
Posts: 880
Joined: Wed Sep 01, 2004 11:21 am
Location: New York

Post by GurlzLubme » Thu Oct 28, 2004 10:47 am

I have installed the DHTML collapsable ACP mod... if I install your MCP mod, will it automatically adopt the DHTML collapsable menus as well?

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -&gt; see my signature to contact me
Contact:

Post by Famitsu » Fri Oct 29, 2004 1:16 am

@ C-3PO -> if you want to allow your moderators to have all options, just copy admin_album.php... and its _body.tpl in their respective directories (= modcp)

Then, there are some lines to edit in PHP file, example: page_header_mod.php instead of page_header_admin.php
path to template: modcp/... instead of admin/...

Take a look in the FAQ.txt, all you need is written


@ [mez] -> Could you send me a mail (same address) with all your files (modcp directory and template/fisubtext/modcp)
and also a link to download fisubtext template?


@ GurlzLubme -> by default i think no, but it will be easy to install your DHTML... mod for the ModCP, apply each step to the modcp... :)
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

[mez]
Registered User
Posts: 76
Joined: Sun Jun 20, 2004 12:50 pm
Location: Australia
Contact:

Post by [mez] » Fri Oct 29, 2004 6:32 am

Famitsu wrote: [mez] -> Could you send me a mail (same address) with all your files (modcp directory and template/fisubtext/modcp)
and also a link to download fisubtext template?


Sent!

User avatar
GurlzLubme
Registered User
Posts: 880
Joined: Wed Sep 01, 2004 11:21 am
Location: New York

Post by GurlzLubme » Fri Oct 29, 2004 7:22 pm

Famitsu wrote: @ GurlzLubme -> by default i think no, but it will be easy to install your DHTML... mod for the ModCP, apply each step to the modcp... :)



keeewwwllll... I'll try installing this later (after I get past my topic cement mod troubleshooting) :|

[mez]
Registered User
Posts: 76
Joined: Sun Jun 20, 2004 12:50 pm
Location: Australia
Contact:

Post by [mez] » Tue Nov 02, 2004 12:32 pm

Famitsu: After i added those files you gave me and then added those files to a new template i installed i still see the permissions problem i have. :cry:

I think ill just stick to making my mods use the Subsilver theme... unless there is a way to make the MOD CP only show the Subsilver theme... like override the modcp so that the mod cp is always subsilver theme?

User avatar
cwipperman
Registered User
Posts: 36
Joined: Wed May 01, 2002 9:40 am

Post by cwipperman » Wed Nov 03, 2004 9:59 pm

OK,

Couple of quick questions. I am running phpbb 2.0.4. So, will this mod not work on this version - or do I have to make some changes????

Second, I see the part about using this mod with a different theme - but I'm confused at something. Do you ONLY have to copy the files to the folder of the other theme - or do you also have to do that second step. That almost looks like a different process - and I can't tell if it's still required to get the modcp to run properly.

Thanks

**EDIT**

Well, I went ahead and upgraded to 2.0.10, and installed the panel. It's AWESOME!

Good work!

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -&gt; see my signature to contact me
Contact:

Post by Famitsu » Wed Nov 03, 2004 11:59 pm

@ [mez] -> you want to make me crazy :roll:
about the link group permissions, remove your files admin_ug_auth.php and admin_ug_auth_.php
add the file from the contrib/permissions directory, unzip in your modcp dir

each file with admin_xxxx.php will appear in the navigation panel of the ModCP
That worked for me with your files, so i don't know what i can do :(
cwipperman wrote: Well, I went ahead and upgraded to 2.0.10, and installed the panel. It's AWESOME!

Good work!
Thanks :)

To answer to your second question,
Non-subSilver template compliant: if you don't use admin_users.php module (= removed it), there is no file to edit
just replace templates files from the modcp by your own files from admin directory
otherwise you need to apply step 2, you can also use the users_edit_body included in the ModCP, but you won't have templates classes and colors (background, text-color,....) -> it will work
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

[mez]
Registered User
Posts: 76
Joined: Sun Jun 20, 2004 12:50 pm
Location: Australia
Contact:

Post by [mez] » Thu Nov 04, 2004 6:11 am

Famitsu wrote: @ [mez] -> you want to make me crazy :roll:
about the link group permissions, remove your files admin_ug_auth.php and admin_ug_auth_.php
add the file from the contrib/permissions directory, unzip in your modcp dir

each file with admin_xxxx.php will appear in the navigation panel of the ModCP
That worked for me with your files, so i don't know what i can do :(


I did this and then i get the thing where the whole screen (mod cp) is black again... :cry:

Post Reply

Return to “[2.0.x] MOD Database Cleanup”