[2.0.10] Bin

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
21
75%
Very Good
5
18%
Good
1
4%
Fair
0
No votes
Poor
1
4%
 
Total votes: 28

User avatar
Guernica
Registered User
Posts: 46
Joined: Sun Oct 01, 2006 2:33 pm
Contact:

Post by Guernica » Fri Nov 10, 2006 5:35 pm

3wheel wrote: Ok, I made a forum called "Bin" and I put the forum ID into the little box but when I press the recycle icon, it still says "Bin has been disabled"

What am I doing wrong!!! Can someone help me please... :(


I am having the exact same problem. =/

I am wondering, does this have anything to do with the SQL setup? When I put in the forum ID, and then check it to make sure it is still there, it is blank. Every time it just goes back to blank. And like wheel said, I get "Bin has been Disabled" when I try to bin a thread.

My forum:
http://www.myoosic.net/forum/
http://www.myoosic.net
Pfft, join newb!

User avatar
Guernica
Registered User
Posts: 46
Joined: Sun Oct 01, 2006 2:33 pm
Contact:

Post by Guernica » Wed Nov 15, 2006 1:31 am

can anyone help me on this? please? i have everything in correctly, and everything shows up, just doesnt let me make a forum a bin forum. :P
http://www.myoosic.net
Pfft, join newb!

cdllt
Registered User
Posts: 42
Joined: Wed Dec 22, 2004 3:01 am

Post by cdllt » Thu Nov 23, 2006 5:41 pm

Hi,
I have same problem as you are, that the field empty, even I enter forum ID = 60 which's the one I just created ! I went to phpAdmin and manually enter 60 to the field and # still now show up in ACP config, try to use Bin in view topic and still got this error " Bin has been disabled"

can anyone have Idea how to fix this? I really need this Mod working, I checked on install text and make sure everything I did is corrected

RiWiX
Registered User
Posts: 5
Joined: Mon Apr 21, 2008 1:34 pm

Re: [2.0.10] Bin

Post by RiWiX » Mon Apr 21, 2008 2:27 pm

Does anybody know how to do the bin button visible only for mods and admins? Not for users. They can't use it but they can see it... thanks.
Sorry for my English please... :-)

RiWiX
Registered User
Posts: 5
Joined: Mon Apr 21, 2008 1:34 pm

Re: [2.0.10] Bin

Post by RiWiX » Tue Apr 22, 2008 10:15 pm

I think that is in modcp.php but I don't know how to repair it, does somebody know?
Sorry for my English please... :-)

User avatar
orynider
Registered User
Posts: 169
Joined: Wed Nov 16, 2005 12:48 pm
Location: Arad, România
Name: Florin Bodin
Contact:

Re: [2.0.10] Bin

Post by orynider » Wed May 07, 2008 7:32 pm

You have a "if ( $is_auth['auth_mod'] )" switch so there is no way the option to be shown for normal users.

About second problem, the version posted here was not upgraded for phpBB 2.0.23 but I still have somewe a version upgraded for phpBB 2.0.22 who still work as intended if you someone need it...

Anyway, I use this mod to move files to Bin forum instead of deleteing them direct, so that users still have the option to delete messages and I still can have the posts or topics in a locked forum in case I whan't to decide to do someting else ;)

edit: Ah, I can't see any change in the text template, then this should work fine with 2.0.23 too.

RiWiX
Registered User
Posts: 5
Joined: Mon Apr 21, 2008 1:34 pm

Re: [2.0.10] Bin

Post by RiWiX » Sat May 17, 2008 11:05 am

But they really see it... Users aren't mods but they see this button. I tried lots of changes but nothing helps...
Sorry for my English please... :-)

User avatar
orynider
Registered User
Posts: 169
Joined: Wed Nov 16, 2005 12:48 pm
Location: Arad, România
Name: Florin Bodin
Contact:

Re: [2.0.10] Bin

Post by orynider » Wed May 28, 2008 11:44 pm

You don't need to edit anything just fix the users permissions.

RiWiX
Registered User
Posts: 5
Joined: Mon Apr 21, 2008 1:34 pm

Re: [2.0.10] Bin

Post by RiWiX » Sat May 31, 2008 12:59 pm

User can see, post, edit, post poll, standart functions... I tried to set edit only for mods but it didn't help...
Sorry for my English please... :-)

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20958
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [2.0.10] Bin

Post by RMcGirr83 » Sat May 31, 2008 1:14 pm

The button should only be availabe for viewing if the edits to viewtopic.php have been done correctly...namely

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
viewtopic.php

#
#-----[ FIND ]------------------------------------------
#
	$topic_mod .= "<a href=\"modcp.$phpEx?" . POST_TOPIC_URL . "=$topic_id&mode=split&sid=" . $userdata['session_id'] . '"><img src="' . $images['topic_mod_split'] . '" alt="' . $lang['Split_topic'] . '" title="' . $lang['Split_topic'] . '" border="0" /></a>&nbsp;';

#
#-----[ AFTER, ADD ]------------------------------------------
#
	// Start add - Bin Mod
	$topic_mod .= "<a href=\"bin.$phpEx?" . POST_TOPIC_URL . "=$topic_id&sid=" . $userdata['session_id'] . '"><img src="' . $images['topic_mod_bin'] . '" alt="' . $lang['Move_bin'] . '" title="' . $lang['Move_bin'] . '" border="0" /></a>&nbsp;';
	// End add - Bin Mod
It does not belong next to the edit, button or any other...the code in viewtopic.php that limits the authorizations to only those authorized for this button are set via this code

Code: Select all

$topic_mod = '';

if ( $is_auth['auth_mod'] )
{
	$s_auth_can .= sprintf($lang['Rules_moderate'], "<a href=\"modcp.$phpEx?" . POST_FORUM_URL . "=$forum_id&sid=" . $userdata['session_id'] . '">', '</a>');

	$topic_mod .= "<a href=\"modcp.$phpEx?" . POST_TOPIC_URL . "=$topic_id&mode=delete&sid=" . $userdata['session_id'] . '"><img src="' . $images['topic_mod_delete'] . '" alt="' . $lang['Delete_topic'] . '" title="' . $lang['Delete_topic'] . '" border="0" /></a>&nbsp;';

	$topic_mod .= "<a href=\"modcp.$phpEx?" . POST_TOPIC_URL . "=$topic_id&mode=move&sid=" . $userdata['session_id'] . '"><img src="' . $images['topic_mod_move'] . '" alt="' . $lang['Move_topic'] . '" title="' . $lang['Move_topic'] . '" border="0" /></a>&nbsp;';

	$topic_mod .= ( $forum_topic_data['topic_status'] == TOPIC_UNLOCKED ) ? "<a href=\"modcp.$phpEx?" . POST_TOPIC_URL . "=$topic_id&mode=lock&sid=" . $userdata['session_id'] . '"><img src="' . $images['topic_mod_lock'] . '" alt="' . $lang['Lock_topic'] . '" title="' . $lang['Lock_topic'] . '" border="0" /></a>&nbsp;' : "<a href=\"modcp.$phpEx?" . POST_TOPIC_URL . "=$topic_id&mode=unlock&sid=" . $userdata['session_id'] . '"><img src="' . $images['topic_mod_unlock'] . '" alt="' . $lang['Unlock_topic'] . '" title="' . $lang['Unlock_topic'] . '" border="0" /></a>&nbsp;';

	$topic_mod .= "<a href=\"modcp.$phpEx?" . POST_TOPIC_URL . "=$topic_id&mode=split&sid=" . $userdata['session_id'] . '"><img src="' . $images['topic_mod_split'] . '" alt="' . $lang['Split_topic'] . '" title="' . $lang['Split_topic'] . '" border="0" /></a>&nbsp;';
}
So either the authorizations are not set correctly or the edits to viewtopic.php were not done correctly.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

RiWiX
Registered User
Posts: 5
Joined: Mon Apr 21, 2008 1:34 pm

Re: [2.0.10] Bin

Post by RiWiX » Sat May 31, 2008 6:24 pm

Oh, thank You a lot! A have found the problem! I added the code before }, not behind it.
Thank You again! :D
Sorry for my English please... :-)

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20958
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [2.0.10] Bin

Post by RMcGirr83 » Sat May 31, 2008 9:29 pm

np...good luck!! :)
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Post Reply

Return to “[2.0.x] MOD Database Cleanup”

Who is online

Users browsing this forum: No registered users and 17 guests