[2.0.13] Separate Announcements and Sticky

The cleanup is complete. This forum is now read only.
Post Reply

Rating:

Excellent!
50
75%
Very Good
8
12%
Good
4
6%
Fair
2
3%
Poor
3
4%
 
Total votes: 67

skaloumbakas
Registered User
Posts: 179
Joined: Wed Sep 25, 2002 11:26 am
Location: Athens Hellas

Post by skaloumbakas » Sat Nov 13, 2004 5:57 pm

GurlzLubme wrote: ... NOW the topic cement works (in conjunction with Separate Mod)!! Back to batting 1000 now. haha thanks, Bard!


FOR ME TOOO. BOTH ARE WORKING (and the Global Ann too) (i am using phpBB 2.0.1...)
Christos Skaloumbakas

User avatar
Makc666
Registered User
Posts: 358
Joined: Fri Mar 07, 2003 12:03 pm
Location: MSK-RU
Name: Maxim
Contact:

Post by Makc666 » Sat Nov 13, 2004 7:05 pm

I figure is out for now.
It means that on every page of any particular forum I will see that topics.

I thought that GLOBAL means that some kind of Announcements must be seen on MAIN forum page. But as I didn't see it in code, that my question rised.

I think word "global" is not so cleare.

Thanks.
Aiencran wrote: Whay do you mean? I can't understand your question...
it's just a definition of a string for GlobalAnn section... it works even if you don't have installed Global Announcements' MOD

Aiencran
Registered User
Posts: 169
Joined: Fri Oct 01, 2004 10:10 am
Location: Italy
Contact:

Post by Aiencran » Sun Nov 14, 2004 11:32 am

Ah ok... I understood... I presume you should move this question to the Author of that MOD... Separate MOD changes only visualization in viewforum...
however, GLOBAL refers to the fact that a global announcements "belongs" to all the forums (even if it's not this way technically)... without using this MOD you should post the same msg in all the forums...
Showing them in MAIN page is only a layout issue... Global Hack creates the topic type, that is it affects the very internal structure of phpBB... the way of showing them in forum is a secondary issue in my opinion.... I hope I've been clear.. excuse me for my English :)
Aiencran

Etosch
Registered User
Posts: 3
Joined: Fri Dec 06, 2002 3:47 pm

Post by Etosch » Mon Nov 22, 2004 6:04 pm

I'm just a beginner in both - phpbb and moddig - so forgive me, if this is a really dump question :)

I applied this mod to a 2.0.10 version of phpbb with mod-topic_calendar-101 installed.

Everything else is original and the board worked fine with the calendar mod installed.

Now i get an error message:

Code: Select all

Parse error: parse error, unexpected T_LOGICAL_AND in /is/htdocs/35989/www.tradeskills.de/foren/ag/viewforum.php on line 309
with the code at this location looking like this:

Code: Select all

$sql = "SELECT t.*, u.username, u.user_id, u2.username as user2, u2.user_id as id2, p.post_time, p.post_username
	FROM " . TOPICS_TABLE . " t, " . USERS_TABLE . " u, " . POSTS_TABLE . " p, " . USERS_TABLE . " u2
	WHERE t.forum_id = $forum_id
		AND t.topic_poster = u.user_id
		AND p.post_id = t.topic_last_post_id
		AND p.poster_id = u2.user_id
        AND t.topic_type BETWEEN " . POST_STICKY . " AND " . POST_ANNOUNCE . "
        ORDER BY t.topic_type DESC, t.topic_last_post_id DESC ";
Any hints, how to correct this?

Thanks in advance,

Etosch

Aiencran
Registered User
Posts: 169
Joined: Fri Oct 01, 2004 10:10 am
Location: Italy
Contact:

Post by Aiencran » Tue Nov 23, 2004 1:45 am

Hmm... this code seems to be correct... perhaps the error is before...
Aiencran

Etosch
Registered User
Posts: 3
Joined: Fri Dec 06, 2002 3:47 pm

Post by Etosch » Tue Nov 23, 2004 9:38 am

LoL - my fault... one whole night spent, only to notice that i'm uploading the correct file to the wrong location - and at the correct location - there was a mistype in that file...

Never mind - and don't tell anyone - promise?

Cu, Etosch

Aiencran
Registered User
Posts: 169
Joined: Fri Oct 01, 2004 10:10 am
Location: Italy
Contact:

Post by Aiencran » Tue Nov 23, 2004 10:35 am

:)
Aiencran

fnzomaar
Registered User
Posts: 6
Joined: Wed Oct 20, 2004 10:16 pm

Post by fnzomaar » Tue Nov 23, 2004 2:45 pm

is it posible to get something like this?

:: Global Announcements ::
- All the global Announcements

:: Announcements Topics ::
- Announces

:: Sticky Topics ::
- Sticky Topics

:: Topics ::
- All the other topics

i mean separate sticky in an other table like the global announces

Aiencran
Registered User
Posts: 169
Joined: Fri Oct 01, 2004 10:10 am
Location: Italy
Contact:

Post by Aiencran » Tue Nov 23, 2004 4:44 pm

It's possible but adding some extra code.... it's not difficult... I need time however... alternatively you could install split topic type MOD, even if it's heavier...
Aiencran

fnzomaar
Registered User
Posts: 6
Joined: Wed Oct 20, 2004 10:16 pm

Post by fnzomaar » Thu Nov 25, 2004 9:14 pm

why did it posted 3 times?

nm look down
Last edited by fnzomaar on Mon Nov 29, 2004 8:02 am, edited 1 time in total.

fnzomaar
Registered User
Posts: 6
Joined: Wed Oct 20, 2004 10:16 pm

Post by fnzomaar » Thu Nov 25, 2004 9:16 pm

post remove
Last edited by fnzomaar on Mon Nov 29, 2004 8:03 am, edited 1 time in total.

fnzomaar
Registered User
Posts: 6
Joined: Wed Oct 20, 2004 10:16 pm

Post by fnzomaar » Thu Nov 25, 2004 9:16 pm

it messes up my codes to much, thats why i asked for this. easyer for all these mods that are already installed ;)

But take ur time

User avatar
onigumo
Registered User
Posts: 1755
Joined: Fri Oct 31, 2003 2:32 am
Contact:

Post by onigumo » Sat Jan 08, 2005 5:28 am

Announcements and Stickies should be seperated. When I'm told how or such a feature is added, I'll install this MOD.
I write articles on community building
@ The Infinity Program.

jupro
Registered User
Posts: 273
Joined: Sat Jun 12, 2004 8:26 am

separate mod only affecting admin's view

Post by jupro » Fri Jan 21, 2005 5:18 am

Hi there,

I recently installed "SeparateAnnouncementAndSticky" mod.

It seemed to work fine, but then I realized...

If I log in as the administrator, everything looks fine, but if I log in as a regular user, there is no separation b/w any of the posts, whether they are global, announcements, sticky, or just regular topics.

very strange.

I am using phpbb 2.0.11, and I have installed the following mods:
  • Admin_Userlist_202
  • advanced_user_search1.0.2-r2
  • global_announcement_1.2.8em
  • Resize_Posted_Images_Based_on_Max_Width
  • signatures_control1.2.1em
I have no idea what is going on here...

Does anyone have any suggestions?

Thanks very much

Aiencran
Registered User
Posts: 169
Joined: Fri Oct 01, 2004 10:10 am
Location: Italy
Contact:

Post by Aiencran » Fri Jan 21, 2005 10:18 am

I've no idea... we should see your viewforum.php and/or viewforum_body.tpl. You can send me these files in a pm so I check them...
Aiencran

Post Reply

Return to “[2.0.x] MOD Database Cleanup”