[2.0.10] HTML BBcode MOD

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
33
87%
Very Good
2
5%
Good
1
3%
Fair
2
5%
Poor
0
No votes
 
Total votes: 38

pillets
Registered User
Posts: 6
Joined: Sun Apr 30, 2006 12:36 am

Post by pillets » Tue May 30, 2006 12:44 am

I have installed BBCODE organizer and i always have it.

Just for the post with html BBcode. For the others i have no problem

You can see what its does exactely :
---(((PHOTO 1)))---
Image

---(((PHOTO 2)))---
Image

The post is review two time ?

Jynks
Registered User
Posts: 242
Joined: Fri May 23, 2003 7:41 am

Post by Jynks » Tue May 30, 2006 1:23 pm

Is there a wat that I can modify the files in tihsmod so i can simple make a PHP page on my fourm that can embed a html file into it?

Basicaly I have made a new page for my fourm that utilized all the login and user rights stuff for viewing. I am using the below code.

Code: Select all

<?php

define('IN_PHPBB', true);
$phpbb_root_path = '../yourphpbbfolderhere'; // edit this to reflect where your phpbb is installed
include($phpbb_root_path . 'extension.inc');
include($phpbb_root_path . 'common.'.$phpEx);

//
// Start session management
//
$userdata = session_pagestart($user_ip, PAGE_INDEX);
init_userprefs($userdata);
//
// End session management
//
//
// Start output of page
//
$page_title = "TITLE HERE!";
include($phpbb_root_path . 'includes/page_header.'.$phpEx);



?>

<!-- HTML STARTS -->
put your html here
<!-- HTML ENDS -->

<?php


include($phpbb_root_path . 'includes/page_tail.'.$phpEx);
?>
What I am trying to do is simple embed a html page inside the php page.

So I have the header and the footer of the fourm and load up an existing html file from my server. I need to do this as the html file is constantly updated with an automatic proccess. So having a php page that is functional with the fourm would b great, but for it to load up the html file as a source.

I have trued sing <frames> but they do nto seam to work.

markus_petrux
Former Team Member
Posts: 1887
Joined: Wed Apr 23, 2003 7:11 am
Location: Girona, Catalunya (Spain)
Contact:

Post by markus_petrux » Fri Jun 02, 2006 5:22 pm

@Jynks: You can simply use include ;)

@pillets: I'm sorry to say that I don't get the problem by looking at your screenshots. :? do you have a link? That is not a warranty but it may help.

Anyway, the MOD works, so it might be a mistake when applying the changes. It happens, specially if you did it manually, try checking the changes made again.

...or it might be a conflict with something different in your theme.

Do you have any other BBCode MOD installed? If not, try unistalling the HTML BBCode and install another BBCode (f.e the Google BBCode). If the problem persists, then it might be something weird with the Multiple BBCode or the Buttons Organizer MODs.
EasyMOD Standards | MOD Template Actions | MODs in Development Rules
Useful information for MOD Authors | MOD Queue Stats | Search MODs
Write SQL/DDL portable to all SQL servers supported by phpBB!
Get EasyMOD 0.3.0! | Suport al phpBB en Català!
8)

pillets
Registered User
Posts: 6
Joined: Sun Apr 30, 2006 12:36 am

Post by pillets » Fri Jun 02, 2006 10:26 pm

hi
You can reply to this post without subscribe to see what happen

http://islam-fr.com/forum/viewtopic.php?t=9

But if you go to this post http://islam-fr.com/forum/viewtopic.php?t=12 you don't have the problem (?)

I have installed first the multiple bbcode, then the HTML bbcode, then Buttons organizer, but not another bbcode. I have made all that manually but its seems no problem in the code.

Like you can see, there is problem with {TOPIC_REVIEW_BOX}

Thanks you.

markus_petrux
Former Team Member
Posts: 1887
Joined: Wed Apr 23, 2003 7:11 am
Location: Girona, Catalunya (Spain)
Contact:

Post by markus_petrux » Fri Jun 02, 2006 11:41 pm

There are several errors in your HTML pages. Examples:

28 errors checking islam-fr.com/forum/viewtopic.php?t=9
17 errors checking islam-fr.com/forum/posting.php?mode=reply&t=9

Some of those errors might be causing that problems.

You seem to have other MODs installed, maybe a mistake in one of them. But this is not caused by the HTML BBCode itself.
I have installed first the multiple bbcode, then the HTML bbcode, then Buttons organizer

Nope. Try installing: first the Multiple BBCode, then Buttons Organizer and then any other BBCode.

Sorry, I can help you further than that.
EasyMOD Standards | MOD Template Actions | MODs in Development Rules
Useful information for MOD Authors | MOD Queue Stats | Search MODs
Write SQL/DDL portable to all SQL servers supported by phpBB!
Get EasyMOD 0.3.0! | Suport al phpBB en Català!
8)

pillets
Registered User
Posts: 6
Joined: Sun Apr 30, 2006 12:36 am

Post by pillets » Sat Jun 03, 2006 7:51 pm

markus_petrux wrote: [...]
Sorry, I can help you further than that.


Ok thanks you.

haalaaluu
Registered User
Posts: 5
Joined: Mon Jun 06, 2005 6:50 am
Contact:

Post by haalaaluu » Mon Jun 12, 2006 6:18 pm

Code: Select all

#
#-----[ SQL ]-------------------------------------------------
#
#  REMINDER --- Make backups BEFORE installing MODs
#
INSERT INTO phpbb_config (config_name, config_value) VALUES ('bbcode_html_group', '-1');
If i took out this part and install with Easymod, then it can process. So, i have to alter through phpMyAdmin for this.

All lastest source, and just fresh install at this site.

:D

joeydee
Registered User
Posts: 292
Joined: Tue Mar 07, 2006 2:05 am

Post by joeydee » Mon Jun 12, 2006 10:18 pm

Hello,

I have a question about how to change the BBCODE panel color.. for example look at this screenshot on my forum i woud like to change it from the existing color which is grey to a clear white. Can someone give me tips please?

http://i39.photobucket.com/albums/e197/ ... bccode.png

Thank you kindly
Joey Dee

pietropaolo
Registered User
Posts: 8
Joined: Mon Jan 30, 2006 5:17 pm

Re: [2.0.10] HTML BBcode MOD

Post by pietropaolo » Thu Jun 15, 2006 10:32 am

Dear Sirs,
I installed succesfully easymod.
When installation asked the FTP way to my PHPBB forum I wrote:
/forim.
then I insert the FTP username and FTP password.

Now easymod is installed and into the admin menu there are 3 easymod choices.
But nothing choice (installing, history and setting) work .
The link of the choices are:

http://www.mysite.com/forum/admin/admin ... 64bd191138

http://www.mysite.com/forum/admin/admin ... 64bd191138

http://www.mysite.com/forum/admin/admin ... 64bd191138

But nothing work because the link do not find the adress

It is also impossible to reinstall easymod because I have the 3th.choice (setting) that not answer like others.

Please can you help me ?

regards

Paolo

User avatar
TurtleX
Registered User
Posts: 245
Joined: Sat Apr 24, 2004 9:19 pm

Post by TurtleX » Mon Jun 19, 2006 7:37 pm

Works in 2.0.21! Thanks.

danko
Registered User
Posts: 25
Joined: Wed Dec 24, 2003 8:16 am

Post by danko » Tue Jul 18, 2006 10:03 am

markus_petrux wrote: Known Issues:
  • Problem: If you're using phpBB 2.0.20 (and up), you may find that HTML tags and/or attributes aren't displayed, even when using the HTML BBCode.

    Workaround: Go to your AdminCP / General Admin / Configuration, scroll down and set the option "Allow HTML" to No.

Is there a way to avoid/fix this problem without disabeling the "allow html" function?

tight now my users cant user some html-tags...

markus_petrux
Former Team Member
Posts: 1887
Joined: Wed Apr 23, 2003 7:11 am
Location: Girona, Catalunya (Spain)
Contact:

Post by markus_petrux » Tue Jul 18, 2006 11:37 am

Sorry, not at this moment. It's not a good idea to let your users use HTML tags directly. It's been changed (restricting functionality) in the past by phpBB itself due to security issues.

I would suggest to replace that functionality by adding BBCodes, it's more secure.
EasyMOD Standards | MOD Template Actions | MODs in Development Rules
Useful information for MOD Authors | MOD Queue Stats | Search MODs
Write SQL/DDL portable to all SQL servers supported by phpBB!
Get EasyMOD 0.3.0! | Suport al phpBB en Català!
8)

spoonium
Registered User
Posts: 2
Joined: Fri Sep 08, 2006 12:22 pm

Post by spoonium » Fri Sep 08, 2006 12:29 pm

I wanted to install this mod into my phpBB2 Plus installation.
I was somehow successful, as the site founder I can now post [html] code.
Yet I cannot enable other users/groups to be allowed as well, since for the life I seem unable to access the conifuration in the ACP.

I could not fully implent this mod into my installation, since phpBB2 plus doesn't seem to have EMBB installed. Yet as far as I could tell from the code, EMBB only provides the HTML button while writing a posting.
The function itself works without making the according modification, i.e. I can flawlessly post in html using the [html] tag.

Really, the only problem is assigning the rights to other users. The option just won't show up.

Could you give me a hint on where to look so that maybe I find a way?
An SQL statement to add a specific group to the allowed groups would also be enough, since it's basically only one group that needs these rights.

Thanks in advance.


*** edit
Whoa. Disregard my question.
I had a backup copy of my admin_board.php named admin_board.ori.php in my admin folder.
And phpbb was chosing the backup copy over my actual "normal" admin_board.php, so I was always accessing the unedited admin_board.ori.php.
I have now renamed that file and everything works fine.
Can't believe that sort or c*ap took me 2 days to figure out and only AFTER I had posted here...

Works like a charm now. Except the html button, which I don't need anyway. :)

recoha
Registered User
Posts: 1
Joined: Tue Sep 12, 2006 8:33 pm
Contact:

Post by recoha » Tue Sep 12, 2006 8:38 pm

mans sorry my english... i'am braziliam :P

i instaled HTML BBcode in my forum version 2.0.21!!
ok, but only founder can post [html] tags!! and in ACP no have menu drop down for select who can use the html tags...

somebody help me?

thx!

Ryan O
Registered User
Posts: 3
Joined: Thu Apr 07, 2005 9:30 pm
Location: San Diego
Contact:

Re: PLEASE HELP WITH THIS !!!!!!

Post by Ryan O » Wed Sep 13, 2006 4:23 am

David Pook wrote: Guys,

I downloaded and installed Multi BB code MOD v1.04

I downloaded and installed HTML BB code MOD v1.1.4

Updated my SQL as indicated, read the text document informing me about the main board administrator number changing ie:

Code: Select all

define('USER', 0); 
define('ADMIN', 1); 
define('MOD', 3); 
//+MOD: HTML BBCode MOD 
define('FOUNDER', 3);   // If needed, you can change 2 to the user_id of your main board admin. 
//-MOD: HTML BBCode MOD 
My main admin is not number 3 as i wanted one of my users to have access to HTML BB codes so i took his number (3) and changed it accordingly in the code above.

It didnt work

My question is this.... have i done this correctly OR have i missed something ? I have followed the install and change of files very meticulously and i dont have any errors on the pages etc

Could someone help me out with this please ?..... I apologise if this is in the wrong category on this forum.


By the way.... I dont have visible [html] [/html] codes above the posting box as you do for say.... [img] [/img]
Was I supposed to get this after installing the MODS or not ????


In a similar vein, I am basically *the* admin of the forum, the guy who really owns it all is rarely around. As such I have FTP access and essentially run all aspects of the board. The rub here is that I have no idea how to glean the user_id to find out what mine is so that I can alter constants.php and have the HTML mod work in the first place. Until I know what my own user_id is, I'm tanked pretty much. I've googled to no avail, so I feel pretty dumb right now. Someone enlighten me please?

Edit: So I've been helped to figure out my user_id. That's good. Bad thing is, I tried changing the variable in constants.php to reflect my user_id and then installed the HTML MOD without luck, as I saw no new option to enable HTML tags. Any ideas as to what I may have done wrong?

Post Reply

Return to “[2.0.x] MOD Database Cleanup”