[2.0.12] Hide Zero Posters

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
13
65%
Very Good
2
10%
Good
0
No votes
Fair
2
10%
Poor
3
15%
 
Total votes: 20

User avatar
Alundra
Registered User
Posts: 125
Joined: Sat Mar 18, 2006 12:56 pm
Location: Aussie in the USA
Contact:

Re: [2.0.12] Hide Zero Posters

Post by Alundra » Fri Jul 13, 2007 8:44 pm

lol
i did that. its done but when i tried to install the hierarchy thing it said
Could not open [includes/functions_categories_hierarchy.php] for reading.
it doesnt exist in the mod folder, or my phpBB folder.
what can i do?

User avatar
TerraFrost
Former Team Member
Posts: 5957
Joined: Sun Dec 26, 2004 3:40 am
Location: Austin, TX

Re: [2.0.12] Hide Zero Posters

Post by TerraFrost » Tue Jul 17, 2007 3:46 am

Alundra wrote:lol
i did that. its done but when i tried to install the hierarchy thing it said
Could not open [includes/functions_categories_hierarchy.php] for reading.
it doesnt exist in the mod folder, or my phpBB folder.
what can i do?
It's likely that a later version of the Categories Hierarchy mod removed that file. Unfortunately, I don't have the time, right now, to get it to work, either. Maybe someone on Ptirhiik's board can help you out. Good luck!

User avatar
Alundra
Registered User
Posts: 125
Joined: Sat Mar 18, 2006 12:56 pm
Location: Aussie in the USA
Contact:

Re: [2.0.12] Hide Zero Posters

Post by Alundra » Wed Jul 18, 2007 5:52 pm

it doesnt matter. i got a mod called actual posters, which does the job and more.

User avatar
Lyoness
Registered User
Posts: 12
Joined: Mon Apr 11, 2005 8:40 am

Re: [2.0.12] Hide Zero Posters

Post by Lyoness » Thu Sep 13, 2007 3:15 am

Hi there,

Like many users that have posted, I'm trying to install this mod and get the following message when using EasyMod:
SQL PROCESSING HALTED

An error was encountered while processing the SQL commands. Further SQL processing has been halted. You may choose to complete the MOD installation anyway and perform the SQL commands manually yourself. However, at this point EM cannot guarantee the MOD will work correctly so you are best off seeking support from the Author before continuing further.

The failed line was:

UPDATE users AS u,posts AS p1 LEFT OUTER JOIN posts AS p2 ON p1.poster_id = p2.poster_id AND p2.post_time < p1.post_time INNER JOIN posts AS p3 ON p3.post_time = p1.post_time SET u.user_firstpost=p3.post_time WHERE p2.post_time IS NULL AND p1.poster_id = u.user_id;;


SQL ERROR: 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '; p1.post_time INNER JOIN posts AS p3 ON p3.post_time = p1.post_time SET u.user_' at line 1
So I tried to run the query in phpmyadmin (granted I may have done it wrong because I'm not too experienced with doing this). I basically logged into phpmyadmin, chose the database I wanted to use (gamerwidow_phpbb) and clicked on the SQL tab. Then I pasted this:

Code: Select all

UPDATE phpbb_users AS u, phpbb_posts AS p1
   LEFT OUTER JOIN
   phpbb_posts AS p2
   ON p1.poster_id = p2.poster_id AND
      p2.post_time < p1.post_time
   INNER JOIN
   phpbb_posts AS p3
   ON p3.post_time = p1.post_time
SET u.user_firstpost=p3.post_time
WHERE p2.post_time IS NULL AND
   p1.poster_id = u.user_id;
and clicked on OK.

I got this error :( :
import.php: Missing parameter: import_type (FAQ 2.8)
import.php: Missing parameter: format (FAQ 2.8)
:cry:
I noticed no one has posted this type of error yet. Can you help me please?

User avatar
Lyoness
Registered User
Posts: 12
Joined: Mon Apr 11, 2005 8:40 am

Re: [2.0.12] Hide Zero Posters

Post by Lyoness » Thu Sep 13, 2007 3:51 am

Okay I kept at it and analysed the SQL more closely and I realized that I was trying to run it in the users table instead of at the database level. So I ran it from there, got that weird error about not finding something or other and remembered that it was the prefix (my tables aren't phpbb_users but users) so I modified the code there and VOILA! It now works!!

Wow my membercount went from over 3000 to just over 900. So sad that so many accounts are spam. :(

My only issue is that I was the first member to join but it's showing another member as #1 and I know this issue was addressed earlier in the thread so I'll go look for a solution for that now.

Thanks Terra! :D

User avatar
Lyoness
Registered User
Posts: 12
Joined: Mon Apr 11, 2005 8:40 am

Re: [2.0.12] Hide Zero Posters

Post by Lyoness » Thu Sep 13, 2007 4:23 am

yay I found the fix (the one about not changing a few of the lines in the membership.php file) and it works great!!! :D

Now to find a mod that restricts new users from posting urls. God I hate spammers!!

StarrC
Registered User
Posts: 1
Joined: Thu Nov 08, 2007 6:14 am

Re: [2.0.12] Hide Zero Posters

Post by StarrC » Thu Nov 08, 2007 6:22 am

I installed this MOD and now I am receiving the following error code on my board when trying to post or delete existing posts: Parse error: syntax error, unexpected $end in /home/parapath/public_html/forum/includes/functions_post.php on line 922

Can someone please help me fix this?

User avatar
TerraFrost
Former Team Member
Posts: 5957
Joined: Sun Dec 26, 2004 3:40 am
Location: Austin, TX

Re: [2.0.12] Hide Zero Posters

Post by TerraFrost » Thu Nov 08, 2007 6:12 pm

Can you post that file? It's hard to say anything without being able to see it...

brokensword
Registered User
Posts: 10
Joined: Sun Jan 13, 2008 11:58 pm

Re: [2.0.12] Hide Zero Posters

Post by brokensword » Tue Jan 29, 2008 3:37 pm

Hello,

I've been reading and am new to phpBB code. I've tried to run this Mod and encountered this error which says I should seek some help from the author. So, below is the message. Could you advise how I'm to proceed?


SQL PROCESSING HALTED

An error was encountered while processing the SQL commands. Further SQL processing has been halted. You may choose to complete the MOD installation anyway and perform the SQL commands manually yourself. However, at this point EM cannot guarantee the MOD will work correctly so you are best off seeking support from the Author before continuing further.

The failed line was:

ALTER TABLE phpbb_users ADD user_firstpost INTEGER(11) NOT NULL;;


SQL ERROR: 1060
Duplicate column name 'user_firstpost'



(This is what the script attempted to do, per my EM cPanel window;)



ALTER TABLE phpbb_users ADD user_firstpost INTEGER(11) NOT NULL;;

FAILED


UPDATE phpbb_users AS u,phpbb_posts AS p1 LEFT OUTER JOIN phpbb_posts AS p2 ON p1.poster_id = p2.poster_id AND p2.post_time < p1.post_time INNER JOIN phpbb_posts AS p3 ON p3.post_time = p1.post_time SET u.user_firstpost=p3.post_time WHERE p2.post_time IS NULL AND p1.poster_id = u.user_id;;

Not Attempted


UPDATE phpbb_users SET user_firstpost = user_regdate WHERE user_posts <> 0 AND user_firstpost = 0;;

Not Attempted


INSERT INTO phpbb_config(config_name,config_value) VALUES('zero_count',1),('zero_newest',1),('zero_group',1),('zero_list',1);;



Thank you in advance for any further insight.

Michael

User avatar
TerraFrost
Former Team Member
Posts: 5957
Joined: Sun Dec 26, 2004 3:40 am
Location: Austin, TX

Re: [2.0.12] Hide Zero Posters

Post by TerraFrost » Thu Apr 24, 2008 8:45 pm

Sorry for the delay - I don't check the MOD Database Cleanup forum much.

Anyway, it looks like you already have a user_firstpost column. My guess would be that you've, in fact, already ran the SQL, too.

So, try it without the SQL.

Post Reply

Return to “[2.0.x] MOD Database Cleanup”

Who is online

Users browsing this forum: No registered users and 9 guests