[2.0.11] Redirect User Fix

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
14
45%
Very Good
2
6%
Good
2
6%
Fair
0
No votes
Poor
13
42%
 
Total votes: 31

phantomk
Registered User
Posts: 1039
Joined: Wed Apr 14, 2004 5:32 am
Location: Canada Eh?
Name: Daniel Lee
Contact:

Post by phantomk » Mon Aug 29, 2005 9:36 am

It does work, it just has an issue with email notification.

vossen
Registered User
Posts: 123
Joined: Thu Aug 21, 2003 9:11 am

Post by vossen » Mon Aug 29, 2005 4:25 pm

i'm sorry, i did not know, that a new mod is allowed to damage a other function(or mod) in the phpbb forum. i allways learn and take it in concideration, for the future.
so each mod release in phpbb, can damage something else.


:roll:

Peter77s
Registered User
Posts: 260
Joined: Fri Sep 17, 2004 8:18 pm
Location: Michigan

Post by Peter77s » Sun Sep 04, 2005 7:08 am

Do a seach for Redirection Suite ... that mod worked for me!

dj.retcon
Registered User
Posts: 1
Joined: Sat Sep 17, 2005 1:23 am
Location: Seattle, WA
Contact:

Another break, Mail2Forum

Post by dj.retcon » Sat Sep 17, 2005 1:47 am

Found another MOD that Redirect User Fix 1.0.0 breaks: Mail2Forum v1.1.3c.

Installed in this order:
  1. New clean phpBB v2.0.17
  2. easyMOD v0.2.1a
  3. Mail2Forum v1.1.3c
  4. Redirect User Fix 1.0.0
As soon as Redirect User Fix was installed, I could no longer get M2F to generate e-mail from forum posts, either new topic, new reply or editing existing posts. All other functions would work, including creating new topics from e-mail sent to the mailing list and threading posts generated from e-mail into exisiting topics. Only after removing the Redirect User Fix MOD did I regain full M2F functions.

Since many others have pointed to the alternate Redirection Suite, will be checking that out and seeing if it can't co-exist peacefully with M2F.

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP » Sat Sep 17, 2005 2:38 am

I posted in the wrong place. Please delete this message...

:oops:

Capmaster
Registered User
Posts: 69
Joined: Tue Jul 05, 2005 1:26 pm

Post by Capmaster » Tue Sep 20, 2005 1:52 pm

We have discovered a problem with this mod. It affects the unread posts flag set for forums and topics. You can just view or post in a topic and it remains set to "unread posts". Sometimes right away and sometimes after you leave the site and return.

We saw this problem on two separate forums in subdomains on my site, and another completely unrelated site. All three have varying levels of number of hacks installed.

We thought the problem was cookie settings, but nothing seemed to work. Finally we uninstalled this mod and the problem went away. Strangely, on my main forum I have this hack still installed and have never had trouble :?

I thought I'd mention it here in case someone else experiences the same problem.
Image
Some mornings, it's just not worth chewing through the leather straps

Madball
Registered User
Posts: 16
Joined: Wed Feb 23, 2005 11:57 pm

Post by Madball » Wed Nov 09, 2005 6:24 am

YES THIS MOD IS FLAWED, IT MAKES MESSAGES APPEAR AS UNREAD (EVEN AFTER YOU HAVE READ THEM) AFTER YOU POST A MESSAGE.

Use this mod: http://www.phpbbhacks.com/download/550
Unzip and use the redirect_post.txt

It does what this mod was supposed to do but without this annoying problem.

micato
Registered User
Posts: 2
Joined: Thu Nov 03, 2005 12:16 pm
Contact:

Post by micato » Wed Nov 09, 2005 6:01 pm

Ótimo post !! :) Quebrou um galhão !

Lucas Malor
Registered User
Posts: 143
Joined: Tue Jun 28, 2005 7:12 pm
Contact:

Post by Lucas Malor » Mon Nov 14, 2005 11:16 am

Little bug: the mod does not redirect to the post, but to the start of the page.

itzamia
Registered User
Posts: 37
Joined: Tue Nov 22, 2005 3:13 am

Post by itzamia » Wed Nov 30, 2005 7:53 pm

I'd love to get rid of the 'Successfully Entered' screen, but since the MOD appears to be a bit buggy, it makes sense to me to set the 3 seconds to 0 seconds until someone comes up with something better, as stated here:
I've therefore uninstalled the mod, and changed the redirect time (which was set to 3 seconds) to 0. Now the redirect pages flashes up only momentarilly. Not ideal, but it'll do for now until I find a better mod. One that works.


The problem for me, is WHERE to change it?

Thanks,

mia

PKfanSteph
Registered User
Posts: 15
Joined: Thu Mar 11, 2004 8:07 am
Contact:

Post by PKfanSteph » Sat Dec 03, 2005 5:31 am

itzamia wrote: The problem for me, is WHERE to change it?


I spent an entire day trying to figure out what was wrong with my topic reply function. Great idea...but it needs some work.

I'm no PHP expert, but the following should work to change the time:

In "includes/functions_post.php", find:

Code: Select all

$meta = '<meta http-equiv="refresh" content="3;url=' . append_sid("viewtopic.$phpEx?" . POST_POST_URL . "=" . $post_id) . '#' . $post_id . '">'; 
and replace it with:

Code: Select all

$meta = '<meta http-equiv="refresh" content="0;url=' . append_sid("viewtopic.$phpEx?" . POST_POST_URL . "=" . $post_id) . '#' . $post_id . '">'; 
That should be slightly less annoying.

itzamia
Registered User
Posts: 37
Joined: Tue Nov 22, 2005 3:13 am

That Did It!

Post by itzamia » Tue Dec 06, 2005 3:53 am

Steph,

So sorry to hear that you spent a whole day working on this... but delighted that you've shared the 'fix.'

I've just followed your instructions, and I can verify that the obnoxious popup only lasts a split second now.

THANK YOU!

mia

User avatar
felipe
Registered User
Posts: 112
Joined: Wed Dec 21, 2005 6:12 am
Contact:

Post by felipe » Fri Dec 30, 2005 3:22 am

Madball wrote: YES THIS MOD IS FLAWED, IT MAKES MESSAGES APPEAR AS UNREAD (EVEN AFTER YOU HAVE READ THEM) AFTER YOU POST A MESSAGE.

Use this mod: http://www.phpbbhacks.com/download/550
Unzip and use the redirect_post.txt

It does what this mod was supposed to do but without this annoying problem.


Does this mean that the original MOD is not worth d/loading? Does the link to this new MOD work well? I don't like the time change from 3 seconds to 0 seconds, because this does not avoid the page, it only reduces the time it is exposed. i would like to completely remove that page, totally prevent it from appearing. And redirect the user directly to *their* post. I'm still looking for a hack/MOD that does all of these things. EMC would be a bonus, but not a necessity.

It seems most people aren't happy with *this* mod.
Felipe Alvarez's website

User avatar
drumstix42
Registered User
Posts: 1100
Joined: Tue Sep 24, 2002 11:01 pm
Location: NJ
Contact:

Post by drumstix42 » Sat Dec 31, 2005 5:31 am

Yes, I wouldn't recommend using *this* mod. And the link that is posted there works great.
Need a phpBB update or mod installed? PM me for any questions and pricing!
HostMonster.com (Unlimited Space, Unlimited Transfer, Unlimited Domains, $6.95/month )

User avatar
Agnostik
Registered User
Posts: 145
Joined: Sat Oct 12, 2002 2:07 pm
Contact:

Post by Agnostik » Tue May 02, 2006 3:23 pm

I believe this MOD (Redirect User Fix 1.0) broke the Attachment MOD on my board.

Post Reply

Return to “[2.0.x] MOD Database Cleanup”