[2.0.13] Forum Watch

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
32
78%
Very Good
3
7%
Good
3
7%
Fair
0
No votes
Poor
3
7%
 
Total votes: 41

JEM
Registered User
Posts: 81
Joined: Mon Aug 16, 2004 7:15 pm

Post by JEM » Fri Sep 09, 2005 7:46 pm

true statement!

I thought upgrading my forum version would be difficult but it really wasn't.

Thanks.

rossmpersonal
Registered User
Posts: 2
Joined: Tue Sep 20, 2005 8:43 pm

Is Forum Watch Compatible with phpBB 2.0.17 ?

Post by rossmpersonal » Tue Sep 20, 2005 8:47 pm

Is Forum Watch Compatible with phpBB 2.0.17 ?

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP » Tue Sep 20, 2005 9:45 pm

It works fine on my 2.0.17 board, so I would have to say YES!!!

:lol:

Sallala
Registered User
Posts: 1
Joined: Tue Oct 04, 2005 11:51 pm

Bug in Forum Watch Topic Add on 1.0.2 mod?

Post by Sallala » Tue Oct 04, 2005 11:58 pm

In the file:
Forum-Watch-Topic-1.0.2.mod
that I downloaded

there is:

Code: Select all

...
		do
		{
			if ($row['user_email'] != '')
			{
				$bcc_list_ary[$row['user_lang']][] = $row['user_email'];
			}
			$update_watched_sql .= ($update_watched_sql != '') ? ', ' . $row['user_id'] : $row['user_id'];
		}
		while ($row = $db->sql_fetchrow($result));
#
#-----[ AFTER, ADD ]------------------------------------------
#

		$sql_priority = (SQL_LAYER == "mysql") ? "LOW_PRIORITY" : '';
				$sql = "INSERT $sql_priority INTO " . TOPICS_WATCH_TABLE . " (user_id, topic_id, notify_status)
					VALUES (" . $row['user_id'] . ", $topic_id, 0)";
		$new_result = $db->sql_query($sql);
...
But I think, the correct install code is that:

Code: Select all

...
		do
		{
			if ($row['user_email'] != '')
			{
				$bcc_list_ary[$row['user_lang']][] = $row['user_email'];
			}
			$update_watched_sql .= ($update_watched_sql != '') ? ', ' . $row['user_id'] : $row['user_id'];


#
#-----[ AFTER, ADD ]------------------------------------------
#

		$sql_priority = (SQL_LAYER == "mysql") ? "LOW_PRIORITY" : '';
				$sql = "INSERT $sql_priority INTO " . TOPICS_WATCH_TABLE . " (user_id, topic_id, notify_status)
					VALUES (" . $row['user_id'] . ", $topic_id, 0)";
		$new_result = $db->sql_query($sql);
		}
...
Deleted the row:

Code: Select all

		}
while ($row = $db->sql_fetchrow($result));
In this case, the additional code will be in the do..while part.



Thank you this mod for the author!
Now, I can use PHPBB as a fully functional workflow system.

andyng
Registered User
Posts: 29
Joined: Sun Jun 20, 2004 7:59 am

Post by andyng » Fri Oct 14, 2005 7:03 am

Hi,

I came in late in this topic and my phpbb 2.0.17 was just install 2 weeks ago. The forum I am running is a private closed board for classmate. Register users should not be more than 20. Is it possible to set the default that everytime a Topic is created it will send a mail notification to all register users.

That would be great as the board are not too active in the beginning and after a couple of time loging in and find nothing the users would not logon on at all. That way everyone would know that something is created and they would logon to watch and reply.

Regards
Andy Ng

imrich
Registered User
Posts: 237
Joined: Tue Nov 09, 2004 9:52 pm

Re: Bug in Forum Watch Topic Add on 1.0.2 mod?

Post by imrich » Fri Oct 14, 2005 11:38 am

Sallala wrote: In the file:
Forum-Watch-Topic-1.0.2.mod
that I downloaded

there is:

Code: Select all

...
		do
		{
			if ($row['user_email'] != '')
			{
				$bcc_list_ary[$row['user_lang']][] = $row['user_email'];
			}
			$update_watched_sql .= ($update_watched_sql != '') ? ', ' . $row['user_id'] : $row['user_id'];
		}
		while ($row = $db->sql_fetchrow($result));
#
#-----[ AFTER, ADD ]------------------------------------------
#

		$sql_priority = (SQL_LAYER == "mysql") ? "LOW_PRIORITY" : '';
				$sql = "INSERT $sql_priority INTO " . TOPICS_WATCH_TABLE . " (user_id, topic_id, notify_status)
					VALUES (" . $row['user_id'] . ", $topic_id, 0)";
		$new_result = $db->sql_query($sql);
...
But I think, the correct install code is that:

Code: Select all

...
		do
		{
			if ($row['user_email'] != '')
			{
				$bcc_list_ary[$row['user_lang']][] = $row['user_email'];
			}
			$update_watched_sql .= ($update_watched_sql != '') ? ', ' . $row['user_id'] : $row['user_id'];


#
#-----[ AFTER, ADD ]------------------------------------------
#

		$sql_priority = (SQL_LAYER == "mysql") ? "LOW_PRIORITY" : '';
				$sql = "INSERT $sql_priority INTO " . TOPICS_WATCH_TABLE . " (user_id, topic_id, notify_status)
					VALUES (" . $row['user_id'] . ", $topic_id, 0)";
		$new_result = $db->sql_query($sql);
		}
...
Deleted the row:

Code: Select all

		}
while ($row = $db->sql_fetchrow($result));
In this case, the additional code will be in the do..while part.



Thank you this mod for the author!
Now, I can use PHPBB as a fully functional workflow system.


I didn't have to do any of this and the mod seems to work.

What difference will this make? Or what problems were you having that this solved?
Rich

andyng
Registered User
Posts: 29
Joined: Sun Jun 20, 2004 7:59 am

Post by andyng » Sat Oct 15, 2005 6:24 am

Hi,

Can I change the below DEFAULT TO "1" for all so that all new topic an email would be sent to register member. I have a very small board and the traffic is low. So a new topic generate an email would be OK and after all member can turn it off in the profile.

Andy Ng


#-----[ SQL ]------------------------------------------
#
#
# Table structure for table 'phpbb_forums_watch'
#
CREATE TABLE phpbb_forums_watch (
forum_id mediumint(8) UNSIGNED NOT NULL DEFAULT '1',
user_id mediumint(8) NOT NULL DEFAULT '1',
notify_status tinyint(1) NOT NULL default '1',
KEY forum_id (forum_id),
KEY user_id (user_id),
KEY notify_status (notify_status)
);
#

crownroyal
I've Been Banned!
Posts: 187
Joined: Fri Mar 18, 2005 12:35 am

Post by crownroyal » Tue Oct 18, 2005 1:46 am

Hi, when i receive the notification, it gives me everything perfect . the only thing is the link to the post is as a text word, it is not like a link to click on. I have to copy teh link then paste it into teh browser, how can i make it so that it is clickable from teh email?


please help.


PS I love this mod !

eq4bits
Registered User
Posts: 49
Joined: Fri Jan 21, 2005 3:01 pm

Post by eq4bits » Fri Oct 28, 2005 8:38 pm

Heyla, just installed this mod however no emails are going out/being received when a new topic is created in the 'watched' forum. Any clue as to what may be going on?

the only think I wasn't 'sure' about on the install was the KEY part in the section about creating the new table and the fields. I haven't had KEY on any of the other mods that required new tables and fields and was wondering what I'm supposed to do with these three KEY things.

I use phpMYAdmin to mess with the phpbb2 tables and had no problem with

Code: Select all

CREATE TABLE phpbb_forums_watch (
  forum_id mediumint(8) UNSIGNED NOT NULL DEFAULT '0',
  user_id mediumint(8) NOT NULL DEFAULT '0',
  notify_status tinyint(1) NOT NULL default '0',
but what the heck do I do with this

Code: Select all

  KEY forum_id (forum_id),
  KEY user_id (user_id),
  KEY notify_status (notify_status)
);
stuff?

smitjel
Registered User
Posts: 461
Joined: Sat Jun 11, 2005 11:40 pm
Location: Birmingham, AL

Post by smitjel » Fri Oct 28, 2005 9:05 pm

Anyone know if the author of this mod is the same as the author of the mod in this topic?

The reason I ask is because the mod I pointed to has the ability to disable forum notifications for certain forums. Does this option exist in this mod?
My Quick Reply MOD for phpBB2

antoonvdr
Registered User
Posts: 84
Joined: Sat Mar 20, 2004 11:11 pm

Post by antoonvdr » Sun Oct 30, 2005 1:06 am

smitjel wrote: Anyone know if the author of this mod is the same as the author of the mod in this topic?

The reason I ask is because the mod I pointed to has the ability to disable forum notifications for certain forums. Does this option exist in this mod?

You are right. I already installed it a long time ago and it is creepy how similar the code is.....
The mod you are pointing to is much older and more complete!!!

I am currently working on a little addon to make a default list of forums to which any new user can subscribe automatically. Both MODs depend on the exact same database, so it should work for both.

smitjel
Registered User
Posts: 461
Joined: Sat Jun 11, 2005 11:40 pm
Location: Birmingham, AL

Post by smitjel » Sun Oct 30, 2005 2:02 am

antoonvdr wrote: The mod you are pointing to is much older and more complete!!!

I am currently working on a little addon to make a default list of forums to which any new user can subscribe automatically. Both MODs depend on the exact same database, so it should work for both.

It says it was updated in June so it's not that old.
My Quick Reply MOD for phpBB2

antoonvdr
Registered User
Posts: 84
Joined: Sat Mar 20, 2004 11:11 pm

Post by antoonvdr » Sun Oct 30, 2005 2:12 am

The original mod from David Herrmann is dated 2004-2-22, version 1.4, whereas skinmaster claims that the first stable release was 1.0.0 in 2005-04-08. That is more than a year later.....

I would like to know if Michael Jervis is really the same as David Herrmann???

antoonvdr
Registered User
Posts: 84
Joined: Sat Mar 20, 2004 11:11 pm

Post by antoonvdr » Sun Oct 30, 2005 3:11 pm

antoonvdr wrote: I am currently working on a little addon to make a default list of forums to which any new user can subscribe automatically. Both MODs depend on the exact same database, so it should work for both.
If you are interested in this addon, you can download it here: http://www.chathamkiwanis.com/BB/dload. ... file_id=25
;)
Last edited by antoonvdr on Wed Dec 14, 2005 3:31 am, edited 1 time in total.

shipley.c
Registered User
Posts: 7
Joined: Sat Oct 15, 2005 10:03 pm
Location: Hartford, CT, USA
Contact:

Utilizing Group Permissions...

Post by shipley.c » Mon Oct 31, 2005 4:34 pm

I'm using Group Permissions for my forums, and when a user gets a post for viewforum.php?f=16 - they can't view the forum. They log in, and it gives them the message that the forum they are looking for doesn't exist. However, my admin account has no issues. I think the viewforum.php code is somehow not looking at group permissions prior to seeing if the user has access to the code. I suppose I could give read access to all registered users to temporarily solve the problem, but I don't want to do that. Any thoughts?
Chris Shipley
Nutmeg Consulting

Post Reply

Return to “[2.0.x] MOD Database Cleanup”