[2.0.13] Forum Watch

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
32
78%
Very Good
3
7%
Good
3
7%
Fair
0
No votes
Poor
3
7%
 
Total votes: 41

User avatar
wads24
Registered User
Posts: 534
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Post by wads24 »

i had an older version of this script installed. it is suppose to allow users to subscribe to watch a whole forum, so if someone posts a new topic that user if they subscribes to that forum by clicking on the bottom left of the subscribe page, when I installed it... it even stopped the newer version from sending emails for topics also.

SDGR-Chewy
Registered User
Posts: 5
Joined: Wed Sep 13, 2006 8:58 pm

Request for addition to this MOD

Post by SDGR-Chewy »

I'm looking for an addition to this MOD, which is a topic excerpt included in the notification email. For more information, please read:

http://www.phpbb.com/phpBB/viewtopic.php?t=442970

Thanks in advance,

Chris.

SDGR-Chewy
Registered User
Posts: 5
Joined: Wed Sep 13, 2006 8:58 pm

Post by SDGR-Chewy »

By the way, don't forget to add the language entries in custom languages, else the watch option won't pop up in your custom language.

Nimasdj
Registered User
Posts: 40
Joined: Sat Dec 11, 2004 11:23 pm

I don't receive email

Post by Nimasdj »

Hi,

I installed the module, and by clicking watch forum I see that the info is entered into DB as I checked it with phpMyAdmin, and by unwatching forum this is deleted from DB so I assume that I followed the manual correctly, my smtp also works fine for any other email sent from forums. except the notify_topic.tpl email I don't receive when I added a new topic.

Could you please advice why I am not receiving notification email when I added a new topic to a watched forum?

Thanks,

User avatar
wads24
Registered User
Posts: 534
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Post by wads24 »

snowmoon wrote: Hi wads24

I've just installed on phpBB 2.0.21 and it's not doing what it's supposed to do. So I'm interested to know what version you were using previously. Was it 2.0.20? Thanks.


snowman,
no, I was using even an older version then that... I still haven't found a patch for the newest version of PHPBB. It sounds like this mod is no longer working, as it should, for lots of people though

konni_b
Registered User
Posts: 37
Joined: Mon Oct 31, 2005 11:51 pm
Location: Australia

Post by konni_b »

snowmoon wrote: I've just installed on phpBB 2.0.21 and it's not doing what it's supposed to do. So I'm interested to know what version you were using previously. Was it 2.0.20? Thanks.


if it's not working properly does it mean that its causing problems otherwise?

I can't bear to go back and reinstall a previous version (v.19) and then have to hack stuff again. This coding doesn't come easy to me.

User avatar
wads24
Registered User
Posts: 534
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Post by wads24 »

konni_b wrote:
snowmoon wrote: I've just installed on phpBB 2.0.21 and it's not doing what it's supposed to do. So I'm interested to know what version you were using previously. Was it 2.0.20? Thanks.


if it's not working properly does it mean that its causing problems otherwise?

I can't bear to go back and reinstall a previous version (v.19) and then have to hack stuff again. This coding doesn't come easy to me.


doesn't come to me easily either... Just have to waite for someone that it does come easy too, but it doesn't work well with the newest phpbb version.

cbmr777
Registered User
Posts: 6
Joined: Thu Nov 02, 2006 5:58 am

Post by cbmr777 »

Forgive me... I'm an absolute newbie to phpBB...

I tried installing this mod using easymod. I'm using phpBB 2.0.21.

I now have this error:

Code: Select all

SQL Error : 1146 Table 'carrierangel.phpbb_forums_watch' doesn't exist

SELECT notify_status FROM phpbb_forums_watch WHERE forum_id = 4 AND user_id = 4

Line : 131
File : viewforum.php
Can someone help me?
How do I create this table?

TIA!
-- Christine

User avatar
wads24
Registered User
Posts: 534
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Post by wads24 »

cbmr777 wrote: Forgive me... I'm an absolute newbie to phpBB...

I tried installing this mod using easymod. I'm using phpBB 2.0.21.

I now have this error:

Code: Select all

SQL Error : 1146 Table 'carrierangel.phpbb_forums_watch' doesn't exist

SELECT notify_status FROM phpbb_forums_watch WHERE forum_id = 4 AND user_id = 4

Line : 131
File : viewforum.php
Can someone help me?
How do I create this table?

TIA!


I wouldn't waste your time... it doesn't work with that version...

User avatar
bonelifer
Community Team Member
Community Team Member
Posts: 3492
Joined: Wed Oct 27, 2004 11:35 pm
Name: William
Contact:

Post by bonelifer »

Not only does it work with 2.0.21, all they need to do is run the SQL statements from the install file on their database to make it work. As that error message is just saying they haven't run the SQL from the install file on the database.
Knowledge Base | phpBB Board Rules | Search Customisation Database
Image
Please don't contact me via PM or email for phpBB support .

cbmr777
Registered User
Posts: 6
Joined: Thu Nov 02, 2006 5:58 am

Post by cbmr777 »

So how would I go about rerunning the SQL install?

TIA!
-- Christine

User avatar
wads24
Registered User
Posts: 534
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Post by wads24 »

cbmr777 wrote: So how would I go about rerunning the SQL install?

TIA!


i know what the error on yoru SQL says when attempting to install with easymod, just that the functionality doesn't work with the new version of the mod. Tia, I wouldn't waste your time until it is fixed to work with the newest version of phpbb.


if you don't want to listen, then go to your sql admin,
click sql, then copy and paste this code:

Code: Select all

CREATE TABLE phpbb_forums_watch (
  forum_id mediumint(8) UNSIGNED NOT NULL DEFAULT '0',
  user_id mediumint(8) NOT NULL DEFAULT '0',
  notify_status tinyint(1) NOT NULL default '0',
  KEY forum_id (forum_id),
  KEY user_id (user_id),
  KEY notify_status (notify_status)
);
But the easymod should have ran this code for you, if you provided the correct info for Myphpadmin

cbmr777
Registered User
Posts: 6
Joined: Thu Nov 02, 2006 5:58 am

Post by cbmr777 »

wads24 wrote: if you don't want to listen, then go to your sql admin,


Now why in the world would you say that? :lol: BTW, it worked like a charm! 8) Thank you!!!

My new error is a parse error after I try to post a new topic or reply to a topic:
Parse error: parse error in /usr/home/carrierangel/public_html/phpBB2/posting.php on line 620


My line 620 says:

Code: Select all

	$message = ( !empty($HTTP_POST_VARS['message']) ) ? htmlspecialchars(trim(stripslashes($HTTP_POST_VARS['message']))) : '';
:) I appreciate the help!
-- Christine

User avatar
wads24
Registered User
Posts: 534
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Post by wads24 »

cbmr777 wrote:
wads24 wrote: if you don't want to listen, then go to your sql admin,


Now why in the world would you say that? :lol: BTW, it worked like a charm! 8) Thank you!!!

My new error is a parse error after I try to post a new topic or reply to a topic:
Parse error: parse error in /usr/home/carrierangel/public_html/phpBB2/posting.php on line 620


My line 620 says:

Code: Select all

	$message = ( !empty($HTTP_POST_VARS['message']) ) ? htmlspecialchars(trim(stripslashes($HTTP_POST_VARS['message']))) : '';
:) I appreciate the help!


The functionality doesn't work on mine like it should. Glad to see it's working for you though... The question is... Does it work like it should?

cbmr777
Registered User
Posts: 6
Joined: Thu Nov 02, 2006 5:58 am

Post by cbmr777 »

I don't know... it won't let me post anything to the forums without that error... so I can't test the mod itself... :?
-- Christine

Post Reply

Return to “[2.0.x] MOD Database Cleanup”