[2.0.6] Log Actions MOD

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
128
50%
Very Good
47
18%
Good
35
14%
Fair
9
3%
Poor
39
15%
 
Total votes: 258

kevinneke
Registered User
Posts: 5
Joined: Thu Aug 11, 2005 12:50 pm

Post by kevinneke » Wed Nov 01, 2006 11:14 am

I've added and changed everything. My db is oke, but I have this error:

Code: Select all

PHP Parse error: parse error, unexpected T_STRING in \wwwroot\forum2\language\lang_dutch\lang_main.php on line 1076 
What's wrong? :cry:

kevinneke
Registered User
Posts: 5
Joined: Thu Aug 11, 2005 12:50 pm

Post by kevinneke » Wed Nov 01, 2006 2:00 pm

There is something wrong with this code in lang_main.php:

Code: Select all

$lang['Close_window'] = 'Sluit dit scherm'; 
$lang['Rules_title'] = 'Actie : %s'; 
$lang['Locking_topic'] = 'Sluiten van een Bericht'; 
$lang['Unlocking_topic'] = 'Openen van een Bericht'; 
$lang['Spliting_topic'] = 'Splitsen van een Bericht'; 
$lang['Moving_topic'] = 'Verplaatsen van een Bericht'; 
$lang['Deleting_topic'] = 'Verwijderen van een Bericht'; 
$lang['Editing_topic'] = 'Bewerken van een Bericht'; 
$lang['Lock_Explication'] = 'Als een Moderator of Administrator een bericht sluit, is het niet mogelijk voor een normale gebruiker om te Antwoorden. Moderators of Administrators kunnen wel door blijven gaan in dat bericht.'; 
$lang['Unlock_Explication'] = 'Een Moderator of Administrator kan een bericht weer openen. Dit geeft de gebruikers weer de mogelijkheid om de gebruikers te laten reageren op dit bericht'; 
$lang['Split_Explication'] = 'Door een bericht af te splitsen kun je delen die bijvoorbeeld offtopic gaan ervoor kiezen om daar een nieuw bericht van te maken .'; 
$lang['Move_Explication'] = 'Als je ervoor kiest om een bericht te verplaatsen kan je het onderwerp van A naar B verplaatsen, je kunt er ook voor kiezen om een schaduw link achter te laten.'; 
$lang['Delete_Explication'] = 'Als een Moderator of Administrator een bericht niet wenselijk vind kan men dit verwijderen. <br /><b>Ben voorzichtig met deze functie want het kan niet worden terug gedraaid</b>'; 
$lang['Edit_Explication'] = 'Door het bewerken kan een Moderator of Administrator het bericht bewerken wat een gebruiker heeft geplaatst.'; 
$lang['No_action_specified'] = 'Er is geen actie aangegeven';

Error:

Code: Select all

PHP Parse error: parse error, unexpected T_VARIABLE in \Inetpub\wwwroot\forum2\language\lang_dutch\lang_main.php on line 1082 
Installed Mods:
Communications:
Animated New Message Icon Mod
Extended Private Message Notification
Double Post Control 1.1.0
PM Popup Blocker Fix
Change Email Sender
No PMs to self
Display Number Of Private Messages
Extended Reply Notification

Syndication:
Latest active topics on index
Redirect User Fix

BBcode:
Glow and Shadow BBcode MOD

Security:
Posted email js
Email Admin on ACP Login
Log IP Address on Registration

Can please somebody help me???[/code]

kevinneke
Registered User
Posts: 5
Joined: Thu Aug 11, 2005 12:50 pm

Post by kevinneke » Wed Nov 01, 2006 7:40 pm

I'm sorry but this hack is really ruinating my forum! I've started all over again, and now it works fine...until I want to delete a post. He gives no error, but he just doesn't delete it.

Anyone? :roll:

cybernet
Registered User
Posts: 34
Joined: Mon Jan 09, 2006 5:02 pm
Location: Romanian - i can't speak very well english so please excuse me
Contact:

Post by cybernet » Fri Nov 03, 2006 1:44 pm

so can someone give the SQL commands please



---
i know my english sucks :cry:

masi
Registered User
Posts: 12
Joined: Thu Nov 09, 2006 12:39 pm

Post by masi » Thu Nov 09, 2006 8:45 pm

i just wanted to install this mod, but i keep getting the following error in the last step of the install process

Code: Select all


Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'DATABASE_LOGIN_NAME'@'volf.store' (using password: NO) in /mnt/jd1/01/177/00000015/htdocs/forum/db/mysql4.php on line 48

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /mnt/jd1/01/177/00000015/htdocs/forum/db/mysql4.php on line 330

Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /mnt/jd1/01/177/00000015/htdocs/forum/db/mysql4.php on line 331
phpBB : Critical Error

Could not connect to the database

can anyone help me?

User avatar
George_4net
Registered User
Posts: 82
Joined: Mon May 29, 2006 5:28 pm

Post by George_4net » Sat Nov 11, 2006 7:57 pm

Hi there!

I just wanna say this is a great mod but i have installed it in a forum. Now I want to update tables from the log_actions_db_update.php file. I put it in main phpBB directory but when i call it from my browser i get a message
phpBB : Critical Error

Could not connect to the database


does anyone knows why this happens?

EDIT:

OK I found that I needed:

http://www.phpbb.com/phpBB/viewtopic.ph ... 26#2527326

Asbestos
Registered User
Posts: 26
Joined: Wed Nov 08, 2006 7:40 pm
Location: GA
Contact:

Post by Asbestos » Wed Nov 15, 2006 8:40 pm

clawed wrote:
emtohio wrote:I have phpmyadmin but I just can figure out how to run the sql statement.

Is this somehting I do from this panel or do I need to add that to the code on the forum?


go here http://www.phpbb.com/kb/article.php?article_id=151 (phpbb knowledge base article: Get the steps to executing SQL queries for MODs in phpMyAdmin)


I was reading through all these pages because I was getting the same error the guy about 5-6 posts above me was getting. I ran the query in phpMyAdmin and it worked perfectly!

Thanks!

cwallace
Registered User
Posts: 523
Joined: Tue Dec 14, 2004 4:26 am
Location: Fort Wayne, Indiana
Contact:

Post by cwallace » Tue Nov 21, 2006 10:35 pm

phpBB : Critical Error

Could not connect to the database

That is the error I get. I am assuming there is something in the script that is not set right to grab the right DB information, but I have no clue. Can someone link to the actual SQL that needs to be inserted so that I might be able to do it manually with phpmyadmin...

I will also search for that next..

Chris
http://www.FortWayneMusic.com - Your source for the best in local music and entertainment.

cwallace
Registered User
Posts: 523
Joined: Tue Dec 14, 2004 4:26 am
Location: Fort Wayne, Indiana
Contact:

Post by cwallace » Tue Nov 21, 2006 11:46 pm

Yeah...found the code and manually installed it...worked like a charm...

in case you don't know where it is...here it is again...

CREATE TABLE `phpbb_logs` (
`id_log` MEDIUMINT(10) NOT NULL AUTO_INCREMENT,
`mode` VARCHAR(50) NULL DEFAULT '',
`topic_id` MEDIUMINT(10) NULL DEFAULT '0',
`user_id` MEDIUMINT(8) NULL DEFAULT '0',
`username` VARCHAR(255) NULL DEFAULT '',
`user_ip` CHAR(8) DEFAULT '0' NOT NULL,
`time` INT(11) NULL DEFAULT '0',
PRIMARY KEY (`id_log`)
);

CREATE TABLE `phpbb_admin_logs` (
`id_log` MEDIUMINT(10) NOT NULL AUTO_INCREMENT,
`mode` VARCHAR(50) NULL DEFAULT '',
`user_id` MEDIUMINT(8) NULL DEFAULT '0',
`username` VARCHAR(255) NULL DEFAULT '',
`user_ip` CHAR(8) DEFAULT '0' NOT NULL,
`time` INT(11) NULL DEFAULT '0',
PRIMARY KEY (`id_log`)
);

CREATE TABLE `phpbb_logs_config` (
`config_name` varchar(255) NOT NULL,
`config_value` varchar(255) NOT NULL,
PRIMARY KEY (`config_name`)
);

INSERT INTO `phpbb_logs_config` VALUES ('all_admin', 1);
ALTER TABLE `phpbb_users` ADD `user_view_log` TINYINT(2) NOT NULL DEFAULT '0';
ALTER TABLE `phpbb_forums` ADD `forum_allow_log` TINYINT(2) NOT NULL DEFAULT '1';


ENJOY!

Chris[/quote]
http://www.FortWayneMusic.com - Your source for the best in local music and entertainment.

acharabia
Registered User
Posts: 139
Joined: Fri Sep 27, 2002 4:41 pm
Location: SEOUL/KOREA
Contact:

Post by acharabia » Wed Nov 22, 2006 1:48 am

This MOD work anyway but there are some weirld to understand.
Anybody know what is fonction "rule_body.tpl" on the board?
And what can I do if I have already same file with this name
on my board? I can't find lang which I add to lang_main.
Where can I find those things? Maybe this file miss-done?!?!
Normally, *.tpl file insert into "subSilver" link to
"overal_hearder.tpl" for menu link... doesn't it?!?!
## Included Files: 7
## admin/admin_logs.php
## admin/admin_logs_config.php
## includes/functions_log.php
## includes/rules.php
## templates/subSilver/rules_body.tpl
## templates/subSilver/admin/logs_body.tpl
## templates/subSilver/admin/logs_config_body.tpl


Too long to look this topic...
over 130 page make me hard to find solutions...
So I classication in my way like below.

http://www.phpbb.com/phpBB/viewtopic.ph ... 782#967782
http://www.phpbb.com/phpBB/viewtopic.ph ... 976#464976
http://www.phpbb.com/phpBB/viewtopic.ph ... 779#973779
http://www.phpbb.com/phpBB/viewtopic.ph ... 94#1229594
http://www.phpbb.com/phpBB/viewtopic.ph ... 61#1341161
http://www.phpbb.com/phpBB/viewtopic.ph ... 34#1353834
http://www.phpbb.com/phpBB/viewtopic.ph ... 41#1377041
http://www.phpbb.com/phpBB/viewtopic.ph ... 10#1435810
http://www.phpbb.com/phpBB/viewtopic.ph ... 15#1562415
http://www.phpbb.com/phpBB/viewtopic.ph ... 45#1785245
http://www.phpbb.com/phpBB/viewtopic.ph ... 83#1961783

There are some mal-indication on the mannual and "missing-argument"
error in this MOD with anothers. So that's better to avoid to installing
this MOD who had already huge MOD on their board.


That's the important conclution.

Why? If you install this MOD with others,
there are surely editing error occur.
Especially, "topic-calendar" MOD... etc.
Image

Zenx
Registered User
Posts: 3
Joined: Sat Nov 25, 2006 1:28 am

Post by Zenx » Sat Nov 25, 2006 2:29 am

cwallace wrote: Yeah...found the code and manually installed it...worked like a charm...

in case you don't know where it is...here it is again...

CREATE TABLE `phpbb_logs` (
`id_log` MEDIUMINT(10) NOT NULL AUTO_INCREMENT,
`mode` VARCHAR(50) NULL DEFAULT '',
`topic_id` MEDIUMINT(10) NULL DEFAULT '0',
`user_id` MEDIUMINT(8) NULL DEFAULT '0',
`username` VARCHAR(255) NULL DEFAULT '',
`user_ip` CHAR(8) DEFAULT '0' NOT NULL,
`time` INT(11) NULL DEFAULT '0',
PRIMARY KEY (`id_log`)
);

CREATE TABLE `phpbb_admin_logs` (
`id_log` MEDIUMINT(10) NOT NULL AUTO_INCREMENT,
`mode` VARCHAR(50) NULL DEFAULT '',
`user_id` MEDIUMINT(8) NULL DEFAULT '0',
`username` VARCHAR(255) NULL DEFAULT '',
`user_ip` CHAR(8) DEFAULT '0' NOT NULL,
`time` INT(11) NULL DEFAULT '0',
PRIMARY KEY (`id_log`)
);

CREATE TABLE `phpbb_logs_config` (
`config_name` varchar(255) NOT NULL,
`config_value` varchar(255) NOT NULL,
PRIMARY KEY (`config_name`)
);

INSERT INTO `phpbb_logs_config` VALUES ('all_admin', 1);
ALTER TABLE `phpbb_users` ADD `user_view_log` TINYINT(2) NOT NULL DEFAULT '0';
ALTER TABLE `phpbb_forums` ADD `forum_allow_log` TINYINT(2) NOT NULL DEFAULT '1';


ENJOY!

Chris




Thanks a bunch! This solved my error - too bad there is no reputation mod running. :wink:

User avatar
Ekushey
Registered User
Posts: 13
Joined: Wed Nov 15, 2006 8:15 am
Location: Dhaka
Name: Russell John
Contact:

Post by Ekushey » Wed Nov 29, 2006 6:12 pm

Zenx wrote: Thanks a bunch! This solved my error - too bad there is no reputation mod running. :wink:

I agree with Zenx. :)

I got the same error:
phpBB : Critical Error

Could not connect to the database

and the SQL code above helped me to finalise the MOD installation.

Shouldn't the author fix this problem soon? Not everyone has access to mySQL command line or phpMyAdmin.

User avatar
PaulusB
Registered User
Posts: 216
Joined: Sun May 28, 2006 2:08 pm
Location: Holland
Contact:

Post by PaulusB » Fri Dec 01, 2006 11:07 pm

solved

bobybc
Registered User
Posts: 1
Joined: Fri Dec 08, 2006 10:12 pm

Post by bobybc » Fri Dec 08, 2006 10:17 pm

Hi,
aftrer aplaying this mod, it owrks, but when i try to edit a post, it always say:
'Sorry, but you can only edit your own posts.'
even it is mine post.

Please help?

Regards
Bobby

acharabia
Registered User
Posts: 139
Joined: Fri Sep 27, 2002 4:41 pm
Location: SEOUL/KOREA
Contact:

Post by acharabia » Fri Dec 08, 2006 10:21 pm

bobybc wrote: Hi,aftrer aplaying this mod, it owrks, but when i try to edit a post, it always say:'Sorry, but you can only edit your own posts.'even it is mine post.Please help?RegardsBobby


This is very dangeous(?) MOD for installing at the board which is already
too many MODs installed. So I'm regret to install this MOD on my board.
That problem came from "function_post.php" which is already insert some
code much "topic_calendar" etc. So you should deleate this MOD immedately
or read carefully above my topics again.

http://www.phpbb.com/phpBB/viewtopic.ph ... 58#2604258
Image

Post Reply

Return to “[2.0.x] MOD Database Cleanup”