[2.0.6] Log Actions MOD

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
128
50%
Very Good
47
18%
Good
35
14%
Fair
9
3%
Poor
39
15%
 
Total votes: 258

llj143
Registered User
Posts: 106
Joined: Fri May 06, 2005 11:23 am

Post by llj143 »

anyway also that we can see the log actions in members? :)
Seashairo
Registered User
Posts: 11
Joined: Sun Apr 24, 2005 1:42 pm
Contact:

Post by Seashairo »

Good MOD but when I have it installed when I go to Logs Actions I get this:
-----------
You have not yet delete the file install_tables.php : do it before trying to see this page.
-----------

When I go to Logs Config I get this:
-----------
phpBB : Critical Error

Could not query log config informations

DEBUG MODE

SQL Error : 1146 Table 'silveroceauk.phpbb_logs_config' doesn't exist

SELECT config_value AS all_admin FROM phpbb_logs_config WHERE config_name = 'all_admin'

Line : 51
File : admin_logs_config.php
-----------

Do any of you know what's wrong?
I don't need no dumb signature......
I am the signature virus; copy me to your signature to help me spread!
Theangryone
Registered User
Posts: 333
Joined: Wed Jun 22, 2005 4:16 am
Contact:

Post by Theangryone »

same problem here
Theangryone
Registered User
Posts: 333
Joined: Wed Jun 22, 2005 4:16 am
Contact:

Post by Theangryone »

answers on page 99! :lol:
Mr_Glyn
Registered User
Posts: 116
Joined: Fri Jun 03, 2005 6:40 pm
Location: inside

Post by Mr_Glyn »

problems with this mod...

i have other mods installed the main one was

modcp

i installed your mod and i could not edit / quote any posts... (i'm the admin)
Image
Mr_Glyn
Registered User
Posts: 116
Joined: Fri Jun 03, 2005 6:40 pm
Location: inside

Post by Mr_Glyn »

http://www.phpbb.com/phpBB/viewtopic.php?t=309418

i'm having problems with your mod..
Image
Mr_Glyn
Registered User
Posts: 116
Joined: Fri Jun 03, 2005 6:40 pm
Location: inside

Post by Mr_Glyn »

Seashairo wrote: Good MOD but when I have it installed when I go to Logs Actions I get this:
-----------
You have not yet delete the file install_tables.php : do it before trying to see this page.
-----------

When I go to Logs Config I get this:
-----------
phpBB : Critical Error

Could not query log config informations

DEBUG MODE

SQL Error : 1146 Table 'silveroceauk.phpbb_logs_config' doesn't exist

SELECT config_value AS all_admin FROM phpbb_logs_config WHERE config_name = 'all_admin'

Line : 51
File : admin_logs_config.php
-----------

Do any of you know what's wrong?


i also got this run the file called log_actions_db_update.php
Image
WGreyHawk
Registered User
Posts: 6
Joined: Fri Apr 01, 2005 4:16 am
Contact:

db installer error?

Post by WGreyHawk »

I noticed in the db installer, that it failed to use the prefix, and also added "_table" to the end of each of the two table names. I had to go in and manually rename them.
j_nx
Registered User
Posts: 1
Joined: Tue Aug 02, 2005 12:34 am

Post by j_nx »

i'm getting the

Sorry, you're not allowed to view this page. Only the main Admin has permission.

i tried running
update phpbb_users set user_view_log = 1 where user_id = 1

and change any instances of "$userdata['user_id'] <> '2'" or "$userdata['user_id'] == '2'" or anything like that to the user ID of your main admin account.

both have failed me.

what else can i do?

thanks.
WGreyHawk
Registered User
Posts: 6
Joined: Fri Apr 01, 2005 4:16 am
Contact:

Post by WGreyHawk »

um, I think they were talking about changing that in the PHP, not SQL.
Merr
Registered User
Posts: 3
Joined: Sat Jan 29, 2005 12:45 am

Herm

Post by Merr »

When I installed this MOD I followed instructions. I'm relatively new to the whole mod world.

But I did as you said.

And when I try to view them in the admin panel. I get this message.
When I click the Logs Config
Template->make_filename(): Error - file admin/logs_config_body.tpl does not exist


And When I click Log Action I get this
Template->make_filename(): Error - file admin/logs_body.tpl does not exist


Any Help would be greatly appreciated.

Those 2 files were not in the Zip File I downloaded.
ACK
kevinneke
Registered User
Posts: 5
Joined: Thu Aug 11, 2005 12:50 pm

Post by kevinneke »

Hello,

The script is working with me great, at least, I have no SQLerrors. But...I've got a big problem! :(

Basic the Logs is configurated that only the headadministrator (id1) can access and change the settings. But, I've deleted id1 and I'm the board administrator (I can access my FTP) and I have id3. So, if I click on "Logs Actions" in my panel, he says that I haven't the rights to see the logs. :(

How can I change this?
kevinneke
Registered User
Posts: 5
Joined: Thu Aug 11, 2005 12:50 pm

Re: Herm

Post by kevinneke »

Merr wrote: Those 2 files were not in the Zip File I downloaded.

Yes, they are! Check this in the zipmap: root => templates ==> subsilver ==> admin! ;)
Merr
Registered User
Posts: 3
Joined: Sat Jan 29, 2005 12:45 am

Post by Merr »

Ok turns out I just had a bad download. But I downloaded the zip again, and the files were there I uploaded them. And I still get the message.

I'm at a loss here.

Am I supposed to upload the files to the folder that they were in , in the zip file? If so I've done that, and I'm still confused on why it's not working.

Also Does it matter that I'm not using the SubSilver Theme?
ACK
crocike
Registered User
Posts: 2
Joined: Sun Feb 27, 2005 6:36 am

Post by crocike »

Help me plz i need help fast!!

Where i can find the install_tabel thing. It wasent on the zip file.
And i got errors like this:

Code: Select all

phpBB : Critical Error

Could not query log informations

DEBUG MODE

SQL Error : 1146 Table 'gamelorg_main.phpbb_logs' doesn't exist

SELECT * FROM phpbb_logs ORDER BY time DESC LIMIT 0, 50

Line : 164
File : admin_logs.php

Code: Select all

Running query :: CREATE TABLE phpbb_logs ( id_log MEDIUMINT(10) NOT NULL DEFAULT '0' AUTO_INCREMENT, mode VARCHAR(50) NULL DEFAULT '', topic_id MEDIUMINT(10) NULL DEFAULT '0', user_id MEDIUMINT(8) NULL DEFAULT '0', username VARCHAR(255) NULL DEFAULT '', user_ip CHAR(8) DEFAULT '0' NOT NULL, time INT(11) NULL DEFAULT '0', PRIMARY KEY (id_log)) -> ERROR - QUERY FAILED ----> Invalid default value for 'id_log'
Post Reply

Return to “[2.0.x] MOD Database Cleanup”