RSS Feed 2.0

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
User avatar
Furball Zen
Registered User
Posts: 381
Joined: Thu Oct 18, 2007 9:38 pm

Re: RSS Feed 2.0

Post by Furball Zen » Wed Sep 23, 2009 12:38 am

Midge wrote:
Furball Zen wrote:No, i believe your problem is that you have feed:// in there. I think it should be simply http://yourboardurl.de/phpbb3/rss.php.

My feed works fine formatted like that.
Okay, thank you for the feedback.
But I didn't change the code provided. Which part do I have to alter?
In the overall_header.html, make sure you didnt alter this line:
<link rel="alternate" type="application/rss+xml" title="{L_RSS_FEEDS} - {SITENAME}" href="{U_RSS}" />

I think thats where the problem is. I could be wrong. If you installed this through AutoMod, UNinstall and start over. Then do the Manual items listed in the XML (may show on screen, it didnt the 1st time but did the 2nd time), THEN go to Details for the RSS Mod from the AutoMod tab, scroll to the bottom and install the Icon. Then youll have to do the Manual stuff all over again. Then make sure the rss.gif is in /images.

At least thats what i had to do. Like mentioned above, if you need a fresh copy of /includes/functions.php its in the store\mods\MSSTI_RSS_v121\_backups folder.
I am the almighty Furball Zen. Hear me fluff.

Site Admin: too many to list ;)
Port 80 is for your server, port 3306 is for your db :)
If your forum displays correctly in IE, it needs to be fixed :)

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: RSS Feed 2.0

Post by leviatan21 » Wed Sep 23, 2009 2:18 am

Furball Zen wrote:In the overall_header.html, make sure you didnt alter this line:
<link rel="alternate" type="application/rss+xml" title="{L_RSS_FEEDS} - {SITENAME}" href="{U_RSS}" />

I think thats where the problem is. I could be wrong. If you installed this through AutoMod, UNinstall and start over. Then do the Manual items listed in the XML (may show on screen, it didnt the 1st time but did the 2nd time), THEN go to Details for the RSS Mod from the AutoMod tab, scroll to the bottom and install the Icon. Then youll have to do the Manual stuff all over again. Then make sure the rss.gif is in /images.

At least thats what i had to do. Like mentioned above, if you need a fresh copy of /includes/functions.php its in the store\mods\MSSTI_RSS_v121\_backups folder.
he don't need to do that, his overall_header.html is fine, I visit his board and all is OK 8-)
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

weugs
Registered User
Posts: 2
Joined: Sun Sep 27, 2009 3:21 am

Re: RSS Feed 2.0

Post by weugs » Sun Sep 27, 2009 4:33 am

Difference is it usually introduced this MOD as the following code.

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions_privmsgs.php on line 1818: implode() [function.implode]: Invalid arguments passed
[phpBB Debug] PHP Notice: in file /includes/functions_privmsgs.php on line 1818: implode() [function.implode]: Invalid arguments passed
[phpBB Debug] PHP Notice: in file /includes/functions_privmsgs.php on line 1818: implode() [function.implode]: Invalid arguments passed
[phpBB Debug] PHP Notice: in file /includes/functions_privmsgs.php on line 1818: implode() [function.implode]: Invalid arguments passed
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3860: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3231)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3862: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3231)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3863: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3231)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3864: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3231)
Manifest themselves in PM with some of your users.
Repeat the PM, increases code at the top that one at a time.

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions_privmsgs.php on line 1818: implode() [function.implode]: Invalid arguments passed
How do I?Thanks.
Beginners, so if you misunderstand me.

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: RSS Feed 2.0

Post by leviatan21 » Sun Sep 27, 2009 12:02 pm

Your problem is not related to this MOD, because it never modify the /includes/functions_privmsgs.php file.

If you still have problems, make a new topic in the 3.0.x Support Forum, fill out the Support Request Template so the Support Team can gather a better understanding of your board which may help in finding a solution.
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

weugs
Registered User
Posts: 2
Joined: Sun Sep 27, 2009 3:21 am

Re: RSS Feed 2.0

Post by weugs » Sun Sep 27, 2009 12:09 pm

I understand.
Up new topics elsewhere. Sorry.

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: RSS Feed 2.0

Post by DocSommer » Mon Sep 28, 2009 4:55 pm

Hi,

I know there has been some discussion about this but I got some serious feedback about the fact, that the feed is transmitting the posters mail adresses. The official answere is that the user can decide to show is mail or not within the UCP:
The feed heck if the user want to display his email adress, if not it's replaced with the board contact email
Maybe this Question is stupid but can anyone tell me where I can fand this setting? All I found is "board preferences > Global settings > "Users can contact me by e-mail"

And it doesn't really matter what setting is selected there :?

Disable the item statistic is a work around of course but I'd prefer a solution what makes it possible to keep the user name displayed WITHOUT their mail adresses - just to avoid a flood of spam. What do you think guys? :?:

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: RSS Feed 2.0

Post by DocSommer » Mon Sep 28, 2009 5:29 pm

I found the solution on my own:

rss.php - search:

Code: Select all

		if ( $config['rss_items_statistics'] )
		{
			// Look if the user has email and allow to display it ;)
			$item_row['AUTHOR']			= ( (isset($row['user_allow_viewemail']) && isset($row['user_email']) ) ? $row['user_email'] : $config['board_email'] ) . ' (' . $row['username'] . ')';

change to:

Code: Select all

		if ( $config['rss_items_statistics'] )
		{
			// Look if the user has email and allow to display it ;)
			$item_row['AUTHOR']			= $row['username'];

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: RSS Feed 2.0

Post by leviatan21 » Mon Sep 28, 2009 6:18 pm

DocSommer wrote:I found the solution on my own:

rss.php - search:

Code: Select all

		if ( $config['rss_items_statistics'] )
		{
			// Look if the user has email and allow to display it ;)
			$item_row['AUTHOR']			= ( (isset($row['user_allow_viewemail']) && isset($row['user_email']) ) ? $row['user_email'] : $config['board_email'] ) . ' (' . $row['username'] . ')';

change to:

Code: Select all

		if ( $config['rss_items_statistics'] )
		{
			// Look if the user has email and allow to display it ;)
			$item_row['AUTHOR']			= $row['username'];
Just for clarify : Making that change, your feed is no more valid. 8-)
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: RSS Feed 2.0

Post by DocSommer » Mon Sep 28, 2009 6:59 pm

Just for clarify : Making that change, your feed is no more valid. 8-)
Well - disable the "items statistic" should lead to the same problem but this is a built-in feature of this mod - all I did is customizing this feature a little bit^^

And what's the practical consequence if it's not "valid"? All I know is that "valid" e-mail adresses are like gold for all the spam-servers out there, especially if there's no default privacy anabled for the users who might be not very pleased about the effects afterwards (and might not think about the consequences in the first place). And like I said - I couldn't find a setting inside the UCP wich does successfully supress the e-mail transmission.

But - and that's a little news:

I found an interesting setting within the ACP:

General > Client Communication > E-Mail Settings > Hide E-Mail Adress (This function keeps e-mail addresses completely private)

Doesn't work as well - I think it's not very good that this mod is completely overriding this very "global sounding" setting.

Don't get me wrong - I'm very pleased with this mod, it's just this detail I'm not happy with.

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: RSS Feed 2.0

Post by leviatan21 » Mon Sep 28, 2009 7:23 pm

DocSommer wrote:Well - disable the "items statistic" should lead to the same problem but this is a built-in feature of this mod - all I did is customizing this feature a little bit^^
Is not the same, because disable item statistics, disable a hole FEED tag, meanwhile your modification just make a tag incomplete ;)
DocSommer wrote:And what's the practical consequence if it's not "valid"?
Some Feed readers can display an error, may be not, it depends on the feed program 8-)
DocSommer wrote:Doesn't work as well - I think it's not very good that this mod is completely overriding this very "global sounding" setting.
Not at all, this mod do not overwrite any configuration, it just use the user setting and not the ACP setting.
May be the problem is related to this bug : user's E-Mail
Last edited by leviatan21 on Mon Sep 28, 2009 9:48 pm, edited 1 time in total.
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: RSS Feed 2.0

Post by DocSommer » Mon Sep 28, 2009 9:06 pm

Thanks for the additional informations - I'm not really in to that RSS stuff so that's much apprechiated.
Some Feed readers can display an error, may be not, it depends on the feed program 8-)
That'll be lame :cry:

But if I complete the code in another way to output just my totally unimportand board mail adress (like "noreply@...") it should be avoid this trouble (even if it's still not valid)? Unfortunately I'm not quite shure how to do this cause I'm not very in to php programming as well :oops:

I think it must look kind of:

Code: Select all

$item_row['AUTHOR']			= $config['board_email']  . ' (' . $row['username'] . ')';
:? ? :?

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: RSS Feed 2.0

Post by leviatan21 » Mon Sep 28, 2009 9:50 pm

DocSommer wrote:I think it must look kind of:

Code: Select all

$item_row['AUTHOR']			= $config['board_email']  . ' (' . $row['username'] . ')';
That will be fine ;)
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: RSS Feed 2.0

Post by DocSommer » Tue Sep 29, 2009 1:53 pm

leviatan21 wrote:
DocSommer wrote:I think it must look kind of:

Code: Select all

$item_row['AUTHOR']			= $config['board_email']  . ' (' . $row['username'] . ')';
That will be fine ;)
It's working like a charme - thanks a lot

settergren
Registered User
Posts: 4
Joined: Wed Sep 02, 2009 7:27 pm

Re: RSS Feed 2.0

Post by settergren » Wed Sep 30, 2009 7:47 pm

Works great! Thank you so much!

Is there a way to have the link show only topic title instead of both forum/subforum name and topic title as it does now?

www.allmanmedicin.se/forum/rss.php

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: RSS Feed 2.0

Post by leviatan21 » Thu Oct 01, 2009 6:58 pm

settergren wrote:Works great! Thank you so much!

Is there a way to have the link show only topic title instead of both forum/subforum name and topic title as it does now?

http://www.allmanmedicin.se/forum/rss.php

Code: Select all

#
#---- [ OPEN ] ----
#
root/rss.php
#
#---- [ FIND ] ----
#
$item_row['TITLE']		= $row['forum_name'] . " | " . (( $row[$this->row_title] ) ? $row[$this->row_title] : $row[$this->row_title2]);
#
#---- [ REPLACE WITH ] ----
#
$item_row['TITLE']		= (( $row[$this->row_title] ) ? $row[$this->row_title] : $row[$this->row_title2]);
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

Locked

Return to “[3.0.x] MOD Database Releases”