Forum has a mind of it's own? [solved]...sorta

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Forum has a mind of it's own? [solved]...sorta

Post by EldarionII » Thu Jul 01, 2004 9:38 pm

Allright, I think my board is toast. I have re-done it and everything! See, here's the deal:

I have been having alot of problems lately, but now my forum has hit the loony bin! When I appoint one person a mod, it also appoints another person that shouldn't be a mod. And when I undo that person that shouldn't, the other person goes too.
Another incident: In my forum, I have the disable post count increase mod installed, and in the forum management, I have to uncheck to boxes for it to not count posts!

Another: When someone creates a new topic, it starts out with like 4 or 7 pages! Then you click on it and it says there is no post or what ever.

Other things are going screwy too, like on the top of my board, it created an extra 3 icons for the members link, and they were for subSilver and it is not even installed on my boards! I am using subBlack!

I don't know if it is one of my mods or something I just did (I'll explain what I did below) But here is the list of MODs I have on my board so far:
Cash MOD
The Pruning MOD
Disable post count increase MOD
Total Posts MOD
Edit User Posts MOD
I had plans to add alot more, but I don't think I am going to waste the time.

Now, I think it is something to do with my database. I recently re-started my board becuase I kept getting the 404 error page. So I saved the members, posts, and forums, and catagories by exporting them from MySQL 4.x But when I uploaded them, I would get things like this:
MySQL Said:
Duplicate entry 2 for key 1


And I never successfully uploaded all of them. I only got the Forums anc Catagories. And since those are some of the things that were having problems, I thought that might be the problem, but I have no clue what to do other than restart again which I think will just end up like this one.

(Btw, I am running 2.0.8 after just upgrading to 2.0.6 which was in the Cpanel in Fantastico wich automatically installed 2.0.6)

And here is my board: http://www.eldarionpc.com/forum
I set up a tester account so you all can see what is going on. But I set up a test forum too, but I am not sure if it will do it in there, but:
Account: 'Tester'
Password: 'problem'
Last edited by EldarionII on Fri Jul 02, 2004 11:04 pm, edited 2 times in total.

EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Post by EldarionII » Thu Jul 01, 2004 9:42 pm

Yeah, that forum does work, someone just made a test one or something and it says there is 23 pages of it when there is only one post.

Stefan Koopmanschap
Former Team Member
Posts: 7388
Joined: Sun Oct 28, 2001 9:47 am
Location: Woudenberg, Netherlands
Contact:

Post by Stefan Koopmanschap » Thu Jul 01, 2004 9:48 pm

I'm afraid you will have to de-install the MODs one by one, and check after every MOD to see if the problem has been solved.

EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Post by EldarionII » Thu Jul 01, 2004 10:08 pm

But I doubt it is a MOD because I have been having alot of trouble before this. It started with the 404 error pages redirected to just search. But if I get no other response, I guess I will do that. :(

EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Post by EldarionII » Thu Jul 01, 2004 10:50 pm

I read somewhere that someone was having sorta the same problem that I was, not exactly, and it was their host wasn't completely compatible with 2.0.8 and it messed with the database. Could this be?

EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Post by EldarionII » Fri Jul 02, 2004 1:36 am

CTC, I noticed you are on, any suggestions? :wink: Eh, buddy? I have been good today, I helped 8 people, sucessfully! But the bad thing is that 200 people have my MSN account! :( And I had to sadly inform them that I was busy and can only help them with the problems I have had, which is alot since I have had almost every MySQL error there is, but I have been busy... enought about my day. Any suggestions?

EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Post by EldarionII » Fri Jul 02, 2004 1:54 am

How about flogger? You got anything on this one?

User avatar
CTCNetwork
Former Team Member
Posts: 15424
Joined: Fri Dec 19, 2003 3:50 am
Location: In that Volvo behind you!
Contact:

Post by CTCNetwork » Fri Jul 02, 2004 1:57 am

Hi,

Problems . . Lots of them. . . As you have pointed out.

Answers? Ha. . .

Ok, If you had problems with your previous install, and they were Db issues - chances are you will transport them to the new forum.
Doing a restore - even limited as you did - will carry over garbage you didn't need to the new DB (Old MODs and errors etc).

We can spend a week or more trying to unravel the mess. Or.....

Well, start again - you have a lively community and the old data in the old DB. I am sure that they can handle restarting. Any time old posts may be needed - find them in the old DB and copy it out. DON'T export it.

Get yourselves a decent host (and if need be the members can anti-up 50c for the years fee, less than a Mars Bar! <-Insert favourite Snack here!)

Install the forum. Check styles and test them on members to find the ONE or TWO you WILL want.
Add one MOD at a time and give a weeks testing to make sure it is OK. Find the best MOD for the job, if there are 3, check them all out - inc dredging through the forum for common errors.
Install BY Hand - and damn carefully too.
BACK UP.
I have seen too many times people installing 3, 4 ,5 forums before they get it right - wastes time, energy and gets up your members backs. So think first, then think second too!

Hope this helps, And Good Luck.

Des. . . :wink:
Density:- Not just a measurement~Its a whole way of Life.! ! !
| Welcome! | RTFM!!! | Search! It's Easy! | Problem? | Spam? | Advice! |

EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Post by EldarionII » Fri Jul 02, 2004 2:04 am

Yeah, I was afraid I would have to restart.... Oh well, this is the third time. My database failed before, then it went back up after I created a new one then crashed 'em both and then this one came along.... oh well! Thanx. The one week wait is a good idea. :wink: Well, on to start all over again. :cry:

flogger12
Registered User
Posts: 14936
Joined: Tue Nov 25, 2003 2:13 am

Post by flogger12 » Fri Jul 02, 2004 2:05 am

you go Des, excellent post.


robert

EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Post by EldarionII » Fri Jul 02, 2004 2:07 am

Yes, good post. :D

User avatar
CTCNetwork
Former Team Member
Posts: 15424
Joined: Fri Dec 19, 2003 3:50 am
Location: In that Volvo behind you!
Contact:

Post by CTCNetwork » Fri Jul 02, 2004 2:12 am

Hi,

Thank you both . .

Just hope some of it rubs off on the users . . :D

Des. . . :P
Density:- Not just a measurement~Its a whole way of Life.! ! !
| Welcome! | RTFM!!! | Search! It's Easy! | Problem? | Spam? | Advice! |

EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Post by EldarionII » Fri Jul 02, 2004 2:15 am

That post would be the post to answer 80% of the questions here. That deserves a round of aplause. Image

flogger12
Registered User
Posts: 14936
Joined: Tue Nov 25, 2003 2:13 am

Post by flogger12 » Fri Jul 02, 2004 2:20 am

be careful now ole' Des will start taking himself seriously and then we will all be in trouble.


luck,
robert

EldarionII
Registered User
Posts: 208
Joined: Tue Jun 15, 2004 2:54 am
Location: Wisconsin, USA
Contact:

Post by EldarionII » Fri Jul 02, 2004 3:06 am

LOL! But I will be using quotes from that post. Don't get cocky now CTC. :D

Locked

Return to “2.0.x Support Forum”