[ABD] ACP Mass PM 1.0.1

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
cheesypeanut
Registered User
Posts: 121
Joined: Mon May 05, 2003 12:51 am
Location: England

[ABD] ACP Mass PM 1.0.1

Post by cheesypeanut »

I know this has been done many times before, but I really couldn't find a simple one to meet my needs.

Here we go, hope it works satisfactorily.

Code: Select all

##############################################################
## MOD Title: ACP Mass PM
## MOD Author: cheesypeanut < simonpitfield@frogspawn.org > (Simon Pitfield) http://www.frogspawn.org/
## MOD Description: Like Mass E-mail, but sends a PM to all forum users instead. Accessible through the ACP.
## MOD Version: 1.0.1
##
## Installation Level: (Easy)
## Installation Time: 2 Minutes
## Files To Edit: includes/emailer.php
##                language/lang_english/lang_admin.php
##               
## Included Files: admin/admin_mass_pm.php
##                 includes/functions_mass_pm.php
##                 templates/subSilver/admin/mass_pm_body.tpl
##############################################################
## For Security Purposes, Please Check: http://www.phpbb.com/mods/ for the
## latest version of this MOD. Downloading this MOD from other sites could cause malicious code
## to enter into your phpBB Forum. As such, phpBB will not offer support for MOD's not offered
## in our MOD-Database, located at: http://www.phpbb.com/mods/
##############################################################
## Author Notes: This has to be the simplest Mass PM MOD around :P
##
##############################################################
## MOD History:
##
##   2004-08-07 - Version 1.0.0
##      - First Release
##
##   2004-08-07 - Version 1.0.1
##      - Fixed includes/emailer.php so MOD works with boards prior to 2.0.10
##
##############################################################
## Before Adding This MOD To Your Forum, You Should Back Up All Files Related To This MOD
##############################################################
Grab it here.
Last edited by 3Di on Sat Aug 07, 2004 9:25 am, edited 1 time in total.
User avatar
Anon
Former Team Member
Posts: 7019
Joined: Fri Jan 02, 2004 7:33 am
Location: Christchurch, New Zealand

Post by Anon »

Installed on a phpBB 2.0.8 CVS from area51.phpbb.com and tried sending PM

It sent it, but came up with this error

Code: Select all

Failed sending email :: PHP :: 

DEBUG MODE

Line : 234
File : ***Install Folder***\www\phpbb2.0\includes\emailer.php
cheesypeanut
Registered User
Posts: 121
Joined: Mon May 05, 2003 12:51 am
Location: England

Post by cheesypeanut »

Bit wierd that.

I'm running 2.0.10 and it runs beautifully.

[removed as to not confuse people]

Try this. Boards prior to 2.0.10 need the code below, however as of now it is included in the MOD install template.

Code: Select all

# 
#-----[ OPEN ]------------------------------------------------ 
# 
includes/emailer.php 

# 
#-----[ FIND ]------------------------------------------------ 
# 
function send()

# 
#-----[ REPLACE WITH ]---------------------------------------- 
#

function send($error_level=0)


# 
#-----[ FIND ]------------------------------------------------ 
# 
// Did it work?
if (!$result

#
#-----[ IN-LINE FIND ]----------------------------------------
#
)

# 
#-----[ IN-LINE BEFORE, ADD ]--------------------------------- 
#
&& !$error_level

# 
#-----[ SAVE/CLOSE ALL FILES ]-------------------------------- 
# 
# EoM 
Last edited by cheesypeanut on Sat Aug 07, 2004 9:24 am, edited 1 time in total.
User avatar
Anon
Former Team Member
Posts: 7019
Joined: Fri Jan 02, 2004 7:33 am
Location: Christchurch, New Zealand

Post by Anon »

Ah cool. It worked :D

Works like a charm. Great MOD
davood
Registered User
Posts: 3
Joined: Thu Aug 05, 2004 8:23 pm
Contact:

Post by davood »

nice mod... i like this one more that the one by Niels
Davood aka bcs10
Project Manager Extreme phpBB LE

-------------------------------------------
Using 2.0.10
cheesypeanut
Registered User
Posts: 121
Joined: Mon May 05, 2003 12:51 am
Location: England

Post by cheesypeanut »

Anon wrote: Ah cool. It worked :D

Works like a charm. Great MOD


Awesome, which bit of code did you use, or both?

I will add it to the MOD template.
User avatar
Anon
Former Team Member
Posts: 7019
Joined: Fri Jan 02, 2004 7:33 am
Location: Christchurch, New Zealand

Post by Anon »

Editing /indcudes/functions_mass_pm.php didn't work, but editing includes/emailer.php did
cheesypeanut
Registered User
Posts: 121
Joined: Mon May 05, 2003 12:51 am
Location: England

Post by cheesypeanut »

Tres excellent my friend from Down Under. Thank you very much, I will update it now :D
MaddoxX
Registered User
Posts: 450
Joined: Sat May 15, 2004 4:43 pm
Location: Russia

Post by MaddoxX »

thanks for this great mod :)
:D
Erikina
Registered User
Posts: 145
Joined: Fri Jul 09, 2004 11:27 am
Location: Queensland, Australia

Post by Erikina »

Nice Work, I like mods that involve small amounts of editing existing files and no database changes :D
-Eric Springer
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

i dont know if it is because i am running a windows server,but it takes forever to send a PM to 5 users
I also get this:
Failed sending email :: PHP ::

DEBUG MODE

Line : 234
File : 1
Whos missing up my sig?
cheesypeanut
Registered User
Posts: 121
Joined: Mon May 05, 2003 12:51 am
Location: England

Post by cheesypeanut »

The fix is above mate, look up. It's also included in the current version.
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

With the fix i get this:
Failed sending email :: PHP ::

DEBUG MODE

Line : 234
File : c:\program files\shaun\www\includes\emailer.php

...I think the problem is that i am running this forum off of my computer,where i cant send emails... :cry:
Whos missing up my sig?
MaddoxX
Registered User
Posts: 450
Joined: Sat May 15, 2004 4:43 pm
Location: Russia

Post by MaddoxX »

Shof515 wrote: With the fix i get this:
Failed sending email :: PHP ::

DEBUG MODE

Line : 234
File : c:\program files\shaun\www\includes\emailer.php

...I think the problem is that i am running this forum off of my computer,where i cant send emails... :cry:

Maybe, because it works fine here =/
:D
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

once my other site gets running,then i will install this mod and see if it works,since it can send mails and its on a Linix server
Whos missing up my sig?
Locked

Return to “[2.0.x] MODs in Development”