[MODDB] Auto Cookies

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

[MODDB] Auto Cookies

Post by geocator »

This is now in the database please go to this topic: http://www.phpbb.com/phpBB/viewtopic.php?t=228741
Last edited by geocator on Thu Sep 30, 2004 8:04 pm, edited 10 times in total.
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

I have made this mod load all of the phpBB2 stuf,like the headers and everything else.Heres the file:
http://shof515.com/cookie.zip
Whos missing up my sig?
geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator »

Shof515 wrote: I have made this mod load all of the phpBB2 stuf,like the headers and everything else.Heres the file:

http://shof515.com/cookie.zip



Wow, thanks a lot. Updated origianl post to reflect changes.
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

One thing that will be nice,is have this page work in the admin panel
Whos missing up my sig?
whoo
Registered User
Posts: 575
Joined: Fri Mar 07, 2003 4:12 am

Post by whoo »

ermm what is this sposed to do? it doesnt show my current settings, and its also doesnt appear to be to offering anything but blank choices. (im lost)
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

its suppose to show up infomation about the cookies,and the right cookies setting
Whos missing up my sig?
User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut »

Some people are getting blank settings...and I'm not sure why. Obviously get_env isn't working right, but I can't say I have ever seen that happen before.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

i dont this script is not getting the right infomation,cuz i think some of the stuff is wrong like:
Cookie Domain: .www.shof515.com
they should be no . before the wwww
and the Cookie Name: can also be wrong

when i test this script on my other site,there are some small problems like the domain and the name
Whos missing up my sig?
geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator »

I am gonna have to look at some of it the cookie domain should end up as .domainname.com

Any other problems please let us know so we can fix it.
geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator »

Alright big updates. No more getenv should solve problems with blanks. Also fixed the cookie domain issue. Further improved the interface.

whoo: would you please test this and see if you get values now. you should but I would like to make sure. Thanks.
geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator »

One more update:

Removed security check (pointless, if these setting are wrong you cant login)
Cleaned up code
BulletHead
Registered User
Posts: 30
Joined: Tue May 11, 2004 5:00 pm

Post by BulletHead »

i get this error

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/ffighter/public_html/dean/cookie.php on line 2
{\rtf1\ansi\ansicpg1252\deff0\deflang2057{\fonttbl{\f0\froman\fcharset0 Times New Roman;}{\f1\fswiss\fcharset0 Arial;}} {\*\generator Msftedit 5.41.15.1503;}\viewkind4\uc1\pard\sb100\sa100\f0\fs24 \par \pard\f1\fs20\par }
geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator »

This is created by saving the file in something other than text.
Enkil
Registered User
Posts: 25
Joined: Sun Aug 15, 2004 8:37 am
Contact:

Thanks for the help.

Post by Enkil »

Thanks for the help!
it really fixed my issue!
BulletHead
Registered User
Posts: 30
Joined: Tue May 11, 2004 5:00 pm

Post by BulletHead »

What you mean something other than text.i open NotePad copy and paste the code in and save it with the name cookie.php
Locked

Return to “[2.0.x] MODs in Development”