user warnings / ban info in viewtopic

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
TTInternetHelp
Registered User
Posts: 77
Joined: Tue Nov 17, 2009 11:27 pm

Re: user warnings / ban info in viewtopic

Post by TTInternetHelp » Wed Feb 17, 2010 3:00 pm

RMcGirr83 wrote:Did you install this mod? The code above will not work until this mod is installed.

Yes I have this mod working, I see

BANNED_USERS
SUSPENDED_USERS

at the groups, so the mod is working! But if I do wat you says nothing will happend and the banned username stil not strikethrough!!

My style is subsilver2 based, so do I need to do something else????

Thank you for your quick reply

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: user warnings / ban info in viewtopic

Post by RMcGirr83 » Wed Feb 17, 2010 3:15 pm

This mod has nothing to do with groups.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

TTInternetHelp
Registered User
Posts: 77
Joined: Tue Nov 17, 2009 11:27 pm

Re: user warnings / ban info in viewtopic

Post by TTInternetHelp » Wed Feb 17, 2010 5:58 pm

hmmmm.... strange because after doing this mod I have that????????

Wat do I wrong, because if I reinstall this mod I reseave a error on the userpage

This user don't exist!

But the user exist and is banned?????


So can you help me pleace with this

kocureq
Registered User
Posts: 124
Joined: Sat Apr 11, 2009 7:59 pm

Re: user warnings / ban info in viewtopic

Post by kocureq » Sat Apr 03, 2010 9:49 pm

The "memberlist" modifications don't work when I try to install them with automod, automod cannot find the "sear for" sections.

Is it just my board, or is it that the mod development has been stopped and it's incompatible with the latest phpBB version?

bibendum92
Registered User
Posts: 9
Joined: Sun Oct 10, 2004 10:33 am

Re: user warnings / ban info in viewtopic

Post by bibendum92 » Mon Apr 05, 2010 12:33 am

Hi Everybody

I'm trying to install this mod but i don't understand this tip :

You said find this in member list :

Code: Select all

trigger_error('NO_USER');
         }
But in this file, i can find this code 5 times !!!!

Thanks for your help.

User avatar
bonelifer
Community Team Member
Community Team Member
Posts: 3475
Joined: Wed Oct 27, 2004 11:35 pm
Name: William
Contact:

Re: user warnings / ban info in viewtopic

Post by bonelifer » Mon Apr 05, 2010 12:56 am

bibendum92 that's true, but all FINDS are in ORDER. Therefore if you install from top to bottom then you don't have to worry about that.
Knowledge Base | phpBB Board Rules | Search Customisation Database
Image
Please don't contact me via PM or email for phpBB support .

bibendum92
Registered User
Posts: 9
Joined: Sun Oct 10, 2004 10:33 am

Re: user warnings / ban info in viewtopic

Post by bibendum92 » Mon Apr 05, 2010 11:37 am

Thanks a lot

That's work perfectly.

Phil7789
Registered User
Posts: 32
Joined: Mon Mar 22, 2010 3:16 pm
Location: Germany

Re: user warnings / ban info in viewtopic

Post by Phil7789 » Mon Apr 05, 2010 2:10 pm

Hi,
i have a little problem with this mod ^^

I am using a subsilver2 based style ( AeroBlue ) and while viewing the profile there is no "banned" status shown, just the warnings and the two options for making notes or warnings. I already doublechecked the memberlist.php and everything seems to be correct there

I hope anybody can help me

Phil

kocureq
Registered User
Posts: 124
Joined: Sat Apr 11, 2009 7:59 pm

Re: user warnings / ban info in viewtopic

Post by kocureq » Mon Apr 05, 2010 7:20 pm

kocureq wrote:The "memberlist" modifications don't work when I try to install them with automod, automod cannot find the "sear for" sections.
OK, in my case install.xml was looking for

Code: Select all

			<!-- IF U_NOTES or U_WARN -->
			<dt>{L_WARNINGS}: </dt>
			<dd><strong>{WARNINGS}</strong> [ <a href="{U_NOTES}">{L_VIEW_NOTES}</a> <!-- IF U_WARN --> | <a href="{U_WARN}">{L_WARN_USER}</a> <!-- ENDIF -->]</dd>
			<!-- ENDIF -->
but I had this code instead

Code: Select all

			<!-- IF S_WARNINGS -->
			<dt>{L_WARNINGS}: </dt>
			<dd><strong>{WARNINGS}</strong><!-- IF U_NOTES or U_WARN --> [ <!-- IF U_NOTES --><a href="{U_NOTES}">{L_VIEW_NOTES}</a><!-- ENDIF --> <!-- IF U_WARN --><!-- IF U_NOTES --> | <!-- ENDIF --><a href="{U_WARN}">{L_WARN_USER}</a><!-- ENDIF --> ]<!-- ENDIF --></dd>
			<!-- ENDIF -->
So I had replaced the "search for" sections in actual install.xml.



For subsilver skin, in install.xml there was

Code: Select all

         <!-- IF U_NOTES or U_WARN -->
            <tr>
               <td class="gen" align="{S_CONTENT_FLOW_END}" valign="top" nowrap="nowrap">{L_WARNINGS}: </td>
               <td width="100%"><b class="gen">{WARNINGS}</b><br /><span class="genmed">[ <a href="{U_NOTES}">{L_VIEW_NOTES}</a> <!-- IF U_WARN --> | <a href="{U_WARN}">{L_WARN_USER}</a> <!-- ENDIF -->]</span></td>
            </tr>
         <!-- ENDIF -->
but I had on my board

Code: Select all

			<!-- IF S_WARNINGS -->
				<tr>
					<td class="gen" align="{S_CONTENT_FLOW_END}" valign="top" nowrap="nowrap">{L_WARNINGS}: </td>
					<td width="100%"><b class="gen">{WARNINGS}</b><!-- IF U_NOTES or U_WARN --><br /><span class="genmed"> [ <!-- IF U_NOTES --><a href="{U_NOTES}">{L_VIEW_NOTES}</a><!-- ENDIF --> <!-- IF U_WARN --><!-- IF U_NOTES --> | <!-- ENDIF --><a href="{U_WARN}">{L_WARN_USER}</a><!-- ENDIF --> ]</span><!-- ENDIF --></td>
				</tr>
			<!-- ENDIF -->

And the mod installed fine.



@author: please check if the same problems exist on vanilla phpBB 3.0.6, and if yes, update the install.xml with my fixes so that you have a complete package.

Locked

Return to “[3.0.x] MOD Database Releases”