Error when users post to forums

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
theaustintroncao
Registered User
Posts: 5
Joined: Sat Sep 18, 2010 9:57 am

Error when users post to forums

Post by theaustintroncao »

Support Request Template
What version of phpBB are you using? phpBB 3.0.7-PL1
What is your board's URL? http://sloriders.com
Who do you host your board with? doreo
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Fresh Install
Do you have any MODs installed? Yes
Is registration required to reproduce this issue? Yes
What MODs do you have installed? advertisement manager & phpbb calandar
What styles do you currently have installed? prosilver, getaway, hestia blue, getaway green, ficebusi 2, subadreas, subsilver 2, glass
What language(s) is your board currently using? english
Which database type/version are you using? MySQL 4
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? Nellie
What password can be used to view this issue? nellie
When did your problem begin? began getting posts from users about 4 or 5 days ago
Please describe your problem. When posting new topics or replys nearly everytime get the following error. Posts go up on the forum, but this error is returned. Had read in another forum that it may be related to email settings and email notifications havent worked correctly since i started working on site a month or so ago. changed settings a week or so ago and error messages stopped for a few days.
General Error
SQL ERROR [ mysql4 ]

MySQL server has gone away [2006]

BACKTRACE

FILE: includes/db/dbal.php
LINE: 264
CALL: dbal->sql_error()

FILE: includes/functions_posting.php
LINE: 1343
CALL: dbal->sql_transaction()

FILE: includes/functions_posting.php
LINE: 2588
CALL: user_notification()

FILE: posting.php
LINE: 1108
CALL: submit_post()
User avatar
d1m0
Registered User
Posts: 127
Joined: Wed Nov 25, 2009 9:20 am

Re: Error when users post to forums

Post by d1m0 »

The error "MySQL server has gone away" is most probably caused either by a crashed table or by a heavy SQL query which takes too long to execute and as a result the mysql server times out.

If you have recently enabled any new mods, I would advise you to disable them and see if this helps. You can also contact your host and ask them to investigate the issue.
SiteGround Technical Support Team Member
Check out our special phpBB hosting package
theaustintroncao
Registered User
Posts: 5
Joined: Sat Sep 18, 2010 9:57 am

Re: Error when users post to forums

Post by theaustintroncao »

@D1m0
thank you i will go in and disable my mods and see if that helps out. I also just noticed that my mysql version is MySQL 5.0.91 according to the ACP, but in the error and in my template above is indicated 4.0... let me know if that would cause any errors.
If you have a moment could you also see my post below and let me know if you have any ideas on that one or maybe these two are related?
http://www.phpbb.com/community/viewtopi ... &t=2104557
thank you
austin
User avatar
soumik
Registered User
Posts: 486
Joined: Tue Nov 06, 2007 7:27 pm
Contact:

Re: Error when users post to forums

Post by soumik »

I also just noticed that my mysql version is MySQL 5.0.91 according to the ACP, but in the error and in my template above is indicated 4.0... let me know if that would cause any errors.
That means nothing. :)

Please disable your mods one by one and see if it helps to alleviate the error.
Powered by chocolate
Locked

Return to “[3.0.x] Support Forum”