ACTIVE TAB HELP

For support and discussion related to templates, themes, and imagesets in phpBB 3.0.
Scam Warning
Locked
User avatar
wads24
Registered User
Posts: 576
Joined: Fri Jun 10, 2005 4:44 am
Name: James

ACTIVE TAB HELP

Post by wads24 »

So, I just installed a rules mod that works off the FAQ page. I need help with the menu. When I click on the Rules TAB, I want that TAB to become active. Right now though it is active on the FAQ TAB. Below is the line I need help with.

Code: Select all

 <!-- IF S_HIDE_RULESMOD --><li<!-- IF $_SERVER['SCRIPT_NAME'] == 'faq.php?mode=rules' --> class="activetab"<!-- ENDIF -->><a href="{U_RULES}" title="{L_RULES_PAGE}"><span><img src="styles/prosilver/theme/images/icon_rules.gif" />&nbsp;{L_RULES}</span></a></li><!-- ENDIF -->
This is the FAQ TAB, and it works fine.

Code: Select all

<li<!-- IF $_SERVER['SCRIPT_NAME'] == '/faq.php' --> class="activetab"<!-- ENDIF -->><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}"><span><img src="styles/prosilver/theme/images/icon_faq.gif" />&nbsp;{L_FAQ}</span></a></li>
Thanks in advance for a reply.
User avatar
Josh
Former Team Member
Posts: 1882
Joined: Sun Jan 25, 2009 3:08 pm
Location: Melbourne, AUS
Name: Josh Simpson
Contact:

Re: ACTIVE TAB HELP

Post by Josh »

$_SERVER['SCRIPT_NAME']will not work because it only returns the name and not the parameters.

another way to do this, is define your own template variables.
can you please provide a link to your board?
Josh Simpson- Formerly known as "HardStyle"
Styles: Submission Policy | Database | Knowledge Base | Demo
Please do not PM me for personal support.
Image
User avatar
wads24
Registered User
Posts: 576
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: ACTIVE TAB HELP

Post by wads24 »

PM sent... Thanks for your help.
Thanks in advance for a reply.
Locked

Return to “[3.0.x] Styles Support & Discussion”