Mass email not working

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
beney14574
Registered User
Posts: 3
Joined: Tue Feb 08, 2011 10:26 pm

Mass email not working

Post by beney14574 »

Hey,

I am having problems troubleshooting mass email function is phpbb 3.0.8.
The system will send and receive individual emails, but when I send mass email under SYSTEMS in the the ADMIN I get an error.

Any ideas where to and what to look for?

Thanks,

Brian
Snobothehobo
Registered User
Posts: 19
Joined: Fri Jun 12, 2009 11:18 pm

Re: Mass email not working

Post by Snobothehobo »

Could you please post the error you're receiving?
K_B
Registered User
Posts: 1
Joined: Sat Mar 05, 2011 11:10 pm

Re: Mass email not working

Post by K_B »

I'm actually have the same problem. I can send an email to user groups or individuals but not to all forum members. I'm having a hard time figuring out exactly what files I need to re-copy from the 3.0.8 update. I'm not really even sure if that's the proper method to solve this issue.

The only error I have to go on is what is shown in the Error Log:


E-mail error
» EMAIL/PHP/mail()
/forum/adm/index.php

Additional Info:

Support Request Template
What version of phpBB are you using? phpBB 3.0.8
What is your board's URL? http://www.aroararacing.org/forum
Who do you host your board with? HostPC
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Update from a previous version of phpBB3
Do you have any MODs installed? No
Is registration required to reproduce this issue? Yes
What version of phpBB3 did you update from? phpBB 3.0.7
What styles do you currently have installed? none
What language(s) is your board currently using? english
Which database type/version are you using? MySQL 5
What is your level of experience? New to phpBB but not PHP
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
When did your problem begin? No answer given
Please describe your problem. No answer given
Generated by SRT Generator ($Rev: 4778 $)
Pony99CA
Registered User
Posts: 4783
Joined: Thu Sep 30, 2004 3:13 pm
Location: Hollister, CA
Name: Steve
Contact:

Re: Mass email not working

Post by Pony99CA »

I'm also getting the same error. Here's my SRT:

Support Request Template
What version of phpBB are you using? phpBB 3.0.8
What is your board's URL? http://progunforums.com
Who do you host your board with? inmotionhosting.com
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Fresh Install
Do you have any MODs installed? No
Is registration required to reproduce this issue? Yes
What styles do you currently have installed? ProSilver
What language(s) is your board currently using? British English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
When did your problem begin? When we first tried sending Mass E-mail to all users.
Please describe your problem. One admin got the the following in the Error Log after trying to send Mass E-mail to all users:

E-mail error
>> EMAIL/PHP/mail()
/adm/index.php

Another admin is also getting this message, although I don't know who he sent E-mail to.

I can send Mass E-mail to the Administrators group and not get that error.

Enable board-wide e-mails is set to Enabled, and the Use SMTP server for e-mail setting is set to No.
Generated by SRT Generator ($Rev: 4778 $)

Steve
Silicon Valley Pocket PC (http://www.svpocketpc.com)
Creator of manage_bots and spoof_user (ask me)
Need hosting for a small forum with full cPanel & MySQL access? Contact me or PM me.
Pony99CA
Registered User
Posts: 4783
Joined: Thu Sep 30, 2004 3:13 pm
Location: Hollister, CA
Name: Steve
Contact:

Re: Mass email not working

Post by Pony99CA »

To follow up on this problem, it seems to be related to the following code in \includes\acp\acp_email.php:

Code: Select all

$max_chunk_size = 50;
Sending E-mail to 50 recipients at once seems to be disallowed by my client's hosting company. I changed that to 40 and the Mass E-mail to all users seemed to work.

So why doesn't the Mass E-mail function respect the E-mail package size setting on the E-mail settings page of the ACP's General tab? That seems like a bug to me as it requires a code change to fix.

If there's a good reason to not respect that setting, the maximum number of recipients should be allowed to be set on the Mass E-mail page of the System tab.

Any developers care to comment?

Steve
Last edited by Pony99CA on Sat Apr 30, 2011 3:34 pm, edited 1 time in total.
Silicon Valley Pocket PC (http://www.svpocketpc.com)
Creator of manage_bots and spoof_user (ask me)
Need hosting for a small forum with full cPanel & MySQL access? Contact me or PM me.
User avatar
Martin Truckenbrodt
Registered User
Posts: 3045
Joined: Sun Mar 23, 2003 6:22 pm
Location: Franconia
Name: Martin Truckenbrodt
Contact:

Re: Mass email not working

Post by Martin Truckenbrodt »

Hello,
you can have a look here: http://www.phpbb.com/customise/db/mod/m ... /faq/f_385

and here: http://www.phpbb.com/customise/db/mod/m ... ecipients/

IMO the max chunk size setting should be editable from the ACP and not be hardcoded as it is at the moment. It's a core or basic setting. Perhaps somebody wants to write a patch for Ascraeus?

BTW: Multiple Newsletters Add On is not using this setting. No chunks.

Bye Martin
Free tutorial: Installing MODs in phpBB 3.0
Advanced Block MOD - Prevent spam on your phpBB 3.0 board with Stop Forum Spam, BotScout, Akismet, Project Honey Pot and several IP-RBL and Domain-RBL DNS blacklists!
My MODs
Use the official phpBB Ideas to vote missing core features!!!
Pony99CA
Registered User
Posts: 4783
Joined: Thu Sep 30, 2004 3:13 pm
Location: Hollister, CA
Name: Steve
Contact:

Re: Mass email not working

Post by Pony99CA »

Thanks, Martin. However, I don't think that I need an official MOD; just changing that one line seems to work.
Martin Truckenbrodt wrote:IMO the max chunk size setting should be editable from the ACP and not be hardcoded as it is at the moment. It's a core or basic setting. Perhaps somebody wants to write a patch for Ascraeus?
I agree. The Bulk Email topic confirms that the E-mail package size option is different than the maximum number of recipients, which is not an ACP option. :(

Come on, developers, this seems to be the source of ongoing problems and is very easy to fix. Let's make sure this is done in 3.0.9 or 3.1. :D

Steve
Silicon Valley Pocket PC (http://www.svpocketpc.com)
Creator of manage_bots and spoof_user (ask me)
Need hosting for a small forum with full cPanel & MySQL access? Contact me or PM me.
Oleg
Former Team Member
Posts: 1221
Joined: Sat Jan 30, 2010 4:42 pm
Location: NYC
Contact:

Re: Mass email not working

Post by Oleg »

php mail function does not provide a way to retrieve errors. See http://tracker.phpbb.com/browse/PHPBB3- ... ment-35644 for example. To my knowledge there is nothing we can do to fix this.

Please try smtp to localhost instead.

As far as mass email not respecting various limits, from the multiple support topics I am getting the impression that this is a real issue but so far I do not believe anyone filed a bug ticket clearly describing the problem.
Participate in phpBB development: Get involved | Issue tracker | Report a bug | Development board | [url=irc://chat.freenode.net/phpbb-dev]Development IRC chat[/url]
My stuff: mindlinkgame.com
User avatar
Martin Truckenbrodt
Registered User
Posts: 3045
Joined: Sun Mar 23, 2003 6:22 pm
Location: Franconia
Name: Martin Truckenbrodt
Contact:

Re: Mass email not working

Post by Martin Truckenbrodt »

Hello nn-,
I think http://www.phpbb.com/customise/db/mod/m ... /faq/f_385 tells all things phpBB3 using webmasters have to know about the email settings. 1. and 4. are the default scenarios. People whom need to configure 2. or 3. should have enough knowledge about these things. Perhaps for 2. sometimes the needed knowledge is missing.

I think the email settings thing is a very important thing.

I think following things should be optimized:
  • The max chunk size setting should be added to the E-mail settings ACP page. IMO the default value should be 10 and not 50.
  • I think it should be quite easy to analyse the email settings within the setup automatically and to give some advices based by the given email address and sitename. Although at least for the smtp settings it should be quite easy to display recommendations for the settings based by the sitename and the email address, too. Some kind of documentation should be linked or added, too.
  • Within the phpBB initial setup a e-mail test should be added.
  • These analyse and test things should be added to the E-mail settings ACP page, too.
Bye Martin
Free tutorial: Installing MODs in phpBB 3.0
Advanced Block MOD - Prevent spam on your phpBB 3.0 board with Stop Forum Spam, BotScout, Akismet, Project Honey Pot and several IP-RBL and Domain-RBL DNS blacklists!
My MODs
Use the official phpBB Ideas to vote missing core features!!!
User avatar
jim 777
Registered User
Posts: 105
Joined: Wed Apr 13, 2011 11:56 pm
Location: Sonoma County
Name: Jim
Contact:

Re: Mass email not working

Post by jim 777 »

I had the same issue as the OP and took much edits and attempts before I seemingly got it. However with all the changes, I don't know exactly the changes I made but I know it wasn't to any of the files (php or otherwise).

Here are my settings that I think I changed to get things to work. Maybe they'll help.

General Settings
Most left at default
"E-mail function name:" mail
"E-mail package size:" 0

Under General tab in ACP > E-mail settings > SMTP settings
"Use SMTP server for e-mail:" Yes
"SMTP server address:" tls://smtp.gmail.com (this is dependent on your normal email service, I use Gmail)
"SMTP server port:" 465
"Authentication method for SMTP:" PLAIN
"SMTP Username:" is your email username
"SMTP Password:" is your email password

I remember spending much time Googling the proper gmail settings before getting it to work. Hopefully this will help someone. I know I spent a lot of time trying to figure it out and sent out a bunch of test emails.
Pony99CA
Registered User
Posts: 4783
Joined: Thu Sep 30, 2004 3:13 pm
Location: Hollister, CA
Name: Steve
Contact:

Re: Mass email not working

Post by Pony99CA »

nn- wrote: As far as mass email not respecting various limits, from the multiple support topics I am getting the impression that this is a real issue but so far I do not believe anyone filed a bug ticket clearly describing the problem.
It's not that the Mass E-mail feature doesn't respect certain limits (in the ACP); it's that the limits can't be configured for your ISP/Web host.

I just opened http://tracker.phpbb.com/browse/PHPBB3-10164 which hopefully describes the problem. :D

Steve
Silicon Valley Pocket PC (http://www.svpocketpc.com)
Creator of manage_bots and spoof_user (ask me)
Need hosting for a small forum with full cPanel & MySQL access? Contact me or PM me.
User avatar
Martin Truckenbrodt
Registered User
Posts: 3045
Joined: Sun Mar 23, 2003 6:22 pm
Location: Franconia
Name: Martin Truckenbrodt
Contact:

Re: Mass email not working

Post by Martin Truckenbrodt »

Hello,
Max Email Recipients MOD is a very old MOD.

Perhaps the issue has been posted on Sourceforge?

BTW: Quite often the personalization of mass e-mails e.g. with Hello <username> is requested. For this the setting makes a conflict.

Bye Martin
Free tutorial: Installing MODs in phpBB 3.0
Advanced Block MOD - Prevent spam on your phpBB 3.0 board with Stop Forum Spam, BotScout, Akismet, Project Honey Pot and several IP-RBL and Domain-RBL DNS blacklists!
My MODs
Use the official phpBB Ideas to vote missing core features!!!
pursoontjen
Registered User
Posts: 3
Joined: Fri Sep 04, 2015 8:17 am

Re: Mass email not working

Post by pursoontjen »

Not getting any mail through either to any member, just getting this below

E-mail error
» EMAIL/SMTP
/adm/index.php

Could not get mail server response codes.
Backtrace

Connecting to plus.smtp.mail.yahoo.com:465
User avatar
Lumpy Burgertushie
Registered User
Posts: 68587
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Mass email not working

Post by Lumpy Burgertushie »

never seen that string for the yahoo servers before.

anyway, setup a email account for your board on your hosting account. so that you have something like:
admin@yourdomain.com

then use the email servers of the host that you are paying for.

use that email address for all board communications and that will solve most of your problems with email.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Mass email not working

Post by Oyabun1 »

Yahoo Mail can't be used successfully unless you are hosted by Yahoo, see Yahoo Mail.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
Locked

Return to “[3.0.x] Support Forum”