UBB.threads 7.5.5 to phpBB 3.0.9 Converter

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
Anti-Spam Guide
Locked
Panthera
Registered User
Posts: 1
Joined: Mon Sep 05, 2011 2:11 am

UBB.threads 7.5.5 to phpBB 3.0.9 Converter

Post by Panthera » Mon Sep 05, 2011 2:17 am

This converts users, forums, topics, posts, file attachments. It does not transfer polls or private messages.
Read the contents at the top of convert.php for more details. This software is as-is and I am not offering support for it - I just figured I'd share what I wrote for my own needs.

Please note that this is run from a command line and does not utilize phpBB's conversion package. It works only with MySQL. Also, this will likely work with other versions of UBB.threads 7 but I've only tested with 7.5.5.
Attachments
ubb-7.5.5_to_phpbb-3.0.9_converter.rar
UBB.threads 7.5.5 to phpBB 3.0.9 Converter
(86.43 KiB) Downloaded 232 times

jyt
Registered User
Posts: 18
Joined: Fri Dec 06, 2002 7:37 am
Location: quebec
Name: jean-yves theriault

Re: UBB.threads 7.5.5 to phpBB 3.0.9 Converter

Post by jyt » Sat Jun 18, 2016 3:59 pm

Hi I'm looking for a converter for Ultimate Bulletin Board 6.04 to phpBB, I know this is very old but what can I do, I now have the board on a new server, and it is not working at all:

Error including required files: Can't load 'Modules//auto/GD/GD.so' for module GD: Modules//auto/GD/GD.so: wrong ELF class: ELFCLASS32 at /usr/lib64/perl5/DynaLoader.pm line 200.
at Modules//Authen/Captcha.pm line 11
Compilation failed in require at Modules//Authen/Captcha.pm line 11.
BEGIN failed--compilation aborted at Modules//Authen/Captcha.pm line 11.
Compilation failed in require at ubb_lib.cgi line 5.
BEGIN failed--compilation aborted at ubb_lib.cgi line 5.
Compilation failed in require at ultimatebb.cgi line 64.
No such file or directory
Make sure these files exist, permissions are set properly, and paths are set correctly.

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: UBB.threads 7.5.5 to phpBB 3.0.9 Converter

Post by Lumpy Burgertushie » Sat Jun 18, 2016 4:22 pm

first thing to do is to upgrade from your UBB version to the one that this convertor is designed for.

once you have that, then you can try and convert to phpbb 3.0

this will not work for phpbb 3.1 at all.

once you get it converted to phpbb 3.0 you can then upgrade to phpbb 3.1


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

Locked

Return to “[3.0.x] Convertors”

Who is online

Users browsing this forum: No registered users and 6 guests