[ABD] Auto Video Embed v.0.0.3

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
NCSportbikes
Registered User
Posts: 4
Joined: Tue Feb 22, 2011 4:22 pm

Re: [DEV] Auto Video Embed v.0.0.2

Post by NCSportbikes »

Vimeo doesn't work..........everything else appears to work fine. Did something change with Vimeo so the original code doesn't work anymore.

This is what I have. Just turned everything on.....cause well wanted to see if it would all work. Youtube works fine, dailymotion fine......vimeo doesn't work.


$clipfish = true;
$dailymotion = true;
$flv = true;
$gametrailers = true;
$googlevideo = true;
$megavideo = true;
$metacafe = true;
$mp3 = true;
$myspace = true;
$myvideo = true;
$veoh = true;
$vimeo = true;
$yahoo = true;
$youtube = true;

stock code with no changes from myself.

if (($vimeo) && (strpos($preview_message, 'www.vimeo.com/') !== false)){
$preview_message = preg_replace('#<a class="postlink" href="http:\/\/www.vimeo.com\/(.*?)">(.*?)<\/a>#is', '<object type="application/x-shockwave-flash" style="width:400px;height:230px;" data="http://vimeo.com/moogaloop.swf?clip_id= ... =1"><param name="allowfullscreen" value="true" /><param name="allowscriptaccess" value="always" /><param name="movie" value="http://vimeo.com/moogaloop.swf?clip_id= ... llscreen=1" /></object>', $preview_message);}


all I get is the vimeo hyperlink

like this
http://vimeo.com/31241154



EDIT: FIGURED IT OUT! In the code it has if preview_message, 'www.vimeo.com/, well it doesn't use the www. So you can either have your members type in the www or remove www from the code. Works flawlessly now.
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by 4_seven »

First Post wrote:The right Syntax to Embed:
........
http://www.vimeo.com/9325052
.........
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by 4_seven »

new demo-link in first-post
Current Mods | Mod Base | php(BB) programming | No help via PM
Bash
Registered User
Posts: 337
Joined: Wed Mar 11, 2009 3:36 pm
Location: London, England
Name: Glenn

Re: [DEV] Auto Video Embed v.0.0.2

Post by Bash »

Can't wait for this. Is it recommended for live board yet?

4seven 4life.

*EDIT* I downloaded the mod for a peak and the instructions say:
2 Copy

root/mediaplayer/*.* > mediaplayer/*.*
But this isn't in the dl package :?:
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by 4_seven »

Bash wrote:Is it recommended for live board yet?
I think yes.
Bash wrote:But this isn't in the dl package :?:
Thx for the hint. Go to dl page, strg f5 site and dl again (was false package).
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by 4_seven »

Adding ModX to package, instead of instruction in post.
Current Mods | Mod Base | php(BB) programming | No help via PM
autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [DEV] Auto Video Embed v.0.0.2

Post by autinhyeu »

I was change #U to #is in auto_video_embed_post.php, but link dont show...

Check: http://forum.9xlove.com/nhat-ky-thanh-v ... tml#p98410

Thanks!
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by 4_seven »

hm, the video in post works.

have you read this in first post?
The right Syntax to Embed:

Code: Select all

http://www.clipfish.de/video/3272443/darth-vader-tanzt
http://www.dailymotion.com/video/xbf4y7_revenge-seoyeun-lee_creation
http://www.myflvsite.com/video/yourchosenfile.flv
http://www.gametrailers.com/video/jay-z-vs-dj-hero/62888
http://video.google.com/videoplay?docid=8135690990081075324&ei=_E6US5PKEoen-AbLyPnYAg&q=test#
http://www.megavideo.com/?v=DK2AZWPO
http://www.metacafe.com/watch/4282595/new_peugeot
http://www.mymusicsite.com/audio/yourchosenfile.mp3
http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=4517474
http://www.myvideo.de/watch/6735176/the_nanny_hehe_ur_geil_xDDDDDDDDDDDDDD
http://www.veoh.com/browse/videos/category/movies_horror/watch/e9150
http://www.vimeo.com/9325052
http://video.yahoo.com/watch/6897444/17936899
http://www.youtube.com/watch?v=TyLV4lxMc1g
Current Mods | Mod Base | php(BB) programming | No help via PM
autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [DEV] Auto Video Embed v.0.0.2

Post by autinhyeu »

Yes, i saw... but i want below video have a link to that video...
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by 4_seven »

so additional, ok. you can also have it this way
http://www.4seven.de/forum/media/viewto ... 1043#p1043

click on Image

give a hint which, so i write instruction.
Current Mods | Mod Base | php(BB) programming | No help via PM
crashillo
Registered User
Posts: 1
Joined: Tue Dec 20, 2011 11:55 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by crashillo »

4_seven wrote:so additional, ok. you can also have it this way
http://www.4seven.de/forum/media/viewto ... 1043#p1043

click on Image

give a hint which, so i write instruction.
I'm interested on that mod for collapse videos, can you post the instructions please? :oops:
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by 4_seven »

I add instruction between the years..
Current Mods | Mod Base | php(BB) programming | No help via PM
cfotoceo
Registered User
Posts: 162
Joined: Tue Jan 12, 2010 11:34 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by cfotoceo »

Great mod but the gamtrailers is obsolete, they no longer support flash so that whole code needs to be re-done and I have no idea how to make the adjustments.

For those of us who are not coders this mod is not very easy. In fact, it's difficult to add to it. It does do what it says if and only if you get the code right. How come you did add facebook that is pretty common.

I do want to add cnet, mtv any ideas, has anyone ever compiled all the various codes that may be added and shared them, I searched for facebook for an hour and there was nothing, I am game to learn to teach me please.

I am doing something very wrong

Code: Select all

if (($facebook) && (strpos($preview_message, 'www.facebook.com/video/video.php?v=') !== false)){
$preview_message = preg_replace('#<a class="postlink" href="http:\/\/www.facebook.(.*?)\/video/video.php?v=\/(.*?)">(.*?)<\/a>#is', '<object width="320" height="240" ><param name="allowfullscreen" value="false" /><param name="allowscriptaccess" value="always" /><param name="movie" value="http://www.facebook.com/video/video.php?v=" /><embed src="http://www.facebook.com/video.php?v=" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="false" width="320" height="240"></embed></object>', $preview_message);}

Code: Select all

if (($facebook) && (strpos($message, 'www.facebook.com/video/video.php?v=') !== false)){
$message = preg_replace('#<a class="postlink" href="http:\/\/www.facebook.(.*?)\/video/video.php?v=\/(.*?)">(.*?)<\/a>#is', '<object width="320" height="240" ><param name="allowfullscreen" value="false" /><param name="allowscriptaccess" value="always" /><param name="movie" value="http://www.facebook.com/video/video.php?v=" /><embed src="http://www.facebook.com/video.php?v=" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="false" width="320" height="240"></embed></object>', $preview_message);}

http://www.phpbb.com/community/posting. ... &t=2017165 is what is supposed to show
User avatar
trigger_error
I've Been Banned!
Posts: 200
Joined: Mon Feb 21, 2011 1:27 pm

Re: [DEV] Auto Video Embed v.0.0.2

Post by trigger_error »

this is from first post
4_seven wrote:Example to modify and transform a existing BBCode to Auto Video Embed
http://www.4seven.de/forum/6test/viewto ... =147#p1475
cfotoceo
Registered User
Posts: 162
Joined: Tue Jan 12, 2010 11:34 am

Re: [DEV] Auto Video Embed v.0.0.2

Post by cfotoceo »

I read that, I just do not understand it. So I posted the code with hope to know where I went wrong.

I can't believe there is not a central thread that has a list of every addition i.e. like the thread here on BB Codes people simply dropped in what they did. It would be neat if this mod had the same. It would save people time and may in fact teach people as well.
Locked

Return to “[3.0.x] Abandoned MODs”

cron