[ABD] Share Topic Plus (for Facebook, Twitter & Google Plus)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
cossielee
Registered User
Posts: 101
Joined: Tue Jul 13, 2010 12:26 am

Re: [ALPHA] Share Topic Plus

Post by cossielee » Thu Nov 17, 2011 8:41 am

Is anyone getting the same Login Message issue with G+ that im getting?? (2 posts up)

Peter77sx
Registered User
Posts: 3257
Joined: Wed Nov 09, 2005 2:51 pm

Re: [ALPHA] Share Topic Plus

Post by Peter77sx » Thu Nov 17, 2011 9:03 am

If that's your site where you have those images hosted, then nope I don't have that issue. I can use google + fine on your board and anywhere else. btw, we can not view those images cuz of permissions etc..

cossielee
Registered User
Posts: 101
Joined: Tue Jul 13, 2010 12:26 am

Re: [ALPHA] Share Topic Plus

Post by cossielee » Thu Nov 17, 2011 9:42 am

Peter77sx wrote:If that's your site where you have those images hosted, then nope I don't have that issue. I can use google + fine on your board and anywhere else. btw, we can not view those images cuz of permissions etc..
Cheers mate, i have put them on my photobucket account so they should be visable now :oops:

I know now why it aint working, the email address i use is my google apps email address, so iv changed it to same one as my google+ email, its letting me post a comment on google but itss still wrong

The image/icon that shows on google+ is the first user on the threads sig.

The topic/thread title is correct BUT it contains the following info that seems to be taken BEFORE the actual g+ icon on the viewtopic page, I have social network links in my banner which is the first 6 items then its showing my directory to the topic.
Skip to content. RSS Facebook Twitter Google+ Podcast YouTube. Portal; Board Index; Site Features. Arcade. Game Nights; Points. Board index ‹ Coffin Dodgin Gaming ‹ Coffin Dodgin' Games ‹ RPG'.
..

WTF???

Think its time to disable it untill i get some support, though the FB and Twitter ones work perfect, just seems to be the g+ one thats borked :cry:

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8416
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [ALPHA] Share Topic Plus

Post by _Vinny_ » Fri Nov 18, 2011 12:19 am

cossielee, Thanks for reporting the errors. For me get a better solution for the problems, could you send me the link to your forum?
Leinad4Mind wrote:Do you have the portuguese language of the mod?

Cheers!
Not at the moment but will be available soon.

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8416
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [ALPHA] Share Topic Plus

Post by _Vinny_ » Fri Nov 18, 2011 7:17 pm

cossielee wrote:**EDIT** just noticed that on my page if i disable the Send Button and change to Box Count it moves all the boxes next to the page numbers, reguardless of width set, pic below.
Fix:
Open: styles/prosilver/template/viewtopic_body.html, find:

Code: Select all

<!-- IF U_MCP --><p>[&nbsp;<a href="{U_MCP}">{L_MCP}</a>&nbsp;]</p><!-- ENDIF -->
<!-- INCLUDE sharetopic_body.html -->
Replace with:

Code: Select all

<!-- INCLUDE sharetopic_body.html -->
<!-- IF U_MCP --><p>[&nbsp;<a href="{U_MCP}">{L_MCP}</a>&nbsp;]</p><!-- ENDIF -->
Already included in the new download.
cossielee wrote:Found another FB related bug, iv came across this before and i doubt there is much that can be done but when you 'Share' or 'Send' on facebook, its using random icon images once posted. I tested it and one post used my podcast icon and another used a rank image though the rank image that it used happens to be the rank of the last person to pot on the subject, no idea how it got my podcast icon though
The icon for posting on facebook, when sharing a link can be customized with Open Graph Protocol. I'll try to insert in the modification, but I think it looks better as a tip or FAQ. more info


-----------------------------------

A new download is available.

The only change is that now the Facebook language is available in list(ACP Settings - See screenshots). Who has installed, simply replace the files:
root/includes/acp/acp_share_topic_plus.php
root/language/en/mods/acp_share.php

And upload the new file:
root/FacebookLocales.xml

cossielee
Registered User
Posts: 101
Joined: Tue Jul 13, 2010 12:26 am

Re: [ALPHA] Share Topic Plus

Post by cossielee » Fri Nov 18, 2011 7:38 pm

Nice one vinny, will do those changes tonight ;) any ideas on the g+ problems im having??

User avatar
Zaishen
Registered User
Posts: 189
Joined: Sat Dec 18, 2010 6:08 am

Re: [ALPHA] Share Topic Plus

Post by Zaishen » Mon Nov 21, 2011 6:38 am

good mod, i wait the final version

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [ALPHA] Share Topic Plus

Post by keith10456 » Mon Nov 21, 2011 5:39 pm

Looks really good - especially considering it's only in Alpha. I look forward to the finished mod 8-)

User avatar
kmakoto
Registered User
Posts: 234
Joined: Mon Mar 01, 2010 11:35 pm

Re: [ALPHA] Share Topic Plus

Post by kmakoto » Wed Nov 23, 2011 1:00 am

if share facebook?

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8416
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [ALPHA] Share Topic Plus

Post by _Vinny_ » Wed Nov 23, 2011 2:00 am

kmakoto wrote:if share facebook?
What?

murdmon
Registered User
Posts: 189
Joined: Thu Sep 24, 2009 7:56 am

Re: [ALPHA] Share Topic Plus

Post by murdmon » Wed Nov 23, 2011 8:10 am

^^ :lol:

Question:
is there a way to choose what picture you want to display on facebook. when you click the like button the box shows up where you can type a message about the post...nice to also have the pic to choose

Great mod!

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8416
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [ALPHA] Share Topic Plus

Post by _Vinny_ » Wed Nov 23, 2011 5:40 pm

murdmon wrote:^^ :lol:

Question:
is there a way to choose what picture you want to display on facebook. when you click the like button the box shows up where you can type a message about the post...nice to also have the pic to choose

Great mod!
_Vinny_ wrote:The icon for posting on facebook, when sharing a link can be customized with Open Graph Protocol. I'll try to insert in the modification, but I think it looks better as a tip or FAQ. more info
;)

cossielee
Registered User
Posts: 101
Joined: Tue Jul 13, 2010 12:26 am

Re: [ALPHA] Share Topic Plus

Post by cossielee » Sat Nov 26, 2011 9:44 am

_Vinny_ wrote:
murdmon wrote:^^ :lol:

Question:
is there a way to choose what picture you want to display on facebook. when you click the like button the box shows up where you can type a message about the post...nice to also have the pic to choose

Great mod!
_Vinny_ wrote:The icon for posting on facebook, when sharing a link can be customized with Open Graph Protocol. I'll try to insert in the modification, but I think it looks better as a tip or FAQ. more info
;)
Vinny, i tried this and it didnt really work.

i used the following META code:

Code: Select all

<meta name="og:title" content="MY_SITENAME"/>
<meta name="og:type" content="website"/>
<meta name="og:url" content="http://www.MY_URL/"/>
<meta name="og:image" content="http://www.MY_URL/images/fbicon.png"/>
<meta name="og:site_name" content="MY_URL"/>
<meta name="fb:admins" content="USER_ID"/>
<meta name="og:description" content="A forum for PS3 gamer's where fun is the top priority."/>
By selecting the Send button on a topic i got the following info:

The og Title of site worked
The og URL worked but would not put in the actuall topic i was sending.
The og IMAGE i specified worked.
The og Site_Name worked, again with no connection to the topic i was sending.

When posted on facebook the image was NOT the one from the meta tags, again it was a random image form within the thread, the topic URL was Site_name/portal, thats not where it was posted from.

I messed about again and i seems its now using the icon that i specified, this works for me, im not saying it will work for everyone else, so heres what i added.

Create a image you want to use, mine was 200x200 and looks fine (not sure of actual size for FB)

OPEN overall_header
FIND

Code: Select all

<head>
BEFORE add:

Code: Select all

<html xmlns:og="http://ogp.me/website#" xmlns:fb="http://www.facebook.com/2008/fbml">
FIND

Code: Select all

<head>
AFTER ADD

Code: Select all

<meta name="og:type" content="website"/>
<meta name="og:image" content="http://www.ADD URL TO YOUR IMAGE HERE"/>
Refresh style template. Test it a couple of times, the first few attempts didnt work but now its working fine

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8416
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [ALPHA] Share Topic Plus

Post by _Vinny_ » Sat Nov 26, 2011 4:43 pm

Honestly, I would suggest some changes:

Code: Select all

<meta name="og:title" content="MY_SITENAME"/>
Replace with:

Code: Select all

<meta name="og:title" content="{TOPIC_TITLE}"/>
--------------------

Code: Select all

<meta name="og:url" content="http://www.MY_URL/"/>
It is useless when the URL of the topic is posted.

--------------------

Code: Select all

<meta name="og:site_name" content="MY_URL"/>
Replace with:

Code: Select all

<meta name="og:site_name" content="{SITENAME}"/>
--------------------

ie I only recommend:

Code: Select all

<meta name="og:title" content="{TOPIC_TITLE}" />
<meta name="og:type" content="website" />
<meta name="og:image" content="http://www.MY_URL/images/fbicon.png" />
<meta name="og:site_name" content="{SITENAME}" />
<meta name="og:description" content="Description of your board " />
To see if the facebook bot already recognizes the new tags, do the test: http://developers.facebook.com/tools/debug

cossielee
Registered User
Posts: 101
Joined: Tue Jul 13, 2010 12:26 am

Re: [ALPHA] Share Topic Plus

Post by cossielee » Sat Nov 26, 2011 5:13 pm

Nice one vinny, will try it out and get back to you :)

Locked

Return to “[3.0.x] Abandoned MODs”