Fatal error: Cannot redeclare user_get_id_name

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
adp2020
Registered User
Posts: 18
Joined: Sat Apr 09, 2011 12:23 pm

Fatal error: Cannot redeclare user_get_id_name

Post by adp2020 » Thu Jan 26, 2012 8:12 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.10
What is your board's URL? http://thed2boysclub.co.uk
Who do you host your board with? dream host
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Update from a previous version of phpBB3
Do you have any MODs installed? No
Is registration required to reproduce this issue? Yes
What version of phpBB3 did you update from? phpBB 3.0.9
What styles do you currently have installed? e-tec green modified
What language(s) is your board currently using? english
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
When did your problem begin? About a week ago,
I have updated as per instructions to the new version 10, The
Please describe your problem. Fatal error: Cannot redeclare user_get_id_name() (previously declared in /home/thedboy1/public_html/forums/includes/functions_user.php:27) in /home/thedboy1/public_html/forums/includes/functions_user.php on line 82

I have updated as per instructions to the new version 10, The fault is still there. But it only appears to 3 admin users which are listened as founders but it does not affect the test admin login.
Generated by SRT Generator

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51890
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Fatal error: Cannot redeclare user_get_id_name

Post by Brf » Thu Jan 26, 2012 8:21 pm

You have some sort of mod that is including includes/functions_user.php twice.

adp2020
Registered User
Posts: 18
Joined: Sat Apr 09, 2011 12:23 pm

Re: Fatal error: Cannot redeclare user_get_id_name

Post by adp2020 » Thu Jan 26, 2012 9:00 pm

A daft question, But what as I have not added any MODs.
But it only appears to 3 admin users not the test member which also has admin rights.

Also if I reload the page it works ok!!!

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51890
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Fatal error: Cannot redeclare user_get_id_name

Post by Brf » Thu Jan 26, 2012 9:07 pm

You do not say what page you are seeing this error. There are not that many pages which are supposed to load includes/functions_user.php.

adp2020
Registered User
Posts: 18
Joined: Sat Apr 09, 2011 12:23 pm

Re: Fatal error: Cannot redeclare user_get_id_name

Post by adp2020 » Thu Jan 26, 2012 9:13 pm

Brf wrote:You do not say what page you are seeing this error. There are not that many pages which are supposed to load includes/functions_user.php.
Sorry,
When in ACP and I what to see an inactive user I click their name and then....
Fatal error: Cannot redeclare user_get_id_name() (previously declared in /home/thedboy1/public_html/forums/includes/functions_user.php:27) in /home/thedboy1/public_html/forums/includes/functions_user.php on line 82

Appears. I then reload and it works, try to add or delete them then...
Fatal error: Cannot redeclare user_get_id_name() (previously declared in /home/thedboy1/public_html/forums/includes/functions_user.php:27) in /home/thedboy1/public_html/forums/includes/functions_user.php on line 82

Relaod and it works but any action to do with members it happens.
But if I log in as TEST it works fine, NO problems.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51890
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Fatal error: Cannot redeclare user_get_id_name

Post by Brf » Thu Jan 26, 2012 9:18 pm

Since you do not have any mods, do a file replacement:
*NOTE: Before proceeding backup all files and the database.*
  • Upload all new files from a download of the full version, EXCEPT for config.php, the /images and /files folders.
  • Go to yoursite.com/forumfolder/install/database_update.php
  • Let that run and then delete the install folder.
  • You now have a new up to date board containing all your users and posts but without any MODs that you might have had installed.

adp2020
Registered User
Posts: 18
Joined: Sat Apr 09, 2011 12:23 pm

Re: Fatal error: Cannot redeclare user_get_id_name

Post by adp2020 » Thu Jan 26, 2012 9:30 pm

Brf wrote:Since you do not have any mods, do a file replacement:
*NOTE: Before proceeding backup all files and the database.*
  • Upload all new files from a download of the full version, EXCEPT for config.php, the /images and /files folders.
  • Go to yoursite.com/forumfolder/install/database_update.php
  • Let that run and then delete the install folder.
  • You now have a new up to date board containing all your users and posts but without any MODs that you might have had installed.
Ive done all that and No good.
To be honest I also had our host check it out for me to make sure I did it right.

yamahar
Registered User
Posts: 42
Joined: Sun Dec 09, 2012 12:17 pm

Re: Fatal error: Cannot redeclare user_get_id_name

Post by yamahar » Sat Feb 09, 2013 8:43 pm

Did you fix this ? I seem to be having the same issue ?

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Fatal error: Cannot redeclare user_get_id_name

Post by Oyabun1 » Sat Feb 09, 2013 10:28 pm

yamahar wrote:Did you fix this ? I seem to be having the same issue ?
Please don't cross post (Re: Cannot redeclare user_get_id_name()) about the same issue in multiple topics.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

yamahar
Registered User
Posts: 42
Joined: Sun Dec 09, 2012 12:17 pm

Re: Fatal error: Cannot redeclare user_get_id_name

Post by yamahar » Sat Feb 09, 2013 10:53 pm

Oyabun1 wrote:
yamahar wrote:Did you fix this ? I seem to be having the same issue ?
Please don't cross post (Re: Cannot redeclare user_get_id_name()) about the same issue in multiple topics.
Ok mate, sorry.

Locked

Return to “[3.0.x] Support Forum”