[Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Ideas Centre
Post Reply
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17090
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

[Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by DavidIQ » Sat Mar 10, 2012 2:12 am

Use this topic to discuss the recent announcement of phpBB 3.1 "Ascraeus" to require PHP 5.3.3
Last edited by tbackoff on Thu Nov 15, 2012 8:33 pm, edited 1 time in total.
Reason: changed to 5.3.3
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Danielx64 » Sat Mar 10, 2012 3:48 am

All I can say right now is YES YES YES. Also considering that php 5.4.0 is out, it would be a good time to upgrade to php 5.3.x if one have not done so.

Now phpbb already support php 5.4.0 right?
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

Peter77sx
Registered User
Posts: 3257
Joined: Wed Nov 09, 2005 2:51 pm

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Peter77sx » Sat Mar 10, 2012 4:00 am

That's unfortunate. Maybe if I forward the announcement to my hosting, it will be a cool incentive to upgrade.

User avatar
/a3
Registered User
Posts: 411
Joined: Sun Sep 19, 2010 9:08 am
Location: /dev/random

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by /a3 » Sat Mar 10, 2012 4:25 am

Peter77sx wrote:That's unfortunate. Maybe if I forward the announcement to my hosting, it will be a cool incentive to upgrade.
I imagine phpBB 3.0 will be supported for at least a year after phpBB 3.1 has been released. And phpBB 3.1 hasn't been released yet, either.

But of course most people will be looking forward to the newest, latest and greatest version so far. :)
$ git commit -m "YOLO"

User avatar
Elias
Registered User
Posts: 4626
Joined: Sat Feb 25, 2006 4:31 pm
Location: In the Water!
Name: Elias

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Elias » Sat Mar 10, 2012 6:32 am

*Daniel wrote:All I can say right now is YES YES YES. Also considering that php 5.4.0 is out, it would be a good time to upgrade to php 5.3.x if one have not done so.
Yes sir!!

Glad to see it get accepted after a huge discussion at area51!
*Daniel wrote:Now phpbb already support php 5.4.0 right?
Oleg wrote:The next major release of phpBB, phpBB 3.1 "Ascraeus", will require PHP 5.3.2 or newer.
Thanks
"Mystery creates wonder, and wonder is the basis of man's desire to understand." - Neil Armstrong
|Installing Extensions|Writing Extensions|Extension Validation Policy|

User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by callumacrae » Sat Mar 10, 2012 6:38 am

Peter77sx wrote:That's unfortunate. Maybe if I forward the announcement to my hosting, it will be a cool incentive to upgrade.
Don't worry, 3.1 is a while off yet - they've got plenty of time to upgrade.
macr.ae = my website. you probably won't like it.
Proud user ofProud user of

User avatar
MichaelC
Consultant
Consultant
Posts: 3642
Joined: Mon Dec 21, 2009 3:36 pm
Location: Surrey, UK
Name: Michael Cullum
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by MichaelC » Sat Mar 10, 2012 8:12 am

3.0 will be supported for a while after 3.1 is released. Just as phpBB 2.0 was supported for a while after phpBB 3.0 was released.

This was announced a long time ago here.
:)
Formerly known as Unknown Bliss.
Formerly Website Team Lead/Manager & Development Team.
Please don't PM me for support (or stuff that belongs in the forums or tracker) but otherwise feel free


User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Jessica » Sun Mar 11, 2012 3:08 am

hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

brunoais
QA Team
Posts: 420
Joined: Wed Jun 18, 2008 10:50 am

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by brunoais » Sun Mar 11, 2012 10:29 am

Jessica wrote:hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good
x10hosting is used to keep the php version updated ;) .

User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by callumacrae » Sun Mar 11, 2012 12:02 pm

brunoais wrote:
Jessica wrote:hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good
x10hosting is used to keep the php version updated ;) .
Actually, we only updated to 5.3 about six months ago.

Now I just have to start bugging Corey about 5.4…
macr.ae = my website. you probably won't like it.
Proud user ofProud user of

brunoais
QA Team
Posts: 420
Joined: Wed Jun 18, 2008 10:50 am

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by brunoais » Sun Mar 11, 2012 5:53 pm

callumacrae wrote:
brunoais wrote:
Jessica wrote:hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good
x10hosting is used to keep the php version updated ;) .
Actually, we only updated to 5.3 about six months ago.

Now I just have to start bugging Corey about 5.4…
What? phpbb.com is hosted at x10hosting?

I think it has php 5.3 longer than that. I remember long ago doing stuff for php 5.3.* about 10 months ago or so.

Edit:
The update to php 5.3 was confirmed at 2/08/2011, 8 months ago.
callumacrae wrote: Now I just have to start bugging Corey about 5.4…
Let's do that by 5.4.2+. Before that there will be some fixing like there was with 5.3.*. No need to bug before that, I don't believe they will follow anyway.

User avatar
MichaelC
Consultant
Consultant
Posts: 3642
Joined: Mon Dec 21, 2009 3:36 pm
Location: Surrey, UK
Name: Michael Cullum
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by MichaelC » Sun Mar 11, 2012 6:05 pm

brunoais wrote:
callumacrae wrote:
brunoais wrote:
Jessica wrote:hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good
x10hosting is used to keep the php version updated ;) .
Actually, we only updated to 5.3 about six months ago.

Now I just have to start bugging Corey about 5.4…
What? phpbb.com is hosted at x10hosting?

I think it has php 5.3 longer than that. I remember long ago doing stuff for php 5.3.* about 10 months ago or so.

Edit:
The update to php 5.3 was confirmed at 2/08/2011, 8 months ago.
callumacrae wrote: Now I just have to start bugging Corey about 5.4…
Let's do that by 5.4.2+. Before that there will be some fixing like there was with 5.3.*. No need to bug before that, I don't believe they will follow anyway.
No. Callum works at x10hosting.

phpBB.com is on two servers hosting by OSUOSL.
:)
Formerly known as Unknown Bliss.
Formerly Website Team Lead/Manager & Development Team.
Please don't PM me for support (or stuff that belongs in the forums or tracker) but otherwise feel free

User avatar
DoYouSpeakWak
Registered User
Posts: 2307
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Name: Hans Lassen
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by DoYouSpeakWak » Tue Mar 13, 2012 9:30 am

5.4.0 is out but its not ready yet. Many of the php- modules havnt been updated yet.

But 5.3.2 or higher is in all the ubuntu, debian, fedora releases. Centos im not sure about. But anyone still running older php is a crappy host anyway. So no problems here im sure by the time 3.1 comes out 5.4 will be standard in most setups.
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid phpBB help and System administrator services.

User avatar
victory1
Registered User
Posts: 935
Joined: Sun Oct 10, 2010 6:47 pm
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by victory1 » Tue Mar 13, 2012 5:12 pm

I see on my cpanel that my host is using PHP 5.2.17, when I inquire when they will switch to 5.3, I was told how to switch to PHP 5.3.x?

By default, we use PHP 5.2.x on our systems, however if you wish to run PHP 5.3.x, please add the following line to your public_html .htaccess file:

AddType application/x-httpd-php53 php53 php

So just because your host is running 5.2, does not mean that 5.3 is not available. My ACP PHP Information says PHP Version 5.3.6

Post Reply

Return to “phpBB Discussion”