[ADB] Facebook For PhpBB Light

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Frikkie
Registered User
Posts: 78
Joined: Sat Jul 14, 2007 9:26 am

Re: [DEV] Facebook For PhpBB

Post by Frikkie » Sun Mar 11, 2012 11:57 am

Shucks, this is def not for a Police Pilot in South Africa.
Who can please teach me to install this FB Mod on my Forum.

Thanks
Frikkie

keitzy wrote:Sorry about that. It has been fixed. Just note that my personal site is half way through a code change and was nearing completion until a client wanted a website upgrade done asap.

sanderh
Registered User
Posts: 4
Joined: Sun Mar 11, 2012 12:22 pm

Re: [DEV] Facebook For PhpBB

Post by sanderh » Sun Mar 11, 2012 12:42 pm

is it possible to get the like-button switch on and off? to show and not show?
The Volkswagen Scirocco, either you love it, or hate it.

SciroccoForum.nl for all you scirocco-related information.

Vegano
Registered User
Posts: 6
Joined: Sun Mar 11, 2012 4:15 pm

Re: [DEV] Facebook For PhpBB

Post by Vegano » Sun Mar 11, 2012 11:13 pm

Hi!
I love this mod but can't get it to work. I did two tests. For the first I edited all files manual and used another style. For the second I used auto mod.

The one with auto mod doesn't function at all. If I want to register with facebook and push the I Agree to these terms button I get

Code: Select all

Fatal error: Cannot redeclare fb_language_select() (previously declared in /includes/functions_fb2011.php:32) in /functions_fb2011.php on line 46
If I go to facebook manager in the user control panel I get

Code: Select all

Fatal error: Cannot redeclare fb_language_select() (previously declared in /includes/functions_fb2011.php:32) in /functions_fb2011.php on line 46
The manual edited test with an alternative style (Artodia Helion) worked better. Registration also broke (all registration, fb and old way):

Code: Select all

Parse error: syntax error, unexpected $end in /cache/tpl_art-helion_ucp_register.html.php on line 147
but linking existing accounts with facebook works and it also works to login with facebook.

as this style didn't have a ucp_register.html template I didn't edit it or add the code somewhere else.

It would be really cool if we could help get this to work. The style is wonderful and your mod is just the bomb!

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [DEV] Facebook For PhpBB

Post by keitzy » Mon Mar 12, 2012 12:03 am

Come on people. Please provide links to websites where the mod is installed!!! :)

@sanderh - in the acp Facebook for phpBB manager section there is a switch to turn the like button off and on.
Image

rekabis
Registered User
Posts: 8
Joined: Sat Nov 10, 2007 7:50 am
Location: Kelowna, British Columbia, Canada
Contact:

Re: [DEV] Facebook For PhpBB

Post by rekabis » Mon Mar 12, 2012 12:39 am

It seems that your plugin is killing the ACP.

Whenever I try to install the plugin, I cannot seem to follow the additional instructions for setting up the tab on the ACP, and when I try to log out and log back in (to see if this will give me the step I cannot follow), the ACP itself gives me this error message:
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4592: require_once(functions_fb2011.php): failed to open stream: No such file or directory
In particular, when I try to follow your instructions to create a FB2011 tab, the following part:
Now click on Facebook 2011 in the Administration Control Panel Module Management Window.
Then on the right side at the bottom. From the add module pull down list select Facebook 2011 Settings.
does not work because there is no entry in the list that says “Facebook 2011 Settings”. In the end, the only way to regain control of the ADM (once I log out and log back in to see if that provides me with this setting) is to copy the files in _backups and dump them back into the root of the site, overwriting anything that was altered upon install.

sanderh
Registered User
Posts: 4
Joined: Sun Mar 11, 2012 12:22 pm

Re: [DEV] Facebook For PhpBB

Post by sanderh » Mon Mar 12, 2012 2:41 pm

keitzy wrote:Come on people. Please provide links to websites where the mod is installed!!! :)

@sanderh - in the acp Facebook for phpBB manager section there is a switch to turn the like button off and on.
what i mean is, users turn on and of the like button.

I got some old-timers on the forum who doesn't have facebook. and just hate the button.
but the young ones do like it.
and i do think you did a marvelous job.
The Volkswagen Scirocco, either you love it, or hate it.

SciroccoForum.nl for all you scirocco-related information.

User avatar
hejowicz
Registered User
Posts: 442
Joined: Sun Dec 23, 2007 4:03 pm

Re: [DEV] Facebook For PhpBB

Post by hejowicz » Mon Mar 12, 2012 11:44 pm

hejowicz wrote: i found error

there is a problem with non english characters
http://en.wikipedia.org/wiki/Polish_alphabet
(specials characters)

Instead of display proper characters during connecting, i get questions mark
Do you used utf8 encoding ?
error is on your test forum
http://www.damienkeitel.com/

btw. can you please publish new version of your mod
coz looking on files dates inside folder it's pretty old

thanks

Nonstopdrivel
Registered User
Posts: 19
Joined: Thu Jan 13, 2011 8:28 pm

Re: [DEV] Facebook For PhpBB

Post by Nonstopdrivel » Tue Mar 13, 2012 4:32 am

I have installed this mod on a sandbox version of my forum for testing purposes. It's connected to the same database as my live forum, so all posts are synchronized, but any changes to the sandbox code won't affect the usability of the live forum.

As others have noted, the Facebook login feature still doesn't work. Clicking on the login button sends you to the registration page. So I have disabled that feature for now. However, the Like button still works, with the caveat that the post on one's Facebook profile features the default phpBB logo instead of my forum logo. This must surely be an easy code fix.

I mentioned on your forum that I would be happy to beta test this mod, even if IE compatibility is not complete. Any idea when the beta will be released?

My test forum is at http://projectmw.com/sandbox/.

tassiedevil
Registered User
Posts: 4
Joined: Mon Feb 13, 2012 11:55 am

Re: [DEV] Facebook For PhpBB

Post by tassiedevil » Thu Mar 15, 2012 4:27 am

It seems there is some confusion over whether the existing software is being supported or if we should continue to wait for the new software to be released?

our forum has been waiting patiently for this new release, but it now seems that its further away than before. is it possible to get a clear ETA for this release, or are we better to work through installation errors with the previous release in order to get something functioning and take pressure off you to get the new release spot on?

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [DEV] Facebook For PhpBB

Post by keitzy » Sun Mar 18, 2012 1:09 am

Well for all the impatient people.
I am just letting you know that for the past two weeks, the kids and I have had whooping cough and we are still very sick.
So just be patient, I do not get paid to make this mod, so in my spare time I make progress. Fighting with IE while coughing ya lungs up is not something I feel like doing right now.
Please just wait a week or two for the new release.
Thank you :(
Image

User avatar
elvis_ef
Registered User
Posts: 44
Joined: Sun Feb 13, 2011 10:08 am

Re: [DEV] Facebook For PhpBB

Post by elvis_ef » Sun Mar 18, 2012 8:10 pm

What could be wrong here ? No button in profile.. No login button on the main site.. weird..

Screens:

1: http://img692.imageshack.us/img692/4439/png2pih.png (options, to see if it's ok - it's turn on)

2: http://img822.imageshack.us/img822/2358/png1ga.png (no button here)

Version 3.0.10
All code modifications done without automod and similar software - only manually.
The AppId and the secret are good, and configured well - active of course.

Vegano
Registered User
Posts: 6
Joined: Sun Mar 11, 2012 4:15 pm

Re: [DEV] Facebook For PhpBB

Post by Vegano » Sun Mar 18, 2012 10:41 pm

Hi keitzy ofcourse we don't mind to wait a week or two longer. But most of us are afraid that each next week we will have to wait another week.

You might think that you aren't paid for this but be sure that if you get it working you'll get more donations than if you would have been paid in advance. Already a few other posters said they would donate if it works and I would do the same. This kind of mod is just to great to hide from the public. While we could hire someone to do it for us for a few hundred dollars everyone (you included) would be better of to give a few bucks and get it available for everyone. In the end that is the idea of open source no?

It seems phpbb mods are becoming less and less open source and more about hiring programmers. That's a shame...

Bash
Registered User
Posts: 337
Joined: Wed Mar 11, 2009 3:36 pm
Location: London, England
Name: Glenn

Re: [DEV] Facebook For PhpBB

Post by Bash » Mon Mar 19, 2012 4:28 pm

Get well soon keitzy :)

User avatar
elvis_ef
Registered User
Posts: 44
Joined: Sun Feb 13, 2011 10:08 am

Re: [DEV] Facebook For PhpBB

Post by elvis_ef » Mon Mar 19, 2012 7:44 pm

Ok, I solved the problem. My mistake was a bad editing place for one modification in functions.php file.
Now I have a question about opengraph tags..

I am logged in on my board. Without logging in, there is no possibility to see any thread posts. That's my configuration. I have problem only with two tags:

Code: Select all

<meta property="og:title" content="{PAGE_TITLE}" />
<meta property="og:description" content="{SITE_DESCRIPTION}" />
{PAGE_TITLE} - should show the title of the page - unfortunately, it doesn't. Why is that ? Instead of this I see "Log in" when I use Facebook debugger (http://developers.facebook.com/tools/debug). This is for testing fb tags. It's weird, because even if I'm not logged in, I can see the thread name in the title bar of my browser.

I added my opengraph tags to my overall_header.html file.
There are also a <title> tags, which look like this:

Code: Select all

<title>{SITENAME} &bull; <!-- IF S_IN_MCP -->{L_MCP} &bull; <!-- ELSEIF S_IN_UCP -->{L_UCP} &bull; <!-- ENDIF -->{PAGE_TITLE}</title>
So it looks good, there is a {PAGE_TITLE} text, so it should work good - it seems there is the same part, but it's parsed or something.. so with the title tag it works great - with my opengraph, it's not.
Anyway, I would like to have here (in the opengraph <title> tag) my topic title, cause when somebody clicks on facebook link, should see earlier what the topic name is.

Im wondering where is the problem..

---

The second line of the tag with description - I need to put there for example first post description or if the link is a direct link to the post (is there a possibility after clicking on Like Button ?), the "liked" post description.

If anyone could help me or suggest sth, give advice... whatever.. I'd appreciate it. Thanks in advance...
PS.sorry for my english..

User avatar
Traction
Registered User
Posts: 288
Joined: Fri Jun 06, 2003 8:42 pm
Location: Staten Island, New York
Contact:

Re: [DEV] Facebook For PhpBB

Post by Traction » Tue Mar 20, 2012 7:07 am

This looks awesome, great work! :)
Failure is not an option.
Zap! Classic Video Game Forums

Locked

Return to “[3.0.x] Abandoned MODs”

cron