Nginx & redirection

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Pierre-
Registered User
Posts: 2
Joined: Mon Apr 30, 2012 11:25 am

Nginx & redirection

Post by Pierre- » Mon Apr 30, 2012 11:35 am

Hi everyone,
Support Request Template
What version of phpBB are you using? phpBB 3.0.10
What is your board's URL? http://forum.notinprod.dev
Who do you host your board with? Debian / Nginx / PHP-FPM
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
What styles do you currently have installed? Default
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to phpBB but not PHP
When did your problem begin? When I tried to use it ^^
Please describe your problem. I installed phpbb on my server using nginx & php-fpm. I use the configuration provided by an user on http://wiki.nginx.org/Configuration
The problem is the redirections, for example when I login i redirects me to
http://forum.mydomain.com/ucp.php/index ... fae3f7d324
and all css is crashed...
Do I need to make a rewrite rule for every php file or I missed something in configuration ?
Generated by SRT Generator

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Nginx & redirection

Post by Oyabun1 » Mon Apr 30, 2012 12:02 pm

Server setup is outside the scope of this site, see rule 4b.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

Pierre-
Registered User
Posts: 2
Joined: Mon Apr 30, 2012 11:25 am

Re: Nginx & redirection

Post by Pierre- » Mon Apr 30, 2012 3:32 pm

Thank you for your help, you are so kind..

Is it my fault if phpbb has been developed only for apache and work so badly on other webservers ?
You ask me to see with nginx community but, for your information, it is the app which not fit the webserver, not the opposite. If firefox doesn't run on your Windows, you go ask to microsoft ? No.
And I am not asking for setup but for configuration on both phpbb & nginx, if you are not enough competent, right, but don't say nginx is the problem here.

CaNNon_
Registered User
Posts: 392
Joined: Wed Apr 29, 2009 2:07 am

Re: Nginx & redirection

Post by CaNNon_ » Mon Apr 30, 2012 7:20 pm

Someone delete a post here we can't see Pierre? I don't see Oyabun1 or any other poster doing anything deserving of that post.

Oleg
Former Team Member
Posts: 1221
Joined: Sat Jan 30, 2010 4:42 pm
Location: NYC
Contact:

Re: Nginx & redirection

Post by Oleg » Tue May 01, 2012 1:41 am

phpbb works fine on nginx.

See also https://github.com/phpbb/phpbb3/blob/de ... ample.conf for sample configuration.

It sounds like the domain you entered when you installed the board is not the domain you are using to access the board (and this has nothing to do with your choice of web server). Assuming forum.notinprod.dev is the domain you are using for accessing your board, when you installed it that's what you should have entered instead of forum.mydomain.com.

Edit: reading your post again it looks like the domains you specified have nothing to do with the issue. Did you make up both domains and is the actual domain you are using not either of the ones you did specify?

The issue seems to be incorrect passing of environment variables to php. You should start with the config file I linked to above to see if it would fix the issue. If it does not, check whether other php scripts work correctly.
Participate in phpBB development: Get involved | Issue tracker | Report a bug | Development board | [url=irc://chat.freenode.net/phpbb-dev]Development IRC chat[/url]
My stuff: mindlinkgame.com

Locked

Return to “[3.0.x] Support Forum”