Can't install phpBB...

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Sonic X
Registered User
Posts: 26
Joined: Tue Nov 16, 2010 1:34 pm
Location: Brazil
Contact:

Can't install phpBB...

Post by Sonic X »

Support Request Template
What version of phpBB are you using? phpBB 3.0.10
What is your board's URL? http://www.squareblock.co.cc:8090/
Who do you host your board with? My own computer
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
What styles do you currently have installed? Default
What language(s) is your board currently using? Default
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
When did your problem begin? When I tried to install phpBB
Please describe your problem. Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in C:\Apache24\htdocs\includes\utf\utf_tools.php on line 1781
Is there any other way to describe this?
EDIT: phpinfo.php = http://www.squareblock.co.cc:8090/phpinfo.php
Generated by SRT Generator
Sorry for my bad grammar.
User avatar
tbackoff
Former Team Member
Posts: 7064
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: Can't install phpBB...

Post by tbackoff »

Sonic X wrote:Please describe your problem. Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in C:\Apache24\htdocs\includes\utf\utf_tools.php on line 1781
At what point do you get this? I am able to get to the "Database settings" section of the install (obviously, I can't go any further because I don't have those credentials). :P
Flying is the second best thrill to cheerleaders; being caught is the first.
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Can't install phpBB...

Post by Oyabun1 »

There have been changes to the error reporting in PHP since 5.4.0

Try this.

Open /includes/startup.php

Find

Code: Select all

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);
Replace with

Code: Select all

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT);
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
Sonic X
Registered User
Posts: 26
Joined: Tue Nov 16, 2010 1:34 pm
Location: Brazil
Contact:

Re: Can't install phpBB...

Post by Sonic X »

Oyabun1 wrote:There have been changes to the error reporting in PHP since 5.4.0

Try this.

Open /includes/startup.php

Find

Code: Select all

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);
Replace with

Code: Select all

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT);
Thanks! it's working now!
Sorry for my bad grammar.
User avatar
abassanelli
Registered User
Posts: 7
Joined: Tue Oct 22, 2013 3:51 pm
Name: Andrea
Contact:

Re: Can't install phpBB...

Post by abassanelli »

and if I don't have includes/startup.php?!
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70216
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Can't install phpBB...

Post by KevC »

That would mean your board is very out of date and you should start a new topic.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Can't install phpBB...

Post by Oyabun1 »

Note that the code change in this topic is no longer required because of subsequent code changes in phpBB.

You just need to update your board to the latest version.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
Locked

Return to “[3.0.x] Support Forum”