[2.0.10] Bin

The cleanup is complete. This forum is now read only.

Rating:

Excellent!
21
75%
Very Good
5
18%
Good
1
4%
Fair
0
No votes
Poor
1
4%
 
Total votes: 28

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu » Wed Nov 03, 2004 11:40 pm

hum looks weird :?

i will take a look to this tomorrow and will be back with an answer :roll:
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu » Fri Nov 05, 2004 12:26 am

Lyric wrote: ok that got the mod to begin to install but then i got this...

Warning

FIND FAILED: In file [templates/fiappleblue/modcp_body.tpl] could not find:

<input type="submit" name="unlock" class="liteoption" value="{L_UNLOCK}" />

MOD script line #378 :: FAQ :: Report

Error Detail

Critical Error

FIND FAILED: In file [templates/subSilver/modcp_body.tpl] could not find:

<td align="right" valign="top" nowrap="nowrap"><span class="gensmall">{S_TIMEZONE}</span><br /><span class="nav">{PAGINATION}</span></td>

MOD script line #387

Oh ok, your are trying to install Bin Mod with EM on fiappleblue, but EasyMod only works with subSilver
to install mods to others templates, you have to use manual installation ;)

i tested the bin Mod with EM, it works if you replace each s with S for subSilver :roll:
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

ALLMIGHTYGOD
I've Been Banned!
Posts: 34
Joined: Mon Oct 25, 2004 4:58 pm

Post by ALLMIGHTYGOD » Tue Nov 23, 2004 6:31 pm

sorry it's my fault
in your install.txt replace each subsilver with subSilver Rolling Eyes

I would have never found this!!

THX MASTER ANS I WHISH MANY GIRLS U WILL FUCK HARD!!

*love you know who; PRAY*

cyberider
Registered User
Posts: 2
Joined: Wed Nov 24, 2004 4:41 pm

Post by cyberider » Wed Nov 24, 2004 4:57 pm

Famitsu wrote:
ansafa wrote:
rossmcclymont wrote:OR - is it the MOD I've been waiting for that act like an Invision Power Board and put it in there when anything is DELETED?


This is what I would like to know...

When a user or moderator hits the delete button for a post, will it automatically appear in the 'trash bin'??
No, it doesn't
Ask your moderators to use bin icon instead of delete icon

otherwise you can remove delete link in viewtopic.php or replace it with bin link
something like this

Code: Select all

	$topic_mod .= ( $userdata['user_level'] == ADMIN ) ? "<a href=\"modcp.$phpEx?" . POST_TOPIC_URL . "=$topic_id&mode=delete&sid=" . $userdata['session_id'] . '"><img src="' . $images['topic_mod_delete'] . '" alt="' . $lang['Delete_topic'] . '" title="' . $lang['Delete_topic'] . '" border="0" /></a>&nbsp;' : "";


First off, thanks for you MOD, I have added it to our forums and it works great. The additional functionality you mentioned above would be very handy, we're running logs on Moderators actions, but we really want to be able to limit the actual deletion of posts to our Admins. The trouble is, I'm really new at this and would appreciate it if you could explain the required changes a little further. I had a look through viewtopic.php I've added about 20 or so MODs to our forums (discovered EzyMOD after I'd done over half of them, lol).

I'm thinking that this line of code should be replaced by the one in the quote above...

Code: Select all

$topic_mod .= ( $is_auth['auth_delete'] ) ? "<a href=\"modcp.$phpEx?" . POST_TOPIC_URL . "=$topic_id&mode=delete&sid=" . $userdata['session_id'] . '"><img src="' . $images['topic_mod_delete'] . '" alt="' . $lang['Delete_topic'] . '" title="' . $lang['Delete_topic'] . '" border="0" /></a>&nbsp;' : "";
Then would I need to remove the code for the Bin link?

Any advice you could give would be appreciated.

Thanks.

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -&gt; see my signature to contact me
Contact:

Post by Famitsu » Wed Nov 24, 2004 6:34 pm

if you only want allow ADMIN to delete topic just replace this line:

Code: Select all

$is_auth['auth_delete']
with

Code: Select all

$userdata['user_level'] == ADMIN
keep in mind, your moderators will always delete posts via modcp
so you need to edit this file (modcp.php) too
search for the same variable

Code: Select all

if (!$is_auth['auth_delete'])
replace with

Code: Select all

if (!$userdata['user_level'] == ADMIN)
means: if (!) not level ADMIN return error message
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

cyberider
Registered User
Posts: 2
Joined: Wed Nov 24, 2004 4:41 pm

Thanks.

Post by cyberider » Fri Nov 26, 2004 7:21 am

That worked exactly like I wanted. Now Moderators only have the ability to move posts to our Deleted Files category.

Thanks for the reply, I've only been using phpBB for 3 days now and it really helped.

Cyberpenguin
Registered User
Posts: 14
Joined: Fri Nov 26, 2004 8:28 am

Post by Cyberpenguin » Fri Nov 26, 2004 8:39 am

how would i make it so when i move a thead to the bin, that the posts in that thread dont count towards the users post count.

for example, a user has 100 posts, then posts 10 times in a thread. so he now has 110. then i move that thread to the bin, and now he should be back at 100

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -&gt; see my signature to contact me
Contact:

Post by Famitsu » Fri Nov 26, 2004 10:21 pm

Cyberpenguin wrote: how would i make it so when i move a thead to the bin, that the posts in that thread dont count towards the users post count.

for example, a user has 100 posts, then posts 10 times in a thread. so he now has 110. then i move that thread to the bin, and now he should be back at 100
i don't know if it will work, but there is mod here which disable post count per forum
so try it and reply to confirm :roll:
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

Cyberpenguin
Registered User
Posts: 14
Joined: Fri Nov 26, 2004 8:28 am

Post by Cyberpenguin » Fri Nov 26, 2004 10:23 pm

http://www.phpbb.com/phpBB/viewtopic.php?t=133022

i think this is the correct one, im gonna try it out now.

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -&gt; see my signature to contact me
Contact:

Post by Famitsu » Fri Nov 26, 2004 10:32 pm

Yep :)
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

Cyberpenguin
Registered User
Posts: 14
Joined: Fri Nov 26, 2004 8:28 am

Post by Cyberpenguin » Fri Nov 26, 2004 10:41 pm

Cyberpenguin wrote: http://www.phpbb.com/phpBB/viewtopic.php?t=133022

i think this is the correct one, im gonna try it out now.


Yes, when it wont increase post count when i post in the trash bin, but it wont remove a post count when i move something to the bin.

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -&gt; see my signature to contact me
Contact:

Post by Famitsu » Fri Nov 26, 2004 11:34 pm

if you apply there rules to the bin forum = no post increase for user
if you move a topic to bin, i 'guess' with this mod user's posts will be implemented -1 :!:
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

Cyberpenguin
Registered User
Posts: 14
Joined: Fri Nov 26, 2004 8:28 am

Post by Cyberpenguin » Sat Nov 27, 2004 12:36 am

Famitsu wrote: if you apply there rules to the bin forum = no post increase for user
if you move a topic to bin, i 'guess' with this mod user's posts will be implemented -1 :!:


what i did is i noted my post count, then i made a thread in a general forum with 5 posts. my post count is now +5. then i moved that thread to the bin. my postcount is still +5. then i replyed to that thread while it was in the bin. my postcount is still +5

Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -&gt; see my signature to contact me
Contact:

Post by Famitsu » Sat Nov 27, 2004 6:52 pm

so you should ask Mod author to add support for moved topics :roll:
i can do nothing for you (too busy)
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here

yossabeh
Registered User
Posts: 7
Joined: Mon Oct 04, 2004 9:50 am

Can't find bin

Post by yossabeh » Sun Nov 28, 2004 12:56 pm

OK, a really silly question: how do I set up BIN forum?
I installed the mod and tried tomove some topics there, but got mssg: Bin has been disabled.

How do I enable bin?

Post Reply

Return to “[2.0.x] MOD Database Cleanup”