[RC] Support of SQLite 3.0+

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Get Involved
User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

[RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Tue Aug 02, 2011 8:50 pm

Sorry, MOD was corrupted. Please download it again!

User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

Re: [RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Thu Dec 29, 2011 9:03 pm

Fixed BUG: SQLite queries fail many times with error: DB locked.
If you installed the MOD already, please replace file includes/db/sqlite_3.php from directory root.

User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

Re: [RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Sun Jan 08, 2012 8:49 pm

Please use correction packet to upgrade from 3.0.9 to 3.0.10: SQLite3.0_MOD_update_to_310.zip
You must replace some files into standard upgrade packet before use it.

Lspreee
Registered User
Posts: 1
Joined: Tue Aug 21, 2012 2:30 pm

Re: [RC] Support of SQLite 3.0+

Post by Lspreee » Tue Aug 21, 2012 2:40 pm

Hello,
honestly although you did a great job implementing sqlite3 to phpBB it is hard to follow all the find -> paste steps in your manual. I found after like 30 - 40 changes the further strings unavailable in the given files (e.g. "install/database_update.php" there is no string like 'sqlite' => array( ... ). Seems that the version the manual was made for is 3.0.8 or so.

What if I start from version 3.0.10 at all. You only provided "updates" from 3.0.9 to 3.0.10. Isn't there a complete version with already changed php files?

Thanks for your work anyways.

User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

Re: [RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Thu Sep 06, 2012 9:04 pm

Sorry, it's written 'SQLite3.0_MOD_5.3.x_for_309'; need take 3.0.9 -> set MOD -> upgrade to 3.0.10.
But it isn't actually, I must prepare MOD for 3.0.11...

User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

Re: [RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Mon Sep 24, 2012 11:19 pm

Yes, added update to 3.0.11:
SQLite3.0_MOD_update_to_311.zip

User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

Re: [RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Sun Nov 04, 2012 9:08 pm

If somebody don't know, my MOD will be included into Ascraeus 3.1.

Massimiliano Mancini
Registered User
Posts: 4
Joined: Thu Mar 28, 2013 7:58 am

Re: [RC] Support of SQLite 3.0+

Post by Massimiliano Mancini » Thu Mar 28, 2013 8:09 am

Starting from excellent Boris' work, I hacked the 3.0.11 in order to have an installable version of phpbb 3.0.11 with SQLite 3.0+ support.

Some other changes are done, in particular on data type that are now the SQLite3 native (INTEGER, TEXT, REAL, BLOB and nothing else)

Please consider this work as ALHPA RELEASE and so any comment is apprecieted.

The testing environment is:

PHP 5.4.13
OS WIndows 7 Professional

Here is the link to the download
http://dl.dropbox.com/u/22594893/phpbb_ ... qlite3.zip

MD5 6a6a0cf592712a1b8846a1631f13b66d

User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

Re: [RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Mon Apr 01, 2013 10:20 pm

Massimiliano Mancini,
in includes\db\db_tools.php missing some

Code: Select all

case 'sqlite_3':

Massimiliano Mancini
Registered User
Posts: 4
Joined: Thu Mar 28, 2013 7:58 am

Re: [RC] Support of SQLite 3.0+

Post by Massimiliano Mancini » Tue Apr 02, 2013 7:36 am

Boris Berdichevski wrote:Massimiliano Mancini,
in includes\db\db_tools.php missing some

Code: Select all

case 'sqlite_3':
where?

User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

Re: [RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Fri Apr 05, 2013 3:26 pm

Please download properly latest file from link Update to 3.0.11 -- see my started post!
(Take from zip: install\update\new\includes\db\db_tools.php)

Massimiliano Mancini
Registered User
Posts: 4
Joined: Thu Mar 28, 2013 7:58 am

Re: [RC] Support of SQLite 3.0+

Post by Massimiliano Mancini » Fri Apr 05, 2013 8:23 pm

Updated with correct file coming from last update of Boris.
Please download from same link.

User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

Re: [RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Fri Oct 04, 2013 12:23 pm

Update to 3.0.12:
Use phpBB-3.0.11_to_3.0.12-SQLite3.zip instead phpBB-3.0.11_to_3.0.12.zip

pfarber
Registered User
Posts: 3
Joined: Thu Sep 07, 2006 3:21 pm

Re: [RC] Support of SQLite 3.0+

Post by pfarber » Mon Mar 03, 2014 8:14 am

Can you clarify the instructions for a new installation of phpbb3?

sqlite3 is working on my system, php sees it :

Array ( [versionString] => 3.7.7.1 [versionNumber] => 3007007 ) ?>

So I try and install php-3.0.11 yet the install does not show SQLite as available.

I then copy over the install/ and docs/ directory from phpbb-3.0.11_to_3.0.12-SQlite3 and rerun the install and it still shows SQLite as unavailable.

Can you please give better installation instructions??

User avatar
Boris Berdichevski
Registered User
Posts: 74
Joined: Thu Jul 10, 2008 9:09 pm

Re: [RC] Support of SQLite 3.0+

Post by Boris Berdichevski » Wed Apr 23, 2014 1:38 pm

You need this MOD for phpBB 3.0.12.
I'll try to prepare this...
You used package for upgrade phpBB 3.0.11 -> 3.0.12 while package 3.0.11 includes MOD already!

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 27 guests