[split from] Upgrade question 3.0.0 to 3.0.11

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
Lumpy Burgertushie
Registered User
Posts: 66469
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [split from] Upgrade question 3.0.0 to 3.0.11

Post by Lumpy Burgertushie » Wed Aug 14, 2013 7:10 pm

and no, there should not be any folders in the phpbb's cache folder.


regardless, you can delete everything in that folder. you should keep the index.htm and the .htaccess files if they are there.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
DonkeyBike
Registered User
Posts: 75
Joined: Sun Sep 16, 2007 1:20 am

Re: [split from] Upgrade question 3.0.0 to 3.0.11

Post by DonkeyBike » Thu Aug 15, 2013 11:32 am

Lumpy Burgertushie wrote:and no, there should not be any folders in the phpbb's cache folder.

regardless, you can delete everything in that folder. you should keep the index.htm and the .htaccess files if they are there.

robert
Right, I've deleted the Cache folder in the Cache folder, still no luck installing any updated versions from Ver. 3.0.rc1
Kevin Clark wrote:Are you sure your board was in fact 3.0.0 then?
100% certain, it's not been updated in ages. Below, I think, you'll see where the Database was moved to the new server running MySQL5.

[Thu Aug 15 12:10:37 2013] [error] [client 62.77.184.125] PHP Warning: cannot yet handle MBCS in html_entity_decode()! in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/mobiquo/mobiquo_common.php on line 177
[Thu Aug 15 12:10:37 2013] [error] [client 62.77.184.125] PHP Warning: cannot yet handle MBCS in html_entity_decode()! in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/mobiquo/mobiquo_common.php on line 177
[Thu Aug 15 12:10:37 2013] [error] [client 62.77.184.125] PHP Warning: cannot yet handle MBCS in html_entity_decode()! in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/mobiquo/mobiquo_common.php on line 177
[Thu Aug 15 12:10:37 2013] [error] [client 62.77.184.125] PHP Warning: cannot yet handle MBCS in html_entity_decode()! in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/mobiquo/mobiquo_common.php on line 177
[Thu Aug 15 12:10:37 2013] [error] [client 62.77.184.125] PHP Warning: cannot yet handle MBCS in html_entity_decode()! in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/mobiquo/mobiquo_common.php on line 177
[Thu Aug 15 12:11:45 2013] [error] [client 84.203.33.42] PHP Fatal error: SQL ERROR [ mysql4 ]<br /><br />Lost connection to MySQL server at 'reading initial communication packet', system error: 111 [2013] in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/includes/db/dbal.php on line 757
[Thu Aug 15 12:12:22 2013] [error] [client 84.203.33.42] PHP Fatal error: SQL ERROR [ mysql4 ]<br /><br />Lost connection to MySQL server at 'reading initial communication packet', system error: 111 [2013] in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/includes/db/dbal.php on line 757
[Thu Aug 15 12:12:39 2013] [error] [client 84.203.33.42] PHP Fatal error: SQL ERROR [ mysql4 ]<br /><br />Lost connection to MySQL server at 'reading initial communication packet', system error: 111 [2013] in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/includes/db/dbal.php on line 757
[Thu Aug 15 12:13:23 2013] [error] [client 84.203.33.42] PHP Notice: Undefined property: mysql_version in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/install/database_update.php on line 509
[Thu Aug 15 12:23:53 2013] [error] [client 84.203.33.42] PHP Notice: Undefined property: mysql_version in /usr/local/pem/vhosts/103859/webspace/httpdocs/forum/install/database_update.php on line 509
Last edited by DonkeyBike on Thu Aug 15, 2013 12:06 pm, edited 2 times in total.

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: [split from] Upgrade question 3.0.0 to 3.0.11

Post by Oyabun1 » Thu Aug 15, 2013 12:01 pm

DonkeyBike wrote:still no luck installing any updated versions from Ver. 3.0.rc1
3.0.0 RC1 is an earlier version than 3.0.0. You should not have been able to update from a later version to an earlier version.
DonkeyBike wrote:
Kevin Clark wrote:Are you sure your board was in fact 3.0.0 then?
100% certain, it's not been updated in ages. Below, I think, you'll see where the Database was moved to the new server running MySQL5.
None of those errors indicate what phpBB version is running.

How are you determining what phpBB version you are running?
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
DonkeyBike
Registered User
Posts: 75
Joined: Sun Sep 16, 2007 1:20 am

Re: [split from] Upgrade question 3.0.0 to 3.0.11

Post by DonkeyBike » Thu Aug 15, 2013 12:10 pm

Oyabun1 wrote:
DonkeyBike wrote:still no luck installing any updated versions from Ver. 3.0.rc1
3.0.0 RC1 is an earlier version than 3.0.0. You should not have been able to update from a later version to an earlier version.
I didn't know that, I just chose the earliest I could find.
Oyabun1 wrote:
DonkeyBike wrote:
Kevin Clark wrote:Are you sure your board was in fact 3.0.0 then?
100% certain, it's not been updated in ages. Below, I think, you'll see where the Database was moved to the new server running MySQL5.
None of those errors indicate what phpBB version is running.

How are you determining what phpBB version you are running?
From what's in the image below when I'm updating... the reference to MYSQL4 is disturbing. :shock:
Image

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: [split from] Upgrade question 3.0.0 to 3.0.11

Post by Oyabun1 » Thu Aug 15, 2013 12:57 pm

So you've updated the database from 3.0.0-RC1 to 3.0.1. That is a step forward.

Now try the database_update.php file in the install folder for the 3.0.11 package. It would not have worked properly before since you were only on 3.0.0-RC1.

If that times out then try the staged update again that you tried before:
DonkeyBike wrote:Through blind luck rather than any kind of an idea of what I'm doing I'd just started doing that, from 3.0.0 to 3.0.4
viewtopic.php?p=13199997#p13199997
DonkeyBike wrote:the reference to MYSQL4 is disturbing.
That isn't a problem, it not reflecting the actual MySQL version just how phpBB is treating it internally.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
DonkeyBike
Registered User
Posts: 75
Joined: Sun Sep 16, 2007 1:20 am

Re: [split from] Upgrade question 3.0.0 to 3.0.11

Post by DonkeyBike » Thu Aug 15, 2013 5:45 pm

Deleting those files from the Cache folder along with incremental installation and I got there, see image below.


The style I was using all along (3myl_sable)seems to work ok, is there any reason I shouldn't continue with it ?

Again, thanks Kevin, Robert and Oyabun1 for all your help !

Image

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69210
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: [split from] Upgrade question 3.0.0 to 3.0.11

Post by KevC » Thu Aug 15, 2013 5:56 pm

DonkeyBike wrote: is there any reason I shouldn't continue with it ?
If it's 11 versions out of date, yes.

Try making a poll and voting in it.

Also, I've seen boards where people can no longer get to the admin panel and also, and probably most significantly, the newly added (and highly effective) antispam measures will not work.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
DonkeyBike
Registered User
Posts: 75
Joined: Sun Sep 16, 2007 1:20 am

Re: [split from] Upgrade question 3.0.0 to 3.0.11

Post by DonkeyBike » Sat Aug 17, 2013 3:51 pm

Kevin Clark wrote:
DonkeyBike wrote: is there any reason I shouldn't continue with it ?
If it's 11 versions out of date, yes.
Try making a poll and voting in it.
I did, it seems to be ok, but I won't use it if you think it's dodgy...
Kevin Clark wrote: Also, I've seen boards where people can no longer get to the admin panel and also, and probably most significantly, the newly added (and highly effective) antispam measures will not work.
Those are good reasons not to revert back, but I'm like a dog with a bone on this one, can't let it go. :mrgreen:

I've had a look at WinMerge and it isn't as user friendly as I'd like, is there much to manually upgrading a style. the lack of a "View New Posts" is doing my head in a little, the old Style was very very comfortable.
If only I could get the New Posts on every page I'd be happy, I've posted a few questions in another thread.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66469
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [split from] Upgrade question 3.0.0 to 3.0.11

Post by Lumpy Burgertushie » Sat Aug 17, 2013 4:00 pm

it is a matter of whether the board functions properly when using the out of date style. with one that far out of date, the board will not fucntion properly. there have been many things added since the beginning that won't show up in your old style etc.

using winmerge or other programs like it only help you to find the actual bits of code that have changed etc.

you will still have to copy and paste , delete, edit, etc.

your best bet is to simply find a new style that you like and use it instead. your members won't care.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Locked

Return to “[3.0.x] Support Forum”