Updating database stops working 3.0.11 to 3.0.12 [resolved]

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
sotis
Registered User
Posts: 294
Joined: Tue Oct 17, 2006 4:56 pm
Location: Bulgaria
Contact:

Updating database stops working 3.0.11 to 3.0.12 [resolved]

Post by sotis » Sun Sep 29, 2013 7:17 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.11
What is your board's URL? http://www.kaminata.net
Who do you host your board with? http://vpsbg.eu/
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? Yes
What version of phpBB3 did you update from? phpBB 3.0.11
What MODs do you have installed? No answer given
What styles do you currently have installed? No answer given
What language(s) is your board currently using? Bulgarian
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
When did your problem begin? Updating database from 3.0.11 to 3.0.12
Please describe your problem. When I start updating with Automatic Update Package it starts and stops with that message:

Updating database to latest stable release

Database type :: mysql4
Previous version :: 3.0.11
Updated version :: 3.0.12


Updating database schema

Progress :: No updates required


Updating data

Progress ::

UPDATE phpbb_modules SET module_auth = 'acl_u_sig' WHERE module_class = 'ucp' AND module_basename = 'profile' AND module_mode = 'signature'
.
DELETE FROM phpbb_bots WHERE user_id = 621
.


It happens on my real host and the same on my local XAMPP server on my computer.
Generated by SRT Generator

more details in the logs:

[Mon Sep 30 21:16:56 2013] [error] [client 46.47.82.33] PHP Fatal error: Call to undefined function arcade_delete_user() in /var/www2/includes/functions_user.php on line 386,
Last edited by sotis on Wed Nov 05, 2014 6:43 pm, edited 6 times in total.

User avatar
nextgen
Jr. Style Validator
Posts: 2334
Joined: Mon Jul 26, 2010 10:58 pm
Location: Guatemala
Name: Melvin García
Contact:

Re: Updating database stops working 3.0.11 to 3.0.12

Post by nextgen » Sun Sep 29, 2013 8:24 pm

メルビン・ガルシア • Xtrato SolutionsMy active styles for phpBBphpBB Argentina - Soporte en español🇦🇷

Please do NOT contact for support via PM or email.

sotis
Registered User
Posts: 294
Joined: Tue Oct 17, 2006 4:56 pm
Location: Bulgaria
Contact:

Re: Updating database stops working 3.0.11 to 3.0.12

Post by sotis » Mon Sep 30, 2013 3:31 pm

Ok, I am sorry. I edited the first post.

sotis
Registered User
Posts: 294
Joined: Tue Oct 17, 2006 4:56 pm
Location: Bulgaria
Contact:

Re: Updating database stops working 3.0.11 to 3.0.12

Post by sotis » Mon Sep 30, 2013 7:20 pm

I resolved the problem. And maybe this will help somebody.
There was a conflict with some mod, probably arcade mod.
I copied the fresh /includes/functions_user.php file, made database update and after that put back old moded /includes/functions_user.php and finished update process.

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Updating database stops working 3.0.11 to 3.0.12 [resolv

Post by Oyabun1 » Mon Sep 30, 2013 9:23 pm

You should also manually update your /includes/functions_user.php file.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

sotis
Registered User
Posts: 294
Joined: Tue Oct 17, 2006 4:56 pm
Location: Bulgaria
Contact:

Re: Updating database stops working 3.0.11 to 3.0.12 [resolv

Post by sotis » Tue Oct 01, 2013 6:44 am

Yes, Thank you, I know that. But I put the old one on its place after updating the base and before updating the files. So the automatic update package did that automatically.

dda
Registered User
Posts: 4
Joined: Fri Oct 23, 2009 5:33 pm

Re: Updating database stops working 3.0.11 to 3.0.12 [resolv

Post by dda » Wed Feb 12, 2014 12:54 am

Works! Thank you

User avatar
angeljs
Registered User
Posts: 49
Joined: Wed Nov 10, 2004 5:34 pm
Location: North East UK
Contact:

Re: Updating database stops working 3.0.11 to 3.0.12 [resolv

Post by angeljs » Wed Apr 02, 2014 9:56 pm

Unfortunately, this doesn't work for me, I still can't upgrade. :(

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Updating database stops working 3.0.11 to 3.0.12 [resolv

Post by Oyabun1 » Thu Apr 03, 2014 1:19 am

angeljs wrote:Unfortunately, this doesn't work for me, I still can't upgrade. :(
Start you own topic and include the completed Support Request Template.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

Locked

Return to “[3.0.x] Support Forum”