[Solved] Function set_magic_quotes_runtime() is deprecated

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
ladyluck
Registered User
Posts: 6
Joined: Thu Sep 22, 2011 3:40 am

[Solved] Function set_magic_quotes_runtime() is deprecated

Post by ladyluck »

Support Request Template
What version of phpBB are you using? phpBB 3.0.2
What is your board's URL? http://www.nerovanguard.com/forum/
Who do you host your board with? Dreamhost
How did you install your board? Install package from my host
What is the most recent action performed on your board? Unknown (long ago)
Is registration required to reproduce this issue? No
Do you have any MODs installed? Yes
What styles do you currently have installed? black_pearl, Blue2-302, Brown2-302, Brown-302, Chronicles, DarkFantasy, Dollar-302, Green2-302, Green3-302, Grey-302, GuildWarsAlliance, Magenta2-302, OAmedieval, pro_MylCastel, prosilver, rainbow_pearl, Red-302, Rose-302, subsilver2,
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5 (I think)
What is your level of experience? Novice
When did your problem begin? Yesterday. It's been fine for years and years until this point.
Please describe your problem. I receive the following error at the top of my page, in addition to the text being larger than normal.

Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/neronemo/nerovanguard.com/forum/common.php on line 106
[phpBB Debug] PHP Notice: in file /includes/session.php on line 942: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 942: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 942: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3545: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3547: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3548: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3549: Cannot modify header information - headers already sent by (output started at /common.php:106)

Also, I cannot log in. If I try to log in it takes me back to the home page. I downloaded STK and attempted to log in that way and it gives me the following error:

Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/neronemo/nerovanguard.com/forum/common.php on line 106

Warning: Cannot modify header information - headers already sent by (output started at /home/neronemo/nerovanguard.com/forum/common.php:106) in /home/neronemo/nerovanguard.com/forum/stk/includes/critical_repair.php on line 132

Warning: Cannot modify header information - headers already sent by (output started at /home/neronemo/nerovanguard.com/forum/common.php:106) in /home/neronemo/nerovanguard.com/forum/stk/includes/critical_repair.php on line 133

I have downloaded an autoupdater for the most recent version of phpbb as others have explained that this fixes their issue, but I was wanting to back-up my database before installing it but have no idea how to do that without access to the ACP.
Generated by SRT Generator

In short, I've had the forum up and running for years and no recent changes. I cannot log into ACP (or STK) to backup my DB or else I'd try and update to a newer version as this usually seems to fix the problem.
Last edited by ladyluck on Thu Jul 10, 2014 4:44 am, edited 1 time in total.
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Function set_magic_quotes_runtime() is deprecated

Post by Oyabun1 »

It is likely your host has updated the PHP version used on the server and the phpBB version you are using cannot handle the changes in that PHP version. The solution is to update your board and style to phpBB 3.0.12.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
ladyluck
Registered User
Posts: 6
Joined: Thu Sep 22, 2011 3:40 am

Re: Function set_magic_quotes_runtime() is deprecated

Post by ladyluck »

Is there a way for me to backup my DB without access to the ACP or do I have to just run the upgrade and hope for the best?
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Function set_magic_quotes_runtime() is deprecated

Post by Oyabun1 »

Your host will provide a database management tool, like phpMyAdmin, you can use that to export a copy.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
ladyluck
Registered User
Posts: 6
Joined: Thu Sep 22, 2011 3:40 am

Re: Function set_magic_quotes_runtime() is deprecated

Post by ladyluck »

So when I went to check it I found out my install was wrong and uploaded the new auto updater instead (3.0.7-1PL to 3.0.12). I now get this error:

Fatal error: Call to undefined method diff3::get_num_conflicts() in /home/neronemo/nerovanguard.com/forum/install/install_update.php on line 1548
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Function set_magic_quotes_runtime() is deprecated

Post by Oyabun1 »

Some more information about your board version would be useful:
  1. Download this file – support_info.php
  2. Upload it to the root of your board installation.
  3. Navigate your browser to the file http://www.nerovanguard.com/forum/support_info.php
  4. Select: Version
  5. Copy and paste the information it shows in the blue box to here.
  6. Then delete the file. (The script displays a button to delete itself.)
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
ladyluck
Registered User
Posts: 6
Joined: Thu Sep 22, 2011 3:40 am

Re: Function set_magic_quotes_runtime() is deprecated

Post by ladyluck »

Board start date: 03 Oct 2008
constants.php version: Not defined (constant not accessible or version < 3.0.3)
Cached version: 3.0.12
DB version: 3.0.12
DB version_update_from: 3.0.7-PL1
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Function set_magic_quotes_runtime() is deprecated

Post by Oyabun1 »

Seems that somebody tried, unsuccessfully, to update the board in the past and you now have a mix of versions.

Run these SQL queries to reset the version number in the database:

Code: Select all

UPDATE phpbb_config SET config_value = '3.0.2' WHERE config_name = 'version';
DELETE FROM phpbb_config WHERE config_name = 'version_update_from';
Change phpbb_ if that is not your table prefix.

See Executing SQL Queries in phpMyAdmin if you are unfamiliar with running queries.

Then use the 3.0.2 to 3.0.12 update package.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
ladyluck
Registered User
Posts: 6
Joined: Thu Sep 22, 2011 3:40 am

Re: Function set_magic_quotes_runtime() is deprecated

Post by ladyluck »

Thank you so much!

It took a while for me to manually update some of the files (it wouldn't let me use the ftp upload function) but everything appears to be working great so far.
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: [Solved] Function set_magic_quotes_runtime() is deprecat

Post by Oyabun1 »

You will also need to find up to date versions of your styles, update them yourself, or find new styles which match your board version. Mismatched board and style versions will cause problems.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
Locked

Return to “[3.0.x] Support Forum”