Custom fields wont display

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
omegadarkest
Registered User
Posts: 4
Joined: Mon Dec 01, 2014 5:47 pm

Custom fields wont display

Post by omegadarkest »

I see custom fields being built in now but I can't get them to display in the users profile so they can be changed by the user.

Image

Image

Using a custom theme but I switched back to prosilver to see if it was a theme issue but I still can't see any active custom field in my profile
User avatar
KaileyT
Community Team Member
Community Team Member
Posts: 2845
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: Custom fields wont display

Post by KaileyT »

What is the field? Is it one of the ones that phpBB included or your own? Please fill out the Support Request Template and post it back here.
Kailey Truscott - Community Team
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Custom fields wont display

Post by Oyabun1 »

Users need the global Can change profile field information in order to be able to see or edit profile fields in the ACP. The Newly Registered Users group, by default, has that set to Never.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
User avatar
P_I
Registered User
Posts: 1240
Joined: Tue Mar 01, 2011 8:35 pm
Location: Staying home - Calgary
Contact:

Re: Custom fields wont display

Post by P_I »

Oyabun1 wrote:The Newly Registered Users group, by default, has that set to Never.
For forums upgraded from phpBB 3.0.12 I'm finding that it has been set to No. Reported as PHPBB3-13410
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
Lady_G
Registered User
Posts: 257
Joined: Fri Jun 08, 2012 12:38 pm
Location: US

Re: Custom fields wont display

Post by Lady_G »

I don't remember if the default setting was modified on my forum (also a 3.0.12 to 3.1.2 upgrade), but it's currently set to No.

Permissions --> Global permissions --> Group permissions --> Newly registered users --> Advanced permissions

Instead, I tried the demo site. I would assume the demo site has the default settings, but when I logged into 3.1.x of phpBB® Demo, the settings were also set to No.

BTW, the demo is running 3.1.0. How does one get the demo site updated?
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Custom fields wont display

Post by Oyabun1 »

It seems I was incorrect about the default value. I thought the board I checked it on was a clean install, but that doesn't seem to be the case. However, for the OP's issue it really doesn't matter what the default is, it matters what the value is now.
Lady_G wrote:BTW, the demo is running 3.1.0. How does one get the demo site updated?
Same as with any other problem with the website, check if a bug report has been submitted and if not submit one.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
User avatar
P_I
Registered User
Posts: 1240
Joined: Tue Mar 01, 2011 8:35 pm
Location: Staying home - Calgary
Contact:

Re: Custom fields wont display

Post by P_I »

Oyabun1 wrote:It seems I was incorrect about the default value. I thought the board I checked it on was a clean install, but that doesn't seem to be the case.
I just did a clean install of phpBB 3.1.2 and confirmed you were correct with your original answer that the Newly Registered Users group has the 'Can change profile field information' set to Never.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
Lady_G
Registered User
Posts: 257
Joined: Fri Jun 08, 2012 12:38 pm
Location: US

Re: Custom fields wont display

Post by Lady_G »

Oyabun1 wrote:
Lady_G wrote:BTW, the demo is running 3.1.0. How does one get the demo site updated?
Same as with any other problem with the website, check if a bug report has been submitted and if not submit one.
Thank you, I did not understand what the "Website" tag meant. WEBSITE-1203 has been created.

I also voted for P_I's bug report.
Locked

Return to “[3.1.x] Support Forum”