Upgraded from 3.0.11 to 3.1.2...everything is gone?

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
Proulx06
Registered User
Posts: 19
Joined: Wed Mar 02, 2011 3:52 pm

Upgraded from 3.0.11 to 3.1.2...everything is gone?

Post by Proulx06 » Mon Jan 12, 2015 8:44 pm

I know I did something wrong, but not sure what. I followed these instructions:

To upgrade, perform the following steps:

Make a backup of the original files
Make a backup of the database
Delete all files EXCEPT for:
The config.php file
The images/ directory
The files/ directory
The store/ directory
Upload the contents of the 3.1.x Full Package into your forum's directory.
Browse to install/database_update.php
Delete the install/ directory


I ran into an issue when doing the install steps when it wanted me to define the database prefix. I had to add a couple letters to it because I got the "Tables with the specified prefix already exist, please choose an alternative" message. So instead of phpbb_, I changed it to phpbbjp_.

I finally got through the install and now it appears I have a brand new board. All my settings, posts, etc are gone. What can I do? I do have a full backup of the files.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66738
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Upgraded from 3.0.11 to 3.1.2...everything is gone?

Post by Lumpy Burgertushie » Mon Jan 12, 2015 8:51 pm

using your ftp, upload your backup copy of the old config.php file to overwrite the new one.

that will bring your board back.

those instructions really need to be updated to keep this from happening to people.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Proulx06
Registered User
Posts: 19
Joined: Wed Mar 02, 2011 3:52 pm

Re: Upgraded from 3.0.11 to 3.1.2...everything is gone?

Post by Proulx06 » Mon Jan 12, 2015 8:55 pm

Now my board is showing this error:

Code: Select all

Fatal error: Uncaught exception 'Twig_Error_Loader' with message 'Unable to find template "index_body.html" (looked into: ).' in /home/joeyproulx/backyard-hockey.com/forums/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:202 Stack trace: #0 /home/joeyproulx/backyard-hockey.com/forums/phpbb/template/twig/loader.php(106): Twig_Loader_Filesystem->findTemplate('index_body.html') #1 /home/joeyproulx/backyard-hockey.com/forums/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(138): phpbb\template\twig\loader->findTemplate('index_body.html') #2 /home/joeyproulx/backyard-hockey.com/forums/vendor/twig/twig/lib/Twig/Environment.php(265): Twig_Loader_Filesystem->getCacheKey('index_body.html') #3 /home/joeyproulx/backyard-hockey.com/forums/vendor/twig/twig/lib/Twig/Environment.php(312): Twig_Environment->getTemplateClass('index_body.html', NULL) #4 /home/joeyproulx/backyard-hockey.com/forums/phpbb/template/twig/environment.php(151): Twig_Environment->loadTemplate('index_body.html', NULL) #5 /home/joeyproulx/backyard-hockey.com/forums/v in /home/joeyproulx/backyard-hockey.com/forums/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 202

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Upgraded from 3.0.11 to 3.1.2...everything is gone?

Post by Oyabun1 » Mon Jan 12, 2015 9:45 pm

Open the board’s /cache/ folder on the server and delete everything except index.htm and .htaccess.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

Proulx06
Registered User
Posts: 19
Joined: Wed Mar 02, 2011 3:52 pm

Re: Upgraded from 3.0.11 to 3.1.2...everything is gone?

Post by Proulx06 » Mon Jan 12, 2015 11:38 pm

Thanks. Now I'm getting this:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Table 'backyard_hockey_com_1.phpbb_ext' doesn't exist [1146]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66738
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Upgraded from 3.0.11 to 3.1.2...everything is gone?

Post by Lumpy Burgertushie » Mon Jan 12, 2015 11:53 pm

upload the 3.1.2 folder named install.

in your browser, go to yourdomain.com/yourphpbb/install/database_update.php

when it is done, delete that folder named install and purge the cache.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Proulx06
Registered User
Posts: 19
Joined: Wed Mar 02, 2011 3:52 pm

Re: Upgraded from 3.0.11 to 3.1.2...everything is gone?

Post by Proulx06 » Tue Jan 13, 2015 7:09 pm

You are all awesome. Thank you!

Locked

Return to “[3.1.x] Support Forum”