[CDB]Ajax Shoutbox

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
Stoker 4.0
Registered User
Posts: 1483
Joined: Sun Feb 13, 2011 1:33 pm
Location: Funen, Denmark
Name: Ulrik Christensen
Contact:

Re: [RC]Ajax Shoutbox

Post by Stoker 4.0 » Sun Feb 08, 2015 5:24 am

With the shoutbox enabled I can no longer edit board prefs in UCP. Changed settings doesnt get saved.

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25325
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [RC]Ajax Shoutbox

Post by Paul » Sun Feb 08, 2015 11:06 am

Souloibur, ok, I looked into the cause. The problem was your style didn't inherit from prosilver correctly, causing the templates not to be loaded. I changed your style to inherit it from prosilver, and it works now :).
Please make sure to delete my test account and change your FTP password.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

User avatar
BryanFR
Registered User
Posts: 79
Joined: Wed Aug 27, 2014 4:44 pm
Location: Eure, FR
Contact:

Re: [RC]Ajax Shoutbox

Post by BryanFR » Sun Feb 08, 2015 11:39 am

Your extension does not work on a forum in production?
I'm student in the life based in France. My community is : http://www.thebryx.cf

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25325
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [RC]Ajax Shoutbox

Post by Paul » Sun Feb 08, 2015 12:25 pm

It should work, however you shouldn't use any extension from the development forum in a production forum.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

RaacerzZ
Registered User
Posts: 15
Joined: Sun Feb 08, 2015 1:03 pm

Re: [RC]Ajax Shoutbox

Post by RaacerzZ » Sun Feb 08, 2015 1:08 pm

Hello,

I have a problem with the installation of the shoutbox, I have copied paul999 / shoutbox in the / ext, and I turned in extensions, but shoutbox does not appear on my forum ...

I may be missing something to make it appear? I have checked the shoutbox is on and I can change the options in the "extensions" tab ...

Anyone has had this problem? Is there a solution? Thank you!

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25325
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [RC]Ajax Shoutbox

Post by Paul » Sun Feb 08, 2015 1:47 pm

Did you assign the permissions correctly? What template are you using?
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

RaacerzZ
Registered User
Posts: 15
Joined: Sun Feb 08, 2015 1:03 pm

Re: [RC]Ajax Shoutbox

Post by RaacerzZ » Sun Feb 08, 2015 2:22 pm

I use the theme "Modern Silver". Permissions? which files need to change for this?

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25325
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [RC]Ajax Shoutbox

Post by Paul » Sun Feb 08, 2015 2:31 pm

None. You need to assign the correct user permissions in your ACP.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

RaacerzZ
Registered User
Posts: 15
Joined: Sun Feb 08, 2015 1:03 pm

Re: [RC]Ajax Shoutbox

Post by RaacerzZ » Sun Feb 08, 2015 2:36 pm

How so? I have to go, where to change that? In Users and Groups?

RaacerzZ
Registered User
Posts: 15
Joined: Sun Feb 08, 2015 1:03 pm

Re: [RC]Ajax Shoutbox

Post by RaacerzZ » Sun Feb 08, 2015 3:13 pm

Ha thank you I made it!

If I have two questions:

- Is it planned to sound when members post a message?
- And is it planned to automated messages when a member logs / disconnect from the chat?

Again thank you for your help.

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25325
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [RC]Ajax Shoutbox

Post by Paul » Sun Feb 08, 2015 3:15 pm

No too both.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

Souloibur
Registered User
Posts: 10
Joined: Sun Jan 25, 2015 6:39 pm

Re: [RC]Ajax Shoutbox

Post by Souloibur » Sun Feb 08, 2015 4:14 pm

Paul wrote:Souloibur, ok, I looked into the cause. The problem was your style didn't inherit from prosilver correctly, causing the templates not to be loaded. I changed your style to inherit it from prosilver, and it works now :).
Please make sure to delete my test account and change your FTP password.
Thanks! I really apreciate your help. One more thing, I want to know what files you have modified because if the theme gets an update I don't want to loose the work you have done. Thanks again :D

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25325
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [RC]Ajax Shoutbox

Post by Paul » Sun Feb 08, 2015 4:17 pm

I didn't update any file, just changed your style in the app to inherent prosilver
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

Souloibur
Registered User
Posts: 10
Joined: Sun Jan 25, 2015 6:39 pm

Re: [RC]Ajax Shoutbox

Post by Souloibur » Sun Feb 08, 2015 4:36 pm

Paul wrote:I didn't update any file, just changed your style in the app to inherent prosilver
Okay, thanks :)

User avatar
UXA
Registered User
Posts: 6
Joined: Fri Feb 06, 2015 12:34 pm

Re: [RC]Ajax Shoutbox

Post by UXA » Sun Feb 08, 2015 8:38 pm

I have domain.com/forum but when i click any member name on chat it shows me domain.com/memberlist.php?mode=viewprofile&u=xxxxx

How to fix this?

Thank you for your hard work! :mrgreen:

Locked

Return to “Extensions in Development”