[RC] phpBB Gallery

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
leschek
Registered User
Posts: 789
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [DEV] phpBB Gallery

Post by leschek » Wed Feb 11, 2015 12:51 pm

Lucifer4o on 24 Dec 2014 wrote:While the site was down, I did some work:
....
Just added the little trick to disable all Add-ons on disabling the core.
...
I would like to ask if would be possible to do something similar for enabling. I mean if user accidentally enable some of the add-ons first he/she will get error.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Wed Feb 11, 2015 1:00 pm

Give me few minutes.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Wed Feb 11, 2015 1:16 pm

leschek wrote:
Lucifer4o on 24 Dec 2014 wrote:While the site was down, I did some work:
....
Just added the little trick to disable all Add-ons on disabling the core.
...
I would like to ask if would be possible to do something similar for enabling. I mean if user accidentally enable some of the add-ons first he/she will get error.
leschek wrote:
Lucifer4o on 24 Dec 2014 wrote:While the site was down, I did some work:
....
Just added the little trick to disable all Add-ons on disabling the core.
...
I would like to ask if would be possible to do something similar for enabling. I mean if user accidentally enable some of the add-ons first he/she will get error.
Done
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

leschek
Registered User
Posts: 789
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [BETA] phpBB Gallery

Post by leschek » Wed Feb 11, 2015 1:33 pm

Thank you.
Should I (and probably others) report also smaller issues with gallery now? For example there are some missing variables in language files etc.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Wed Feb 11, 2015 1:37 pm

leschek wrote:Thank you.
Should I (and probably others) report also smaller issues with gallery now? For example there are some missing variables in language files etc.
Sure - go for it. All reports are welcomed while I create tests.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

leschek
Registered User
Posts: 789
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [BETA] phpBB Gallery

Post by leschek » Wed Feb 11, 2015 2:20 pm

OK. It seems that some language variables are (I wouldn't say hardcoded) loaded only from English language file. I'm trying to translate gallery_notification.php and the language strings (in notification settings) are not updated even if I upload the files on server. I can see translated strings only if I replace original English language file with my non English translation (so it mean that I use Czech language, but it read language strings from English language file). This is not everywhere, just in notification and link on phpBB header to Gallery (file info_acp_gallery.php)

in language file gallery_notification.php:

Code: Select all

'NOTIFICATION_PHPBBGALLERY_IMAGE_FOR_APPROVAL'	=> '%2$s uploaded images for approval in album <strong>%1$s</strong>',
I think this should be also singular (in case that user uploaded only one image). I didn't check it, but I guess it apply for these string too:

'NOTIFICATION_PHPBBGALLERY_IMAGE_APPROVED' => 'Images in album <strong>%1$s</strong> were approved',

'NOTIFICATION_PHPBBGALLERY_NEW_IMAGE' => 'New images were uploaded to album <strong>%1$s</strong>',

I think the following string:

'NOTIFICATION_TYPE_PHPBBGALLERY_NEW_COMMENT' => 'New comments',

should be more descriptive, because users will not know that it means comments in Gallery. I think it should be something like: 'NOTIFICATION_TYPE_PHPBBGALLERY_NEW_COMMENT' => 'Someone send new comments to Gallery',

While speaking about notification - it would be nice if it is divided into categories. For example Images waiting for approval and New image report should be in "Moderation Notifications".

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Wed Feb 11, 2015 3:16 pm

I don't have the language issues - all languages are loaded from the files ... have you tried clearing the cache?

Oh this ... I use plural because user may have loaded few images at once ...

If this bugs you so much - I can work on it. If not - I can make it wait 1.2.1
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

Bernd R.
Registered User
Posts: 25
Joined: Fri Feb 06, 2015 5:01 pm

Re: [BETA] phpBB Gallery

Post by Bernd R. » Wed Feb 11, 2015 4:08 pm

I`d install the gallery version 1.2.0 on a 3.1.3 board. Most things work, I see all images and albums from my 3.0.13 board. But if I enter the board and now klick click the gallery link I will see a white page: Fatal error: Class 'phpbb_gallery' not found in /www/htdocs/***/****/testforum/gallery/index.php on line 20 and the adress-line of the browswer shows http://www.xxx.net/testforum/gallery/ instead of http://www.xxx.net/testforum/app.php/gallery. If I visit a forum first and use the gallery-link now, it works correctely. Any idea what to do?
A big thank you to all the people, spending time to keep phpBB running

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Wed Feb 11, 2015 4:16 pm

There is bug report in JIRA for this issue. It is not related to the gallery.

https://github.com/phpbb/phpbb/pull/3392
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

Bernd R.
Registered User
Posts: 25
Joined: Fri Feb 06, 2015 5:01 pm

Re: [BETA] phpBB Gallery

Post by Bernd R. » Wed Feb 11, 2015 4:17 pm

Thanks for this quick reply!
A big thank you to all the people, spending time to keep phpBB running

leschek
Registered User
Posts: 789
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [BETA] phpBB Gallery

Post by leschek » Wed Feb 11, 2015 4:21 pm

Lucifer4o wrote:I don't have the language issues - all languages are loaded from the files ... have you tried clearing the cache?
Yes I cleared the cache. I also try to replace the Czech language file gallery_notifications.php with Bulgarian and it still shows notification settings in English even if I change language to Czech (it suppose to be in Bulgarian).

Is possible to download somewhere Bulgarian pack for phpBB 3.1 (I didn't find it among language packs here on phpBB.com)? I can try to install it and see. Maybe there is some issue with my Czech language pack.
Lucifer4o wrote:Oh this ... I use plural because user may have loaded few images at once ...

If this bugs you so much - I can work on it.
No. It's just small thing, it doesn't need to be changed.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Wed Feb 11, 2015 4:26 pm

leschek wrote:
Lucifer4o wrote:I don't have the language issues - all languages are loaded from the files ... have you tried clearing the cache?
Yes I cleared the cache. I also try to replace the Czech language file gallery_notifications.php with Bulgarian and it still shows notification settings in English even if I change language to Czech (it suppose to be in Bulgarian).

Is possible to download somewhere Bulgarian pack for phpBB 3.1 (I didn't find it among language packs here on phpBB.com)? I can try to install it and see. Maybe there is some issue with my Czech language pack.
Lucifer4o wrote:Oh this ... I use plural because user may have loaded few images at once ...

If this bugs you so much - I can work on it.
No. It's just small thing, it doesn't need to be changed.
There is no Bulgarian yet.

You could try copying EN as Chez (this is how I do it on my test board).
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

leschek
Registered User
Posts: 789
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [BETA] phpBB Gallery

Post by leschek » Wed Feb 11, 2015 4:29 pm

Lucifer4o wrote:You could try copying EN as Chez (this is how I do it on my test board).
What is Chez?

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Wed Feb 11, 2015 4:31 pm

leschek wrote:
Lucifer4o wrote:You could try copying EN as Chez (this is how I do it on my test board).
What is Chez?
Czech language

I am really sorry. It was unintentional mistake (I know how much I upset about making mistake with my country so I apologize)
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

leschek
Registered User
Posts: 789
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [BETA] phpBB Gallery

Post by leschek » Wed Feb 11, 2015 5:11 pm

Oh. It's not a problem at all. I don't care much about such things. I thought you used some term I don't know and didn't think it could be misspelling.

Now to the issue. Not sure if we understand each other. Here is what I have:
  • I'm using as phpBB language my own translation (cs_alt). So far I didn't have any problem with it and other extensions I translated to it.
  • I translated gallery and have in gallery language folder cs_alt with the translation. There is not problem with my gallery translation in ACP and on gallery page (except a few missing variables).
  • Problem I have discovered so far is with link in header file info_acp_gallery.php where I have line
    'GALLERY' => 'Galerie',
    but it shows "Gallery" (it's loaded from English language file). Interesting thing is that strings in ACP are loaded from this file correctly.
    And I have the same issue also on notification settings page. I set language of board to cs_alt. I translated partially file gallery_notifications, but when I look into notification settings it shows me English lines that I translated (rest of gallery is OK as I mentioned above). I thought it can be problem with my translation, so I replace original English language file with mine and now I can see the lines I translated (on notification settings page), but they are loaded from English language files and not cs_alt, because I didn't change board language (it still is cs_alt).
I can upload my language files (for board and gallery) somewhere if you want to try it yourself.

Locked

Return to “Extensions in Development”