[CDB] mChat

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
Slechtvalk
Registered User
Posts: 34
Joined: Tue Jan 15, 2008 12:56 pm

Re: [DEV] mChat

Post by Slechtvalk » Fri May 29, 2015 11:21 pm

Thank you for altering into an extension!

I have one issue too, when i post, the profile image is not working, after reloading the page it is displayed. any idea?

User avatar
spaceace
Registered User
Posts: 1857
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: [DEV] mChat

Post by spaceace » Sat May 30, 2015 1:32 pm

Slechtvalk wrote:Thank you for altering into an extension!

I have one issue too, when i post, the profile image is not working, after reloading the page it is displayed. any idea?
This issue has been posted about many times in this topic and the problem is in the extensions coding for how it handles the image urls. In my extension, the actual problem was found to be a problem in the phpbb core code itself.

User avatar
GoBieN
Registered User
Posts: 543
Joined: Fri Mar 05, 2004 5:22 pm
Location: Belgium
Contact:

Re: [DEV] mChat

Post by GoBieN » Mon Jun 01, 2015 9:23 pm

Circumvent with rewrite rules.

User avatar
spaceace
Registered User
Posts: 1857
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: [DEV] mChat

Post by spaceace » Tue Jun 02, 2015 8:03 pm

GoBieN wrote:Circumvent with rewrite rules.
not all hosts support this as i found while fixing the issue in mine ;)

relying on a host to fix an issue should not be an option to suggest everyone to use as it should work with or without mod rewrite.

User avatar
GoBieN
Registered User
Posts: 543
Joined: Fri Mar 05, 2004 5:22 pm
Location: Belgium
Contact:

Re: [DEV] mChat

Post by GoBieN » Tue Jun 02, 2015 11:01 pm

I'm not the author, I'm just giving suggestions on how to circumvent the problem. Notice the verb to circumvent in both my messages. Since you fixed this already once, how about you do a fork on git and fix it?

User avatar
spaceace
Registered User
Posts: 1857
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: [DEV] mChat

Post by spaceace » Wed Jun 03, 2015 8:54 pm

GoBieN wrote:Since you fixed this already once, how about you do a fork on git and fix it?
i fixed my own extension and the coding for this one is different ;)

Tarantino
Registered User
Posts: 766
Joined: Sat Feb 18, 2012 1:51 pm
Contact:

Re: [DEV] mChat

Post by Tarantino » Thu Jun 04, 2015 4:05 am

Hi there, phpBB 3.1.4 here, and I've found a bug.

Before activate extension:
http://i.imgur.com/5ZFAYpx.png

After activate extension, and disable mchat:
http://i.imgur.com/t9C6sW2.png

User avatar
peteetongman
Registered User
Posts: 395
Joined: Wed Jul 17, 2013 4:29 am
Location: Atlanta GA USA

Re: [DEV] mChat

Post by peteetongman » Thu Jun 04, 2015 4:05 pm

Tarantino wrote:Hi there, phpBB 3.1.4 here, and I've found a bug.

Before activate extension:
http://i.imgur.com/5ZFAYpx.png

After activate extension, and disable mchat:
http://i.imgur.com/t9C6sW2.png

Just FYI I disabled mChat and do not see the behaviour you have pictured

ninowebs
Registered User
Posts: 191
Joined: Tue Dec 15, 2009 6:36 pm
Location: Italia Sicilia
Contact:

Re: [DEV] mChat

Post by ninowebs » Fri Jun 05, 2015 12:06 pm

in a trial installation extension Mchat 'm testing , I have a problem you do not see any message when sending messages , I set all admin permissions on it but the same , some of you can help me , thanks

mark5228
Registered User
Posts: 58
Joined: Thu May 14, 2015 1:07 pm

Re: [DEV] mChat

Post by mark5228 » Sat Jun 06, 2015 11:03 am

great extension. which css file and where do i need to edit to change the colour off the text when typeing.

Image

Thunder_one
Registered User
Posts: 119
Joined: Sat May 09, 2015 11:00 pm

Re: [DEV] mChat

Post by Thunder_one » Sat Jun 06, 2015 11:08 am

Open: ext\dmzx\mchat\styles\prosilver\theme\mchat.css

Code: Select all

input.mChatText {
   cursor: text;
   width: 50%;
   background-color: #FFFFFF;
   border: 1px solid #B4BAC0;
   color: #333333;
   padding: 5px 5px 3px 5px;
   margin: 3px 0px 3px 5px;
}
Change color: #333333;

Thunder_one
Registered User
Posts: 119
Joined: Sat May 09, 2015 11:00 pm

Re: [DEV] mChat

Post by Thunder_one » Sun Jun 07, 2015 8:30 am

Hi

How can I install the Mchat in the JV-Arcade?

Thanks in advance.

User avatar
mrgtb
Registered User
Posts: 563
Joined: Wed Oct 03, 2007 10:51 am

Re: [DEV] mChat

Post by mrgtb » Tue Jun 09, 2015 7:30 pm

Seeing some errors being generated creating in an error.log file on server.

Code: Select all

[09-Jun-2015 00:54:09 America/New_York] PHP Fatal error:  Uncaught exception 'phpbb\exception\http_exception' with message 'MCHAT_ERROR_NOT_IMPLEMENTED' in /home/xxxxxxx/public_html/ext/dmzx/mchat/core/render_helper.php:540
Stack trace:
#0 /home/xxxxxxx/public_html/ext/dmzx/mchat/event/listener.php(128): dmzx\mchat\core\render_helper->render_data_for_page(true)
#1 [internal function]: dmzx\mchat\event\listener->display_mchat_on_index(Object(phpbb\event\data))
#2 /home/xxxxxxx/public_html/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php(164): call_user_func(Array, Object(phpbb\event\data))
#3 /home/xxxxxxx/public_html/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php(53): Symfony\Component\EventDispatcher\EventDispatcher->doDispatch(Array, 'core.index_modi...', Object(phpbb\event\data))
#4 /home/xxxxxxx/public_html/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/ContainerAwareEventDispatcher.php(167): Symfony\Component\EventDispatcher\EventDispatcher->dispatch('core.index_ in /home/xxxxxxx/public_html/ext/dmzx/mchat/core/render_helper.php on line 540
[09-Jun-2015 00:55:20 America/New_York] PHP Fatal error:  Uncaught exception 'phpbb\exception\http_exception' with message 'MCHAT_ERROR_NOT_IMPLEMENTED' in /home/xxxxxxx/public_html/ext/dmzx/mchat/core/render_helper.php:540
Stack trace:
#0 /home/xxxxxxx/public_html/ext/dmzx/mchat/event/listener.php(128): dmzx\mchat\core\render_helper->render_data_for_page(true)
#1 [internal function]: dmzx\mchat\event\listener->display_mchat_on_index(Object(phpbb\event\data))
#2 /home/xxxxxxx/public_html/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php(164): call_user_func(Array, Object(phpbb\event\data))
#3 /home/xxxxxxx/public_html/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php(53): Symfony\Component\EventDispatcher\EventDispatcher->doDispatch(Array, 'core.index_modi...', Object(phpbb\event\data))
#4 /home/xxxxxxx/public_html/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/ContainerAwareEventDispatcher.php(167): Symfony\Component\EventDispatcher\EventDispatcher->dispatch('core.index_ in /home/xxxxxxx/public_html/ext/dmzx/mchat/core/render_helper.php on line 540
[09-Jun-2015 00:56:48 America/New_York] PHP Fatal error:  Uncaught exception 'phpbb\exception\http_exception' with message 'MCHAT_ERROR_NOT_IMPLEMENTED' in /home/xxxxxxx/public_html/ext/dmzx/mchat/core/render_helper.php:540
Stack trace:
#0 /home/xxxxxxx/public_html/ext/dmzx/mchat/event/listener.php(128): dmzx\mchat\core\render_helper->render_data_for_page(true)
#1 [internal function]: dmzx\mchat\event\listener->display_mchat_on_index(Object(phpbb\event\data))
#2 /home/xxxxxxx/public_html/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php(164): call_user_func(Array, Object(phpbb\event\data))
#3 /home/xxxxxxx/public_html/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php(53): Symfony\Component\EventDispatcher\EventDispatcher->doDispatch(Array, 'core.index_modi...', Object(phpbb\event\data))
#4 /home/xxxxxxx/public_html/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/ContainerAwareEventDispatcher.php(167): Symfony\Component\EventDispatcher\EventDispatcher->dispatch('core.index_ in /home/xxxxxxx/public_html/ext/dmzx/mchat/core/render_helper.php on line 540

bmcsoft
Registered User
Posts: 3
Joined: Sat Jun 13, 2015 9:24 pm

Re: [DEV] mChat

Post by bmcsoft » Sat Jun 13, 2015 9:56 pm

Hello, all.
On my forum (phpBB 3.1.4) recent message(s) in chat contain incorrect links, for example:
1)

Code: Select all

<a href="./../memberlist.php?mode=viewprofile&u=2" title="Profile">
  <img src="./../download/file.php?avatar=1432395126.gif" width="30" height="30" alt="Avatar">
If I press F5 to refresh forum page, these links automatically changed to correct:
2)

Code: Select all

<a href="./memberlist.php?mode=viewprofile&u=2" title="Profile">
  <img src="./download/file.php?avatar=1432395126.gif" width="30" height="30" alt="Avatar">
If I open chat with such link separately: "www.hostname.com/forum/app.php/chat",
first type of links always correct and all time point at right objects.

How to fix this problem?

bmcsoft
Registered User
Posts: 3
Joined: Sat Jun 13, 2015 9:24 pm

Re: [DEV] mChat

Post by bmcsoft » Sun Jun 14, 2015 7:35 am

Author of mChat helped me:
Is you url rewrite on ?

Go to acp and then server settings and enable url rewrite and purge boards cache.
It works!

Locked

Return to “Extensions in Development”