Super Quick Reply

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
157
62%
Very Good
31
12%
Good
30
12%
Fair
10
4%
Poor
25
10%
 
Total votes: 253

softdrops.
Registered User
Posts: 11
Joined: Sat Jan 22, 2005 4:28 am

Post by softdrops. »

UPDATE phpbb_users SET user_show_quickreply=0 WHERE user_id=-1;
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_quickreply', '1');

Can anybody help me with doing these MySQL directions? I was able to get the first two but was thoroughly stuck on the last 2 :/.

edit: nvm
User avatar
PCGUY112887
Registered User
Posts: 502
Joined: Thu Apr 01, 2004 12:39 am
Location: Illinois
Contact:

Post by PCGUY112887 »

Humm...
## Anonymous users are not allowed to use the SQR form. It's
## not a bug but rather a feature.
## If yow want to allow the SQR form for anonymous users, run
## the following SQL queries:
## UPDATE phpbb_users SET user_show_quickreply=$show WHERE user_id=-1;
## where $show: 0 - not show, 1 - show, 2 - on the last page only
## UPDATE phpbb_users SET user_quickreply_mode=$mode WHERE user_id=-1;
## where $mode: 0 - basic mode, 1 - advanced mode
## The SQR form also contains a text field for a user name.
## I'm planning to add this feature in the phpBB config of
## the next release.

Ok... what EXACTELLY should we run for the queries? When I try to run like...
UPDATE phpbb_users SET user_show_quickreply=$show WHERE user_id=-1;
where $show: 0 - not show, 1 - show, 2 - on the last page only

I get...
#1054 - Unknown column '$show' in 'field list'


I installed via easymod and know that the required database changes took place...
softdrops.
Registered User
Posts: 11
Joined: Sat Jan 22, 2005 4:28 am

Post by softdrops. »

^ I found that for the SQL thingies, you just put in that one box at the bottom. You just literally type in what's on the install file but I was manually doing it instead -______-" I didn't know you just insert it in like that :X.
asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Post by asinshesq »

PCGUY112887 wrote: Humm...
## Anonymous users are not allowed to use the SQR form. It's
## not a bug but rather a feature.
## If yow want to allow the SQR form for anonymous users, run
## the following SQL queries:
## UPDATE phpbb_users SET user_show_quickreply=$show WHERE user_id=-1;
## where $show: 0 - not show, 1 - show, 2 - on the last page only
## UPDATE phpbb_users SET user_quickreply_mode=$mode WHERE user_id=-1;
## where $mode: 0 - basic mode, 1 - advanced mode
## The SQR form also contains a text field for a user name.
## I'm planning to add this feature in the phpBB config of
## the next release.

Ok... what EXACTELLY should we run for the queries? When I try to run like...
UPDATE phpbb_users SET user_show_quickreply=$show WHERE user_id=-1;
where $show: 0 - not show, 1 - show, 2 - on the last page only

I get...
#1054 - Unknown column '$show' in 'field list'


I installed via easymod and know that the required database changes took place...


$show was just a way for the author to tell you what number to put in there depending on what result you wanted to achieve. So, if you want to have it show for guests only on the last page (i.e. $show = 2), you would run this query in mysql:

Code: Select all

UPDATE phpbb_users SET user_show_quickreply=2 WHERE user_id=-1;
Or, if you want, you can use phpmyadmin or whatever mysql gui you usually use and directly change the column 'user_show_quickreply' to '2' for the row that has user_id = -1.
Mav3r1ck
Registered User
Posts: 23
Joined: Thu Sep 16, 2004 4:52 pm

Post by Mav3r1ck »

I run the boards at http://boards.zerovision.net and I recently installed the Super Quick Reply mod with EasyMOD. The installation went good and I can now post replies quicker. I have one problem though, after I installed the mod my topics were crunched up like the width was changed or something. You can check it out if you visit any of our topics at the above board. If someone could tell me where I could fix this I would appreciate it. I'm guessing it had something to do with the fact I'm using the Darksky style? Any help is appreciated.
Dan39
Registered User
Posts: 186
Joined: Tue Apr 20, 2004 12:39 am
Contact:

Post by Dan39 »

Nice mod, tho its just like the whole post reply but at end of topic.
Pluggen
Registered User
Posts: 19
Joined: Tue Jul 27, 2004 7:28 am

Post by Pluggen »

uddosklanis wrote: I installed this yesterday and found some javascript error :x

just replace all the document.post. to document.forms['post']
and if it is in eval then remember to put an escape char before ' ie document.forms[\'post\']

edit : lol didnt state wot the error was :D ... smilies werent coming thru thts it


I have exact the same problem. But I wasn't able to resolve the problem.

the errors are:
ImageImage

The first error appears when clicking on a emoticon, the second when clicking on a bbcode-button. Hence, the problem only appears while using the advanced modus.

code:

Code: Select all

function emoticon(text) {
	var txtarea = document.post.message;
	text = ' ' + text + ' ';
	if (txtarea.createTextRange && txtarea.caretPos) {
		var caretPos = txtarea.caretPos;
		caretPos.text = caretPos.text.charAt(caretPos.text.length - 1) == ' ' ? caretPos.text + text + ' ' : caretPos.text + text;
		txtarea.focus();
	} else {
		txtarea.value  += text;
		txtarea.focus();
	}
}

Code: Select all

// Shows the help messages in the helpline window
function helpline(help) {
	document.post.helpbox.value = eval(help + "_help");
}
please help me out here...

:(
hayk
Registered User
Posts: 428
Joined: Tue Feb 04, 2003 10:53 am
Location: exUSSR
Contact:

Post by hayk »

Pluggen
The thing is that on your "view topic" page has 2 forms with the same "post" name.
First is SQR, second - Search Topic (by the way, what's the name of this mod?).
For determining that error you should rename Search Topic form.
I could rename SQR form, but then I should make a lot of changes in code.
hayk
Registered User
Posts: 428
Joined: Tue Feb 04, 2003 10:53 am
Location: exUSSR
Contact:

Post by hayk »

Mav3r1ck wrote: I run the boards at http://boards.zerovision.net and I recently installed the Super Quick Reply mod with EasyMOD. The installation went good and I can now post replies quicker. I have one problem though, after I installed the mod my topics were crunched up like the width was changed or something. You can check it out if you visit any of our topics at the above board. If someone could tell me where I could fix this I would appreciate it. I'm guessing it had something to do with the fact I'm using the Darksky style? Any help is appreciated.

Apply this "hack"

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/Your_Template/viewtopic_body.tpl

#
#-----[ FIND ]------------------------------------------
#
  <tr> 
	<td width="40%" valign="top" nowrap="nowrap" align="left"><span class="gensmall">{S_WATCH_TOPIC}</span><br />

#
#-----[ BEFORE, ADD ]--------------------------------------
#
<table width="100%" cellspacing="2" border="0" align="center">
Pluggen
Registered User
Posts: 19
Joined: Tue Jul 27, 2004 7:28 am

Post by Pluggen »

hayk wrote: Pluggen
The thing is that on your "view topic" page has 2 forms with the same "post" name.
First is SQR, second - Search Topic (by the way, what's the name of this mod?).
For determining that error you should rename Search Topic form.
I could rename SQR form, but then I should make a lot of changes in code.

Thanks for your reply. Renaming the search topic resolved my problem.


More information about topic search:
#####################################################################################
## MOD Title: Topic Search
## MOD Author: Darkmonkey <info@darkmonkeydesigns.com> (Brendan kettle) http://www.darkmonkeydesigns.com
## MOD Description: Lets a user search within a specified topic
## MOD Version: 1.1.0
##
## Installation Level: Easy
## Installation Time: 15 Minutes (2 Minutes with EasyMOD)
## Files To Edit:
## language/lang_english/lang_main.php
## templates/subSilver/viewtopic_body.tpl
## search.php
## viewtopic.php
##
## Included Files:
## templates/subSilver/topic_search_results.tpl
##
#####################################################################################
sleepyweasel
Registered User
Posts: 39
Joined: Mon Oct 18, 2004 6:23 pm

Post by sleepyweasel »

sleepyweasel wrote: I've installed this mod, and I like it, but I have an issue with some I've installed since this and can't get them to show up:

The strikethrough add-on and a smilie dropdown menu. Both of these show in the standard Topic Reply screen, but not in the quick reply. I tried manually adding the same code from these 2 mods into the quickreply tpl and php pages, but nothing showed (the smilie drop-down box appeared, but was blank).

Anyone know where I can get help on this?


[ben stein]Bueller? Bueller? Anyone? Anyone?[/ben stein]
hayk
Registered User
Posts: 428
Joined: Tue Feb 04, 2003 10:53 am
Location: exUSSR
Contact:

Post by hayk »

sleepyweasel wrote:
sleepyweasel wrote:I've installed this mod, and I like it, but I have an issue with some I've installed since this and can't get them to show up:

The strikethrough add-on and a smilie dropdown menu. Both of these show in the standard Topic Reply screen, but not in the quick reply. I tried manually adding the same code from these 2 mods into the quickreply tpl and php pages, but nothing showed (the smilie drop-down box appeared, but was blank).

Anyone know where I can get help on this?


[ben stein]Bueller? Bueller? Anyone? Anyone?[/ben stein]


Give me the links to these two mods and your forum and I'll try out to help you.
sleepyweasel
Registered User
Posts: 39
Joined: Mon Oct 18, 2004 6:23 pm

Post by sleepyweasel »

Thanks hayk--but I think I decided to wait for the 3.0 release or turn off the quick reply.
bebe2803
Registered User
Posts: 49
Joined: Tue Jan 25, 2005 7:16 am
Location: Hong Kong

Post by bebe2803 »

Great mod, very useful, and it fix to all templates (that i have installed)

demo : here, although that is not a english forum, but you can see the sqr mod under the posts
phpbbindia
Registered User
Posts: 6
Joined: Sun Feb 20, 2005 2:02 pm
Contact:

Post by phpbbindia »

great mod... thanks a lot mate.. i will try it out
Post Reply

Return to “[2.0.x] MOD Database Releases”