General Error with 3.1.5 to 3.1.6 upgrade - resolved

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
User avatar
Fogbow_Foggy
Registered User
Posts: 109
Joined: Sun Sep 26, 2010 11:25 pm

General Error with 3.1.5 to 3.1.6 upgrade - resolved

Post by Fogbow_Foggy » Sun Sep 13, 2015 9:30 am

Support Request Template
What version of phpBB are you using? phpBB 3.1.5
What is your board's URL? http://thefogbow.com/forum/
Who do you host your board with? ServInt
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Conversion from another software
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What board software did you convert from? InvisionPower Board
What extensions do you have installed? List in graphic below
What styles do you currently have installed? digi, Latte, OrangeBBEs, prosilver Special Edition, SE Square Left, we_universal
What language(s) is your board currently using? American English, British English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Tried to update from 3.1.5 to 3.1.6
Please describe your problem. General error - quoted below
Generated by SRT Generator

I had a General Error, so I can't upgrade from 3.1.5 to 3.1.6.
Running Windows 8.1; 14 extensions installed; Apache Version 2.2.29; PHP Version 5.6.11; MySQL Version 5.6.23.
I can reach the information page for the upgrade, but when I click on the Update tab itself, I get:
General Error
SQL ERROR [ mysqli ]

Access denied for user 'wlbjr_wlbryanjr'@'localhost' (using password: YES) [1045]

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/phpbb/db/driver/mysqli.php
LINE: 109
CALL: phpbb\db\driver\driver->sql_error()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\driver\mysqli->sql_connect()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 1132
CALL: call_user_func_array()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 968
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->callMethod()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 490
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->createService()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/phpbb/db/driver/factory.php
LINE: 52
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->get()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\factory->get_driver()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/phpbb/config/db.php
LINE: 57
CALL: phpbb\db\driver\factory->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\config\db->__construct()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 959
CALL: ReflectionClass->newInstanceArgs()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 490
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->createService()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 1005
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->get()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 1002
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->resolveServices()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 944
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->resolveServices()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 490
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->createService()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/install/install_update.php
LINE: 87
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->get()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/install/index.php
LINE: 409
CALL: install_update->main()

FILE: /home/wlbjr/public_html/thefogbow.com/forum/install/index.php
LINE: 289
CALL: module->load()
Last edited by Fogbow_Foggy on Mon Sep 14, 2015 9:25 am, edited 5 times in total.

User avatar
Fogbow_Foggy
Registered User
Posts: 109
Joined: Sun Sep 26, 2010 11:25 pm

General Error with 3.1.5 to 3.1.6 upgrade

Post by Fogbow_Foggy » Sun Sep 13, 2015 9:36 am

Here's a list of my extensions:
extensions.png
Last edited by Fogbow_Foggy on Sun Sep 13, 2015 11:14 am, edited 2 times in total.

User avatar
david63
Registered User
Posts: 16330
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Fatal Error with 3.1.6 upgrade

Post by david63 » Sun Sep 13, 2015 9:44 am

The clue is here
Access denied for user 'wlbjr_wlbryanjr'@'localhost' (using password: YES) [1045]
Whatever you have in your config.php file does not agree with your database credetials
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Fogbow_Foggy
Registered User
Posts: 109
Joined: Sun Sep 26, 2010 11:25 pm

General Error with 3.1.5 to 3.1.6 upgrade

Post by Fogbow_Foggy » Sun Sep 13, 2015 9:51 am

No, there's nothing wrong with my config.php file. My board is working perfectly as long as the Install folder is not there, so the database credentials are OK. Here's my config.php:

Code: Select all

<?php
// phpBB 3.1.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'phpbb\\db\\driver\\mysqli';
$dbhost = '';
$dbport = '';
$dbname = 'wlbjr_fogbow';
$dbuser = 'wlbjr_wlbryanjr';
$dbpasswd = '[redacted]';  ◄-- hasn't changed recently, still works on all my databases
$table_prefix = 'wlbjr_';
$phpbb_adm_relative_path = 'adm/';
$acm_type = 'phpbb\\cache\\driver\\file';

@define('PHPBB_INSTALLED', true);
// @define('PHPBB_DISPLAY_LOAD_TIME', true);
// @define('DEBUG', true);
// @define('DEBUG_CONTAINER', true);

User avatar
Fogbow_Foggy
Registered User
Posts: 109
Joined: Sun Sep 26, 2010 11:25 pm

Re: General Error with 3.1.5 to 3.1.6 upgrade

Post by Fogbow_Foggy » Sun Sep 13, 2015 8:52 pm

I hate to bump up a thread, but I've been watching the number of views go up all day.

I suppose that's good in a way - if there was a simple solution and I should have known it I'd be embarrassed.

But the plain fact is, I can't upgrade my board until I figure this out. Maybe I have to wait for 3.1.7.

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: General Error with 3.1.5 to 3.1.6 upgrade

Post by Oyabun1 » Sun Sep 13, 2015 9:47 pm

Open the board’s /cache folder on the server and delete everything except index.htm and .htaccess.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
KillBill.
Registered User
Posts: 596
Joined: Tue Jun 02, 2009 4:07 pm
Contact:

Re: General Error with 3.1.5 to 3.1.6 upgrade

Post by KillBill. » Sun Sep 13, 2015 10:02 pm

I also encountered this error.

This error only occurs during installation or update!
The fault is not to accept any special characters in the password field.
Recommend replace the password and it will work.

For example, the % character will not be tolerated.

if change password - purge cache ;)

User avatar
Fogbow_Foggy
Registered User
Posts: 109
Joined: Sun Sep 26, 2010 11:25 pm

Re: General Error with 3.1.5 to 3.1.6 upgrade

Post by Fogbow_Foggy » Sun Sep 13, 2015 10:17 pm

Ahh, this makes sense. I don't have a $ but I have ^, %, and # in my password.

Of course, I have to purge the cache first, then change the password on my cPanel, then change it in my config.php, or else I won't be able to connect to the ACP. If I change the password first, then I can't get into the ACP to purge the cache.

Also, I'll have to change it back. That database user/password is used for about 15 websites, and I'd have to fix them all.

Thanks also to Oyabun1, who has helped me several times over the years.

I'll wait to do this until tomorrow at 5 a.m., when the fewest members of my board will be inconvenienced.

Wish me luck!

User avatar
KillBill.
Registered User
Posts: 596
Joined: Tue Jun 02, 2009 4:07 pm
Contact:

Re: General Error with 3.1.5 to 3.1.6 upgrade

Post by KillBill. » Sun Sep 13, 2015 10:19 pm

Fogbow_Foggy wrote:or else I won't be able to connect to the ACP. If I change the password first, then I can't get into the ACP to purge the cache.
Oyabun1 wrote:Open the board’s /cache folder on the server and delete everything except index.htm and .htaccess.
;)

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: General Error with 3.1.5 to 3.1.6 upgrade

Post by Oyabun1 » Sun Sep 13, 2015 10:37 pm

KillBill. wrote:I also encountered this error.

This error only occurs during installation or update!
The fault is not to accept any special characters in the password field.
Recommend replace the password and it will work.

For example, the % character will not be tolerated.

if change password - purge cache ;)
That shouldn't be an issue in updating from 3.1.5 to 3.1.6. There was a bug that was resolved in 3.1.2, so once the board files are correctly updated beyond that it should not be an issue any more.

If the board was previously not correctly updated the solution to the invalid characters in the password issue is to upload the phpbb/di/extension/config.php file from the latest version and then purge the board's cache.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
KillBill.
Registered User
Posts: 596
Joined: Tue Jun 02, 2009 4:07 pm
Contact:

Re: General Error with 3.1.5 to 3.1.6 upgrade

Post by KillBill. » Sun Sep 13, 2015 11:02 pm

Oyabun1 wrote:
KillBill. wrote:I also encountered this error.

This error only occurs during installation or update!
The fault is not to accept any special characters in the password field.
Recommend replace the password and it will work.

For example, the % character will not be tolerated.

if change password - purge cache ;)
That shouldn't be an issue in updating from 3.1.5 to 3.1.6. There was a bug that was resolved in 3.1.2, so once the board files are correctly updated beyond that it should not be an issue any more.

If the board was previously not correctly updated the solution to the invalid characters in the password issue is to upload the phpbb/di/extension/config.php file from the latest version and then purge the board's cache.
Sorry not work

I download 3.1.6 and first install - add sql pass 12345
installed ok
after install I change password HZ765ttgTTz%!+---+H%5tf%tr!%tg
and purge cache

I go index.php page WORK
I again run install/update script add error

Code: Select all

General Error
SQL ERROR [ mysqli ]

Access denied for user 'test'@'localhost' (using password: YES) [1045]

BACKTRACE

User avatar
Fogbow_Foggy
Registered User
Posts: 109
Joined: Sun Sep 26, 2010 11:25 pm

Re: General Error with 3.1.5 to 3.1.6 upgrade

Post by Fogbow_Foggy » Sun Sep 13, 2015 11:08 pm

It won't do any harm to change the password temporarily, upgrade the board, and then change the password back so all my other sites can access their databases.

But if I run into any problems, I'll come back to this thread and ask for more help. I should be able to handle it, but I have to wait 10 hours before I try it.

Thanks for what you've done already.

This was an original installation of 3.1.5. I haven't upgraded my phpBB version before so the files should all be correct.

User avatar
Fogbow_Foggy
Registered User
Posts: 109
Joined: Sun Sep 26, 2010 11:25 pm

Re: General Error with 3.1.5 to 3.1.6 upgrade

Post by Fogbow_Foggy » Mon Sep 14, 2015 9:24 am

Thank you again, Oyabun1 and KillBill. This issue is resolved.

I am now running 3.1.6, everything went very smoothly, and I was only offline for 21 minutes, including the time to back up my database before making any changes. I had to delete cache files several times, and I had to log in to my server as root in order to delete the LOCK files. But other than that, no problems at all.

Locked

Return to “[3.1.x] Support Forum”

cron