Problems with updating

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Problems with updating

Post by Nikola »

I started setting up one board to 3.1.6 but board index seems to be blank all of sudden. I turned on the debugger and I got the following result. Note that I can work in ACP just fine.

This is showing on board index:

Code: Select all

phpBB Debug] PHP Notice: in file [ROOT]/phpbb/auth/auth.php on line 908: Undefined offset: 168
[phpBB Debug] PHP Notice: in file [ROOT]/phpbb/auth/auth.php on line 908: Undefined offset: 168
[phpBB Debug] PHP Notice: in file [ROOT]/phpbb/auth/auth.php on line 909: Undefined offset: 0
[phpBB Debug] PHP Notice: in file [ROOT]/phpbb/auth/auth.php on line 908: Undefined offset: 166
[phpBB Debug] PHP Notice: in file [ROOT]/phpbb/auth/auth.php on line 908: Undefined offset: 166
[phpBB Debug] PHP Notice: in file [ROOT]/phpbb/auth/auth.php on line 909: Undefined offset: 0
I am unsure if that is related with blank page though.
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.
User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: Problems with updating

Post by Solidjeuh »

I'm not 100% sure, but I think this is a PHP version error.
PHP 5.3.3 is required
I don't suffer from insanity. I enjoy every minute of it.
User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Re: Problems with updating

Post by Nikola »

I am running on 5.5.29
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.
User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Re: Problems with updating

Post by Nikola »

http://i.imgur.com/igcT7TH.png
thats the error i get post login...
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Problems with updating

Post by Oyabun1 »

Please fill out the Support Request Template and post it back here to enable us to assist you better.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Core authentacion module problem?

Post by Nikola »

Hello. I have turned on the debugger after fixing my board. However I noticed following message that pops out and shows less than a second after I installed stock 3.1.6. THe message is not appearing with standard settings in config.php

Image

I did talked with my host recently due to php.ini and I was told the following;
Thank you for your patience.

We have resolved the issue with memory allocation.
We could still see some errors while loading the URL '/Forum/phpbb/cache/driver/file.php', which appears to be a coding related issue.
Please note that issue with coding is beyond the scope of our support. To correct this issue we recommend contacting the application developer. Thank you for your understanding and cooperation.

Do feel free to get back to us if you need any further assistance.
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Problems with updating

Post by Mick »

Oyabun1 wrote:Please fill out the Support Request Template and post it back here to enable us to assist you better.
Specifically anything you've been doing such as editing etc,
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52173
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Problems with updating

Post by Brf »

My install only has acl_options up to 121. Why would yours be looking for 168 or 166?
User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Re: Problems with updating

Post by Nikola »

Support Request Template
What version of phpBB are you using? phpBB 3.1.6
What is your board's URL? http://localhost
Who do you host your board with? locally now
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What extensions do you have installed? I have them dozen. same ones I had on 3.1.4 and 3.1.5
What styles do you currently have installed? Custom style from arty
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I've installed fresh copy of phpbb 3.1.6 and booted up the extension free database.
Please describe your problem. When I clear cache and change user permission i get that error i showed in the SS. I only get the error when I turn on the debugger under config.php
Generated by SRT Generator

I dont know brf. I can give you an admin access if you want.
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52173
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Problems with updating

Post by Brf »

Det. Lawliet wrote: Do you have any extensions installed? Yes
What extensions do you have installed? I have them dozen. same ones I had on 3.1.4 and 3.1.5
Did you remove all of your extensions before you did your update?
Maybe you removed some permissions database entries that one of the extensions needs.
User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Re: Problems with updating

Post by Nikola »

Ok;
Here is what happened prior. I had a DB on this board with several extensions installed. The board was version 3.1.5

I've uninistalled and deleted data from extensions making sure none is left in the DB. After that I ran the modission reset file to remove non standard permissions and modules. After that DB had same tables, columns and fields like a stock one. Same with the board when you look at it permission and modules wise. I even gave a STK for 3.1 a try. The STK found none non standard value in the DB. And thats it.

Having that done; I left only config.php, files, images and store folder before I put in the 3.1.6 files. Once I put in the files I pointed to database update. DB update went smooth and board was working properly. I enabled the debugging via config.php and I noticed the issue. It only appears for an instant then it goes away.

I can put the board up for someone to try it out and see where the problem is. As a staff you are more than welcome and trusted. The internet is a nasty place. The number of people I can trust is very low. Thank you.
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.
User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10416
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Problems with updating

Post by Noxwizard »

Is this the board that had a second phpBB database merged into it?
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.
User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Re: Problems with updating

Post by Nikola »

Noxwizard wrote:Is this the board that had a second phpBB database merged into it?
Nothing was "merged". It was always one database. This one was cleared with your stk back in day and it found only ACP_CATS i believe which was cleared with it. The modules were rebuilt, NRU resyncronized and BB code reparsed and anonymous user was fixed. It was updated manually following the procedure provided by phpbb. I do have several admins there though. Im unsure if they tampered with anything though but I know they deleted bots column so I assigned them later giving them proper user IDs and linking to appear in ACP and they are working fine now. Other two boards were merged from 4 older DB copies and they are working fine never had problems with them. I am not experiencing this error there though. One that are merged are archived and I ran query to sufix usernames with [old]. I.e Noxwizard and Noxwizard[old].

Code: Select all

UPDATE Tableshere
   set Column = concat('Prefix', Column, 'Suffix');
or remove prefix.

I dont have problems with those board. I have this problem with current one. No idea why is this happening but I know I never had any error on version 3.1.5
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.
User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Re: Problems with updating

Post by Nikola »

Update; found the bug in the way how phpbb operates with mcp. A fix should be active in upcoming 3.1.7
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.
User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Re: Problems with updating

Post by Nikola »

Apart from forcing a query to be run that normally wouldn't be run the problem was in the phpbb_mcp_sorting()

Line 391: phpBB/includes/functions_mcp.php

Code: Select all

$sql .= 'AND topic_visibility = ' . ITEM_APPROVED;
Line 407: #

Code: Select all

$sql .= 'AND post_visibility = ' . ITEM_APPROVED;
Fix 391;

Code: Select all

$sql .= ' AND topic_visibility = ' . ITEM_APPROVED;
 			}
 			break;
Fix 407;

Code: Select all

$sql .= 'AND post_visibility = ' . ITEM_APPROVED;
 			}
 			break;
This was probably not noticed before due to not many people have moderators without approve permissions. This can be explained when a moderator who does not have a permission over a forum they try to moderate from tries to moderate from it and therefore they will experience either the SQL syntax error or in my case redirect to the main page. SQL error will happen if the mod/extension is linked to said forum permission wise. Redirect will happen without it, which was in my case.
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.
Locked

Return to “[3.1.x] Support Forum”