topic icons and smileys broken link

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
rbrtgrmn
Registered User
Posts: 17
Joined: Thu Sep 17, 2015 4:28 am

topic icons and smileys broken link

Post by rbrtgrmn » Thu Sep 24, 2015 8:01 pm

Support Request Template
What version of phpBB are you using? phpBB 3.1.6
What is your board's URL? http://baalt.org/flux
Who do you host your board with? FatCow
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What extensions do you have installed? Announcements on index
Board3 Portal 2.1.0-rc2
Inline images in attachment
What styles do you currently have installed? Black, Prosilver, Black Grey
What language(s) is your board currently using? British English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? anonymous
What password can be used to view this issue? Tester1
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? simply copied my backup database from my old forum of the current PHPBB version.

The only thing I know for sure is that the old forum from which I backed up the database, was database type Maria.
Please describe your problem. topic icons and smiley icons for any post/pm/etc, are broken. That is, the radial buttons are there with a broken image link.
Generated by SRT Generator

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69361
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: topic icons and smileys broken link

Post by KevC » Thu Sep 24, 2015 8:13 pm

Check the permissions of the images folder and the ones inside it.

If I try and navigate to a smilie image I get denied.

phpBB3 Chmod Permissions
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: topic icons and smileys broken link

Post by Oyabun1 » Thu Sep 24, 2015 10:26 pm

rbrtgrmn wrote:What username can be used to view this issue? anonymous
What password can be used to view this issue? Tester1
The Anonymous user is the account used by anybody who has not yet logged in. It should never have a password assigned. The account shows as being inactive on your board, that should also never be the case. Have you deleted the original Anonymous user?
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

rbrtgrmn
Registered User
Posts: 17
Joined: Thu Sep 17, 2015 4:28 am

Re: topic icons and smileys broken link

Post by rbrtgrmn » Fri Sep 25, 2015 4:12 am

Oyabun1 wrote:
rbrtgrmn wrote:What username can be used to view this issue? anonymous
What password can be used to view this issue? Tester1
The Anonymous user is the account used by anybody who has not yet logged in. It should never have a password assigned. The account shows as being inactive on your board, that should also never be the case. Have you deleted the original Anonymous user?
i selected the checkbox to 'use anonymous user' in ACP. Is this an issue? can I undo this?

rbrtgrmn
Registered User
Posts: 17
Joined: Thu Sep 17, 2015 4:28 am

Re: topic icons and smileys broken link

Post by rbrtgrmn » Fri Sep 25, 2015 4:25 am

i applied all the permissions...

no go.

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: topic icons and smileys broken link

Post by Oyabun1 » Fri Sep 25, 2015 5:39 am

rbrtgrmn wrote:i selected the checkbox to 'use anonymous user' in ACP. Is this an issue? can I undo this?
Yes, it's an issue. As stated, the Anonymous user already has a defined and essential function. It is not provided as a spare user. Remove whatever changes you made to that account and make sure it is in the Guests group and no other group, and no other users are in the Guests group.
rbrtgrmn wrote:i applied all the permissions...
What does that mean?
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

rbrtgrmn
Registered User
Posts: 17
Joined: Thu Sep 17, 2015 4:28 am

Re: topic icons and smileys broken link

Post by rbrtgrmn » Fri Sep 25, 2015 5:06 pm

Oyabun1 wrote:
rbrtgrmn wrote:i applied all the permissions...
What does that mean?
KevC wrote:Check the permissions of the images folder and the ones inside it.

If I try and navigate to a smilie image I get denied.

phpBB3 Chmod Permissions

rbrtgrmn
Registered User
Posts: 17
Joined: Thu Sep 17, 2015 4:28 am

Re: topic icons and smileys broken link

Post by rbrtgrmn » Fri Sep 25, 2015 5:09 pm

Based on the post above, I checked my permissions; they were all jacked up. I fixed them as listed in that guide linked above. Still, not working.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69361
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: topic icons and smileys broken link

Post by KevC » Fri Sep 25, 2015 5:40 pm

If I try and look at this
http://baalt.org/flux/images/smilies/rolleyes.png
It doesn't seem to exist.

If I try and see the smilie folder http://baalt.org/flux/images/smilies/
I'm forbidden.

Are the smilies actually there?
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

rbrtgrmn
Registered User
Posts: 17
Joined: Thu Sep 17, 2015 4:28 am

Re: topic icons and smileys broken link

Post by rbrtgrmn » Fri Sep 25, 2015 7:21 pm

KevC wrote:If I try and look at this
http://baalt.org/flux/images/smilies/rolleyes.png
It doesn't seem to exist.

If I try and see the smilie folder http://baalt.org/flux/images/smilies/
I'm forbidden.

Are the smilies actually there?
All the smilies are named thusly:
icon_rolleyes.gif

and all the topic icons are gifs as well.
:o

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69361
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: topic icons and smileys broken link

Post by KevC » Fri Sep 25, 2015 7:24 pm

That's an address it's looking for.

What do you see if you go to the admin panel > posting > smilies
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

rbrtgrmn
Registered User
Posts: 17
Joined: Thu Sep 17, 2015 4:28 am

Re: topic icons and smileys broken link

Post by rbrtgrmn » Fri Sep 25, 2015 7:36 pm

I see the broken images along with the code and emotion.

I hover over the broken image link and it has the text code for the smiley

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69361
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: topic icons and smileys broken link

Post by KevC » Fri Sep 25, 2015 7:42 pm

Sounds like all of the image names or links are wrong. You should be able to edit each one and correct that.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: topic icons and smileys broken link

Post by Oyabun1 » Fri Sep 25, 2015 9:47 pm

What do you have set for?
ACP > GENERAL > Server settings > Path settings > Smilies storage path
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

rbrtgrmn
Registered User
Posts: 17
Joined: Thu Sep 17, 2015 4:28 am

Re: topic icons and smileys broken link

Post by rbrtgrmn » Sat Sep 26, 2015 4:54 am

Oyabun1 wrote:What do you have set for?
ACP > GENERAL > Server settings > Path settings > Smilies storage path
Smilies- images/smilies
Post topics- images/icons

I am getting smilies to work; just need to rename them to png.

I cannot get topic/post icons to show yet however.

Locked

Return to “[3.1.x] Support Forum”