[CDB] Board3 Portal 2.1.0-RC2

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
Skysect
Registered User
Posts: 57
Joined: Thu Dec 13, 2007 5:40 pm
Name: Cenk Aslan

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Skysect » Sun Sep 27, 2015 11:10 am

Anuj Dhawan wrote:
Skysect wrote:Max length of news article: broken with latest version
Thanks. It worked initially on a test board and than broke later...I understand it now. Thanks again.
After I copied RC3 files on the RC2 files it's fixed . Probably something missing in RC3 files .

User avatar
mr.ruf
Registered User
Posts: 136
Joined: Thu Apr 04, 2013 11:12 pm
Location: PuErTo RiCo
Name: Harold
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by mr.ruf » Mon Sep 28, 2015 1:41 pm

I have problems with the portal , look what happens with style we_universal

Image

Image

Image

any idea ?

User avatar
Darva
Registered User
Posts: 58
Joined: Tue Jan 01, 2013 8:10 pm

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Darva » Thu Oct 01, 2015 10:01 pm

Is there any way to put a teamspeak viewer script into one of the boxes on the side?
Also, is there a way to integrate the phpbbGallery mod with this portal?
How do you change the colors in this mod? I need it to match my style;
Image

Also, how do you get rid of this damn spacer in the box? All I want it to do is show the script and not a blank space on the left that forces people to scroll instead of it adjusting itself to fit the box.
Image
Thanks,

Darva

User avatar
Skysect
Registered User
Posts: 57
Joined: Thu Dec 13, 2007 5:40 pm
Name: Cenk Aslan

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Skysect » Sat Oct 03, 2015 3:32 pm

Marc wrote:Of course it also works with subsilver2.
I changed "read all" text with a button from template files. But same buttom still there when I viewing full form of news. Could I add a "back" button instead of "read all" when I am viewing news ?

EDIT: nevermind I fixed it with editing module php code

User avatar
canam800er
Registered User
Posts: 113
Joined: Thu Jul 21, 2011 7:42 pm
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by canam800er » Sat Oct 03, 2015 4:55 pm

Hi
mr.ruf wrote:I have problems with the portal , look what happens with style we_universal

any idea ?
The Style "we_universal" is not compatible Board3 portal.
Sorry for my bad english, I am German and translated with Google!
My Extensionen!

User avatar
mr.ruf
Registered User
Posts: 136
Joined: Thu Apr 04, 2013 11:12 pm
Location: PuErTo RiCo
Name: Harold
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by mr.ruf » Sat Oct 03, 2015 5:22 pm

canam800er wrote:Hi
mr.ruf wrote:I have problems with the portal , look what happens with style we_universal

any idea ?
The Style "we_universal" is not compatible Board3 portal.
if supported, I have the solution, those with Board3 Portal version 2.1.0-RC3, read well the RC3.
A friend of phpbb-Es, andares,
told him my problem and gave me the solution to it

http://www.phpbb-es.com/foro/viewtopic. ... 54&t=40941

please see this topic , contain the solution

see mi screenshot
Image Image Image

User avatar
mr.ruf
Registered User
Posts: 136
Joined: Thu Apr 04, 2013 11:12 pm
Location: PuErTo RiCo
Name: Harold
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by mr.ruf » Sat Oct 03, 2015 5:25 pm

and just in case, I also supplied the solution for the current RC2 is, in my case was updated to RC3 and change, you the option of placing blocks within the forum, which I apludo option because I really like.

but again if you have solution!

FomenkoAndrey
Registered User
Posts: 367
Joined: Thu Aug 19, 2010 10:44 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by FomenkoAndrey » Fri Oct 09, 2015 9:56 pm

try to update from RC2 to RC3, delete data of the extention from DB, delete files rc2, upload rc3, clear phisicaly cache from the cache folder, except index and htaccess...
error at all pages:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/ext/board3/portal/vendor/autoload.php on line 5: require_once([ROOT]/ext/board3/portal/vendor/composer/autoload_real.php): failed to open stream: No such file or directory
UPD:
the same error i have, when try fully unistall Board3 Portal 2.1.0-RC2 extention:
turn it off, then delete data from DB, then delete files of the ext, then clear cache - the same error at all pages.

UPD2:
in RC2 i have next problem...
i think, this is conflict Board3Portal with HIDEbbcode viewtopic.php?f=456&t=2279486 ? but noone HIDE tag in the topic by examlple URL...
for example url: http://motobratva.com/portal?np_13=1582, where "read all" - link to http://motobratva.com/portal?np_13=1582 ... 3=0#n_13_0, where i have next error

Code: Select all

Unable to find template "portal/portal_body.html" (looked into: ./styles/prosilver_se/template, ./styles/prosilver_se/theme, ./styles/prosilver/template, ./styles/prosilver/theme, ./ext/marcovo/hideBBcode/styles/all/template, ./ext/marcovo/hideBBcode/styles/all/theme).
debug dont show errors.

i need help plz.

FomenkoAndrey
Registered User
Posts: 367
Joined: Thu Aug 19, 2010 10:44 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by FomenkoAndrey » Sat Oct 10, 2015 2:58 pm

try version 2.1.0 from github, block "latest news", Max length of news article: 250 - doesnt work.
i see whole first posts of topics, option does not respond to the value set.

..777..
Registered User
Posts: 150
Joined: Tue Oct 28, 2014 5:43 pm

Re: [RC] Board3 Portal 2.1.0-RC2

Post by ..777.. » Sat Oct 10, 2015 3:21 pm

I possibly found a bug. In the lastest news if you click on the last page, or one of the last pages I get this error:

Code: Select all

DateTime::__construct(): Failed to parse time string (@) at position 0 (@): Unexpected character
Last edited by ..777.. on Sat Oct 10, 2015 4:10 pm, edited 1 time in total.

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5405
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Marc » Sat Oct 10, 2015 3:24 pm

The packages you can download from github are missing the vendor folder. If you really want the most up-to-date package, then please download it here: https://download.m-a-styles.de/2.1.x/latest/

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5405
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Marc » Sat Oct 10, 2015 3:46 pm

..777.. wrote:I possibly found a bug. In the lastest news if you click on the last page, or one of the last pages I get this error:

Code: Select all

DateTime::__construct(): Failed to parse time string (@) at position 0 (@): Unexpected character
raypeatforum.com
I have seen this before and it's caused by invalid topic/post data. Take a look at your oldest topics in your viewforum page(s). You probably won't be able to open these topics. It would be nice if you could give me a database dump of the offending topics/posts as nobody has done that before.

smenrik
Registered User
Posts: 17
Joined: Mon Oct 05, 2015 8:33 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by smenrik » Sat Oct 10, 2015 6:32 pm

Can you tell me where and how I can reduce search and login box width ( autoresize for this don't work well under recomended blocks width) if I reduce left and right size from 180 to 160 that boxes are bigger than block width , margins are one over other and this look's bad on mobiles and tablets
I use Black style, it works with portal good enought on desktops but I have that small problems on mobile
left and right block are too big , doesn't resize well because search and login boxes width are not autoresize to fit the block
check http://www.smenpoker.ro to see how it looks
try to reduce your desktop window at a mobile size and look at the bottom , where are left and right blocks to see margins and search box problem
Now I noticed that same error I have on a desktop view on google Chrome...

FomenkoAndrey
Registered User
Posts: 367
Joined: Thu Aug 19, 2010 10:44 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by FomenkoAndrey » Sat Oct 10, 2015 9:56 pm

Marc, I downloaded and made clean install the version by your link.
but i have the same error:
http://motobratva.com/portal?np_13=2268#n_13 (page 325)

Code: Select all

Unable to find template "portal/portal_body.html" (looked into: ./styles/prosilver_se/template, ./styles/prosilver_se/theme, ./styles/prosilver/template, ./styles/prosilver/theme, ./ext/marcovo/hideBBcode/styles/all/template, ./ext/marcovo/hideBBcode/styles/all/theme).
next page - work fine:
http://motobratva.com/portal?np_13=2275#n_13 (page 326 and others)
prosilver_se - made a copy of prosilver folder in the portal\styles.

whats wrong with this?

UPD: problem with hideBBcode!

Miri4ever
Registered User
Posts: 409
Joined: Sat Mar 07, 2015 11:18 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Miri4ever » Sat Oct 10, 2015 11:54 pm

Darva wrote:Is there any way to put a teamspeak viewer script into one of the boxes on the side?
Also, is there a way to integrate the phpbbGallery mod with this portal?
How do you change the colors in this mod? I need it to match my style;
Image

Also, how do you get rid of this damn spacer in the box? All I want it to do is show the script and not a blank space on the left that forces people to scroll instead of it adjusting itself to fit the box.
Image
Thanks,

Darva
Ok yours using a dark style, maybe you check the link to my site and see if it fits better for your. The portal has some little errors for differ styles:

For your problem, it exist on all styles and you need the change this file: prosilver/template/portal/modules/custom_side.html

Code: Select all

{$LR_BLOCK_H_L}<!-- IF $S_BLOCK_ICON --><img src="{$IMAGE_SRC}" width="{$IMAGE_WIDTH}" height="{$IMAGE_HEIGHT}" alt="" />&nbsp;<!-- ENDIF -->{$TITLE}{$LR_BLOCK_H_R}
   <div class="inner">
      <div>
         <div class="content portal-module-content">{$CUSTOM_CODE}</div>
      </div>
   </div>
{$LR_BLOCK_F_L}{$LR_BLOCK_F_R}
Mabye you need to adapt the first div class to some of your boards style. For middle block and Welcome message nearly same changes must be made. On Page 26 here I posted some changes I made for getting it work much easier with all kind of differ styles. Maybe you check my Article there.
Last edited by Miri4ever on Sun Oct 11, 2015 12:00 am, edited 1 time in total.
Homepage: Terra Oceanica

Locked

Return to “Extensions in Development”