PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by Solidjeuh » Wed Jan 13, 2016 7:41 pm

When I change from php 5.6.16 to 7.0.1 I receive an error.
Is this because of some extensions then need an update?
I have that error on board3 portal and viewtopic.php
Maybe Advanced BBCode Box and few other extensions...?
I updated to phpBB 3.1.7-pl1 last night.

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 370: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5282: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
I don't suffer from insanity. I enjoy every minute of it.

User avatar
david63
Registered User
Posts: 16400
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by david63 » Wed Jan 13, 2016 9:20 pm

I believe that phpBB 3.1 is not 100% compatible with php 7
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by Solidjeuh » Wed Jan 13, 2016 9:26 pm

david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
It seems to work, except in JV-Shoutbox and Advanced BBCode Box ..
So extensions that use BBCode.
So could be the extensions.. maybe.. :geek:
Oh well, it's not needed to upgrade to php 7.0.1, who cares :lol:
I don't suffer from insanity. I enjoy every minute of it.

User avatar
Crizzo
Translations & International Support Teams Manager
Translations & International Support Teams Manager
Posts: 885
Joined: Thu Apr 23, 2009 1:20 pm
Location: Germany
Name: Christian
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by Crizzo » Wed Jan 13, 2016 9:32 pm

phpBB 3.1.x does not support PHP 7.0 and higher. See: https://github.com/phpbb/phpbb/blob/3.1 ... r.json#L28
My extensions for phpBB: crizzo.de
German phpBB Support at www.phpbb.de

User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by Solidjeuh » Wed Jan 13, 2016 9:34 pm

Crizzo wrote:phpBB 3.1.x does not support PHP 7.0 and higher. See: https://github.com/phpbb/phpbb/blob/3.1 ... r.json#L28
Then it's 3.2 that works with 7.0.1..? I was being stupid again.. :lol:
I don't suffer from insanity. I enjoy every minute of it.

User avatar
3Di
Former Team Member
Posts: 14047
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by 3Di » Wed Jan 13, 2016 9:34 pm

david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
Clearly stated into the 3.1.7-pl1 release (docs/INSTALL.html): between PHP 5.3.3+< and PHP < 7.0. If I correctly understood is equal to less than 7.0.?
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

LavIgor
Registered User
Posts: 541
Joined: Mon Apr 28, 2014 1:47 pm

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by LavIgor » Thu Jan 14, 2016 11:52 am

3Di wrote:
david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
Clearly stated into the 3.1.7-pl1 release (docs/INSTALL.html): between PHP 5.3.3+< and PHP < 7.0. If I correctly understood is equal to less than 7.0.?
Where have you taken this line from?
In the official package there's the following line:
PHP 5.3.3+ and PHP < 7.0 with support for the database you intend to use.
This commit includes the updated supported PHP version numbers.
As you can notice, the line in README.html states the supported version numbers more clearly:
The minimum version required is PHP 5.3.3 and the maximum supported version is any version prior to PHP 7.0.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by RMcGirr83 » Thu Jan 14, 2016 12:22 pm

3Di wrote:
david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
Clearly stated into the 3.1.7-pl1 release (docs/INSTALL.html): between PHP 5.3.3+< and PHP < 7.0. If I correctly understood is equal to less than 7.0.?
Not equal to less than, that would be this =< 7.0 otherwise simply less than
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

LavIgor
Registered User
Posts: 541
Joined: Mon Apr 28, 2014 1:47 pm

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by LavIgor » Thu Jan 14, 2016 1:00 pm

RMcGirr83 wrote:
3Di wrote:
david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
Clearly stated into the 3.1.7-pl1 release (docs/INSTALL.html): between PHP 5.3.3+< and PHP < 7.0. If I correctly understood is equal to less than 7.0.?
Not equal to less than, that would be this =< 7.0 otherwise simply less than
I didn't disagree with that statement because it is correct.

> If I correctly understood is equal to less than 7.0.?
means "equal to less than 7.0", not less than or equal to 7.0.

"Equal to" is related to the statement in this case. The statement is equal to this. ;)

User avatar
3Di
Former Team Member
Posts: 14047
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by 3Di » Thu Jan 14, 2016 7:17 pm

^ this ^

I should have wrote "means less than...", don't know. :)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by Solidjeuh » Thu Jan 14, 2016 7:19 pm

This is very confusing for a noob like me :lol: :lol:
I don't suffer from insanity. I enjoy every minute of it.

Sugama97
Registered User
Posts: 5
Joined: Sat Aug 13, 2016 5:33 am

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by Sugama97 » Sat Aug 13, 2016 5:37 am

This is very confusing.

This was all discussed in January for 3.1.7?
Is there any update since?

User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7631
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by JimA » Sat Aug 13, 2016 6:41 am

Sugama97 wrote:This is very confusing.

This was all discussed in January for 3.1.7?
Is there any update since?
Hi, welcome to phpBB.com! :)

Well, not really. It is still the same in the way that the 3.1.x line is not compatible with PHP7. You'll need a PHP version that's 5.3.3 or higher, but not at high as PHP7.

We are currently in the last testing phase (RC) of our new feature release, phpBB 3.2, which will be compatible with PHP7. It's currently not suitable for use in a live environment, but I expect it to be released in the next few months. So you have two options. Either use phpBB 3.1 and downgrade your PHP version back to PHP5, or wait for the final release of phpBB 3.2 in a few months which supports PHP7.
Image Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66559
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by Lumpy Burgertushie » Sat Aug 13, 2016 7:12 am

why are so many people/hosts upgrading to php7 when it is still in beta. it isn't even in release candidate status yet. there aren't that many programs that can use 7 yet.

5.6 is the current stable version of php.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25316
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Post by Paul » Sat Aug 13, 2016 7:14 am

Lumpy Burgertushie wrote:why are so many people/hosts upgrading to php7 when it is still in beta. it isn't even in release candidate status yet. there aren't that many programs that can use 7 yet.

5.6 is the current stable version of php.

robert
Php7 is not in beta, the first stable release of php 7 was in december last year ;)
Knock knock
Race condition
Who's there?

My Blog • My Photos • my phpBB Extensions • custom phpBB work & Development

Locked

Return to “[3.1.x] Support Forum”