[CDB] Thanks for posts

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
Fisch.666
Registered User
Posts: 219
Joined: Sat Jul 30, 2005 10:58 am

Re: [DEV] Thanks for posts

Post by Fisch.666 » Sun Jan 10, 2016 4:04 pm

Hi,

i've just notices when running this mod in version 2.0.2 on a phpBB 3.1.6 the following two options are mixed:

THANKS_REPUT_HEIGHT / Graphics height

and

THANKS_REPUT_LEVEL / Number of images in a graphic scale

If i choose a graphics height of 15 px and a number of images in a graphic scale of 10 (which are the defaults of this mod) the graphics height is 10 px and the number of images 15.

*Edit*

Mhhh, thats strange. It seems they are counted somehow together. If i choose a graphics height of 15px and a number of images of 13 i get 20 stars in the forums overview of the rating.

*Edit2*

Ok, that seems to be caused by an own graphic image i had used for the stars. Sorry for the noise.

Fisch.666
Registered User
Posts: 219
Joined: Sat Jul 30, 2005 10:58 am

Re: [DEV] Thanks for posts

Post by Fisch.666 » Sun Jan 10, 2016 6:13 pm

Hi,

sorry can't find the right search words to search within the topic for this issue. When using own images for the reputation the shown reputation of a post is still using the default images. It seems the "thanks_reput_image" is hard coded within the .css:

Code: Select all

<div class="thanks_reput_image" style="height: 10px; width: 100%;"></div>
and

Code: Select all

.thanks_reput_image {
    background: rgba(0, 0, 0, 0) url("../../../images/rating/reput_star_gold.gif") repeat-x scroll 0 0;
}
Is this intended?

cycling
Registered User
Posts: 22
Joined: Wed Sep 16, 2015 7:36 am

Re: [DEV] Thanks for posts

Post by cycling » Sun Jan 10, 2016 6:52 pm

I don't know if this was asked before but,

Is it possible to list usernames who liked a post, bottom of the post?

For example,

I list only 5 usernames (to keep the post clean as much as possible) under the post. It says;

X, y, z, a, b and 5 more people thanked.

When I click that "5 more people" link, is it possible an Ajax window opens to list everyone who thanked to that post ?

koreldan
Registered User
Posts: 3
Joined: Thu Oct 08, 2015 4:10 pm

Re: [DEV] Thanks for posts

Post by koreldan » Thu Jan 14, 2016 5:08 pm

Leinad4Mind wrote:I guess the problem is on both sides... ask tapatalk for a solution!

Try this:

thanks_for_posts/notification/thanks.php

Code: Select all

public function get_url()
	{
		return append_sid($this->phpbb_root_path . 'viewtopic.' . $this->php_ext, "p={$this->item_id}#p{$this->item_id}");
	}
changes to

Code: Select all

public function get_url()
	{
		$server_url = generate_board_url();
		return append_sid($this->server_url . 'viewtopic.' . $this->php_ext, "p={$this->item_id}#p{$this->item_id}");
	}
Maybe it can work... not even tested :lol:
Did this solution worked ?

drooid
Registered User
Posts: 81
Joined: Tue Mar 31, 2009 9:15 am

Re: [DEV] Thanks for posts

Post by drooid » Sat Jan 16, 2016 10:54 am

ThanksForPosts has two different ways to show toplist (at the bottom of main page) for registered users and for guests (with restricted rights). Toplist for guests doesn't show thanks received in topics not available for guests (I think so).
Is it intentional action of author or kind of bug?
Is there any way to show complete list for all kind of users?

User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: [DEV] Thanks for posts

Post by Solidjeuh » Sat Jan 16, 2016 6:43 pm

I receive an error when I enable this extension.
And when I go to forum permissions I see just an empty tab..

Code: Select all

[phpBB Debug] PHP Notice: in file [ROOT]/ext/gfksx/ThanksForPosts/migrations/v_0_4_0.php on line 24: Undefined variable: thanks_table_exists
Image
I don't suffer from insanity. I enjoy every minute of it.

rxu
Extensions Development Team
Posts: 3003
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Sat Jan 16, 2016 7:00 pm

Solidjeuh wrote:I receive an error when I enable this extension.
And when I go to forum permissions I see just an empty tab..
That should be fixed in the repo already. Please try redownloading and reinstalling the ext again.
drooid wrote:Is it intentional action of author or kind of bug?
Is there any way to show complete list for all kind of users?
I'm not sure, will check that later.

User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: [DEV] Thanks for posts

Post by Solidjeuh » Sat Jan 16, 2016 8:00 pm

rxu wrote:
Solidjeuh wrote:I receive an error when I enable this extension.
And when I go to forum permissions I see just an empty tab..
That should be fixed in the repo already. Please try redownloading and reinstalling the ext again.
Yes permissions are ok now! Thank you!
Just debug error when you enable the extension.
But everything seems to work
I don't suffer from insanity. I enjoy every minute of it.

Holger
Registered User
Posts: 1761
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: [DEV] Thanks for posts

Post by Holger » Thu Jan 21, 2016 7:40 am

Hi there,

running ext version 2.0.2 on phpBB 3.1.7-PL1.
Some of my users get this when they want to thank for a post:

Image

They are logged in, they can edit, yuote, post and so on. But they cant thank.
Some other users CAN thank as you can see in the screenshot. I can also use the thank button.

What can cause this problem?

Best regards
Holger

Holger
Registered User
Posts: 1761
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: [DEV] Thanks for posts

Post by Holger » Thu Jan 21, 2016 7:47 am

As the permission tab was empty I updated the ext and now the permission tab shows Yes.
But now the Thank you button is missing in the posts.

Edit: nevermind! Works!

Holger
Registered User
Posts: 1761
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: [DEV] Thanks for posts

Post by Holger » Thu Jan 21, 2016 1:12 pm

Updated the Ext today and this is still valid:
Holger wrote:Hi there,

running ext version 2.0.2 on phpBB 3.1.7-PL1.
Some of my users get this when they want to thank for a post:

Image

They are logged in, they can edit, yuote, post and so on. But they cant thank.
Some other users CAN thank as you can see in the screenshot. I can also use the thank button.

What can cause this problem?

Best regards
Holger

User avatar
alex75
Registered User
Posts: 364
Joined: Sun Jun 10, 2012 9:09 am
Location: Italy
Name: Alessandro
Contact:

Re: [DEV] Thanks for posts

Post by alex75 » Thu Jan 21, 2016 1:59 pm

Hi. Congratulations for the excellent work you are doing. I want to report a problem with the scrolling of pages of thankslist. if I open the thankslist works, but if I try to go to the next pages gives me error (No route found for "GET /thankslist/givens/2/app.php/thankslist/givens/2/false").
Example:
First page ok
Second page dont work

rxu
Extensions Development Team
Posts: 3003
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Thu Jan 21, 2016 3:14 pm

Holger wrote:running ext version 2.0.2 on phpBB 3.1.7-PL1.
Some of my users get this when they want to thank for a post:
I guess you're using this addon extension viewtopic.php?f=456&t=2259666
You can try without it and/or try to update that addon from the repo.

Holger
Registered User
Posts: 1761
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: [DEV] Thanks for posts

Post by Holger » Thu Jan 21, 2016 3:17 pm

Ah, yes, stupid me!
Ill try that!

rxu
Extensions Development Team
Posts: 3003
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Thu Jan 21, 2016 3:17 pm

alex75 wrote:No route found for "GET /thankslist/givens/2/app.php/thankslist/givens/2/false"
Are you using the latest code from the repo? Do you have URL rewriting enabled in ACP?

Locked

Return to “Extensions in Development”