Convert phpBB to 3.1 only have DB

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
gnagis
Registered User
Posts: 8
Joined: Sat Sep 05, 2015 9:39 am

Convert phpBB to 3.1 only have DB

Post by gnagis » Tue May 03, 2016 8:25 am

i only have the DB from old forum left not the files.
can i still convert the db only in some way? the converter for installer needs a path to phpbb to work so that i cant use :(

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69465
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Convert phpBB to 3.1 only have DB

Post by KevC » Tue May 03, 2016 8:29 am

From what to 3.1?
From 3.0?

No part of going from 3.0 to 3.1 involves needing a path.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

gnagis
Registered User
Posts: 8
Joined: Sat Sep 05, 2015 9:39 am

Re: Convert phpBB to 3.1 only have DB

Post by gnagis » Tue May 03, 2016 8:34 am

the old site used 3.0.8

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69465
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Convert phpBB to 3.1 only have DB

Post by KevC » Tue May 03, 2016 9:08 am

Your config.php file needs to be correct.

Rebuilding Your config.php File


Apart from this, follow this

Notes:
  • Your server must be running at least PHP 5.3.3
  • Most MODs for 3.0.x are incompatible with 3.1.x and their functionality will be removed in the update process.
  • Styles for 3.0.x cannot be installed or used on 3.1.x.
  1. Backup up your board's files and database
  2. Deactivate all styles except for prosilver
  3. Ensure that the activated spambot countermeasure is one of the standard phpBB plugins (Simple image, GD image, GD 3D image, Q&A, reCaptacha).
  4. Set British English as the only language pack
  5. Delete all of your phpBB 3.0.x files EXCEPT for the following:
    • The config.php file
    • The /images/ directory
    • The /files/ directory
    • The /store/ directory
  6. Upload the contents of the phpBB3 directory from the uncompressed 3.1.x Full Package (EXCEPT for config.php) into your forum's directory (Note: you don't want to overwrite your original config.php file)
  7. Browse to www.example.com/install/database_update.php
  8. Delete the /install/ directory
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

gnagis
Registered User
Posts: 8
Joined: Sat Sep 05, 2015 9:39 am

Re: Convert phpBB to 3.1 only have DB

Post by gnagis » Tue May 03, 2016 9:33 am

Database type :: mysqli
Previous version :: 3.0.8
Installing Schema: \phpbb\db\migration\data\v30x\release_3_0_9_rc1.

Code: Select all

SQL ERROR [ mysqli ]

Out of range value for column 'bbcode_id' at row 2 [1264]

SQL

ALTER TABLE `phpbb_bbcodes` CHANGE `bbcode_id` `bbcode_id` smallint(4) UNSIGNED DEFAULT '0' NOT NULL

BACKTRACE


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/tools.php
LINE: 1428
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/phpbb/db/tools.php
LINE: 2567
CALL: phpbb\db\tools->_sql_run_sql()

FILE: [ROOT]/phpbb/db/tools.php
LINE: 760
CALL: phpbb\db\tools->sql_column_change()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\tools->perform_schema_changes()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 550
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 496
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 305
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 202
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 185
CALL: phpbb\db\migrator->update_do()

FILE: [ROOT]/install/database_update.php
LINE: 205
CALL: phpbb\db\migrator->update()

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69465
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Convert phpBB to 3.1 only have DB

Post by KevC » Tue May 03, 2016 9:54 am

That's probably caused by a BBcode MOD you had.

Upload the Support Toolkit and run the database cleaner to see if that fixes it.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

gnagis
Registered User
Posts: 8
Joined: Sat Sep 05, 2015 9:39 am

Re: Convert phpBB to 3.1 only have DB

Post by gnagis » Tue May 03, 2016 12:00 pm

when i try to go to STK folder....

Code: Select all

 PHP Fatal error:  Class 'critical_repair' not found in /srv/web/mydomainname.com/hpc/forum/stk/includes/functions.php on line 655

User avatar
3Di
Former Team Member
Posts: 14487
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Convert phpBB to 3.1 only have DB

Post by 3Di » Tue May 03, 2016 12:28 pm

Is better, because of very old software, to try this steps:

1 - d/l a fresh full package of 3.0.8
2 - install it as a fresh Board, an empty one.. and delete the install folder. Do nothing else.
3 - import your old 3.0.8 DB on it (if very big, using bigdump in order to repopulate it as it was.)
4 - you then probably need to adjust some little bits, in config.php if I correctly recall.

To add:
once you got the 3.0.8 working you can update first to 3.0.14 and only once also this step is done you could consider to upgrade to 3.1.9... following the steps required.

Every step followed by the other one etc..

download the 3.0.8 full package from here:
https://download.phpbb.com/pub/release/3.0/
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
✒️ Black Friday 2019 @ The Studio ▪️◾️

Locked

Return to “[3.1.x] Support Forum”