[3.3][RC] Autolinks 1.3.3

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
mcten
Registered User
Posts: 10
Joined: Sat Aug 06, 2016 3:10 pm

Re: [RC] Autolinks 1.0.15

Post by mcten »

I installed the latest version, but it still does not work. I would add only that removed the old data after the update and cleaned cache.

Maybe somehow I can help diagnose the problem?
User avatar
pierredu
Registered User
Posts: 1119
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.15

Post by pierredu »

Could you send me the files data_autolinks.php and data_al_enabled.forums.php, to be found in the forum/cache/folder ?
I'll send you my email per pm.
User avatar
pierredu
Registered User
Posts: 1119
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.15

Post by pierredu »

After installing your cache file on my test forum, your link works fine.
There must be something else.

A conflict with another extension?
Do you have other extensions installed?
Which ones?
mcten
Registered User
Posts: 10
Joined: Sat Aug 06, 2016 3:10 pm

Re: [RC] Autolinks 1.0.15

Post by mcten »

Yes, You have right.
I turned off Tapatalk Plugin for phpBB 3.1 extension and Autolinks starts working ok. I updated tapatalk to the latest version but i have some conflict with this two extensions.
User avatar
pierredu
Registered User
Posts: 1119
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.15

Post by pierredu »

Fine, thanks, we are on the right track.
User avatar
pierredu
Registered User
Posts: 1119
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.16

Post by pierredu »

Well, here we are.
There is indeed an incompatibility issue with tapatalk for 3.1.x. I could observe it after installing the extension.

Both extensions hook the same event (core.viewtopic_post_rowset_data). I added a negative priority value to the subscription code to be loaded after tapatalk and it now works.

The code was updated on github.
User avatar
spaceace
Registered User
Posts: 1994
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: [RC] Autolinks 1.0.16

Post by spaceace »

pierredu wrote:There is indeed an incompatibility issue with tapatalk for 3.1.x.
many extensions have issues with tapatalk and i have pointed out many issues to them and they have fixed a couple but not all :roll:
User avatar
pierredu
Registered User
Posts: 1119
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.16

Post by pierredu »

Thanks for the confirmation. Curing the problem was relatively painless (a negative priority value when subscribing the event).
mcten
Registered User
Posts: 10
Joined: Sat Aug 06, 2016 3:10 pm

Re: [RC] Autolinks 1.0.16

Post by mcten »

Works :)
Thank You :)
User avatar
serek
Registered User
Posts: 58
Joined: Fri Jan 30, 2015 12:47 pm
Location: London
Name: Serge Victor
Contact:

Re: [RC] Autolinks 1.0.16

Post by serek »

Hi, installed few minutes from github master:

Code: Select all

HP message: PHP Fatal error:  Cannot access protected property lmdi\autolinks\acp\autolinks_module::$u_action in /opt/www/talk/includes/functions_module.php on line 625
when i try to configure the extension.
User avatar
pierredu
Registered User
Posts: 1119
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.16

Post by pierredu »

I'll check this.
Stay tuned.
User avatar
RMcGirr83
Former Team Member
Posts: 21684
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: [RC] Autolinks 1.0.16

Post by RMcGirr83 »

$u_action shouldn't be protected but rather public.
Former Modifications/Extensions Team Member | My extensions | github | All requests for support via PM will be ignored
Appreciate the extensions/mods/support then buy me a beerImage
User avatar
pierredu
Registered User
Posts: 1119
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.16

Post by pierredu »

Rich,

Thanks for the tip.
You gave me the solution.
User avatar
pierredu
Registered User
Posts: 1119
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.17

Post by pierredu »

The repository was updated on github.
User avatar
serek
Registered User
Posts: 58
Joined: Fri Jan 30, 2015 12:47 pm
Location: London
Name: Serge Victor
Contact:

Re: [RC] Autolinks 1.0.17

Post by serek »

pierredu wrote:The repository was updated on github.
It works now, thanks, Pierre!

BTW, I would suggest a tiny, but very desired improvement: an option to define CSS3 class of links created by the extension.
Post Reply

Return to “Extensions in Development”