3.1.10 ACP Custom Profile Fields Error [Solved]

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
orre
Registered User
Posts: 22
Joined: Fri Feb 25, 2011 8:19 pm
Name: Jan Orre

3.1.10 ACP Custom Profile Fields Error [Solved]

Post by orre » Tue Oct 18, 2016 4:59 pm

Hello powerful community! :geek:

I have migrated from 3.0 and cannot edit the Custom Profile Fields in ACP.
Hitting any green edit gear give the error:
Information. The submitted form was invalid. Try submitting again.
All fields seem to work and display fine though.
Except one where I had [url]'s (Isn't that possible?) Just deactivated that one for now.

I don't know if/how its related, but I did found what I perceived was two mod leftovers in ACP - User&Groups tab - Users: [ADD_USER] and [ACP_PROFILE_CONTROL]
Don't even remember what they where, but I didn't have any fuzz removing them.
-No difference though..

The "moddision_reset.php" have neither helped here.

I'm hoping for some input from you guys! :)

Thanks!
/Jan
Last edited by orre on Wed Oct 19, 2016 11:00 am, edited 1 time in total.

User avatar
david63
Registered User
Posts: 16795
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: ACP Custom Profile Fields Error (3.0 migration)

Post by david63 » Tue Oct 18, 2016 5:45 pm

That is a known bug in 3.1.10 - viewtopic.php?f=466&t=2389761
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

orre
Registered User
Posts: 22
Joined: Fri Feb 25, 2011 8:19 pm
Name: Jan Orre

Re: ACP Custom Profile Fields Error (3.0 migration)

Post by orre » Tue Oct 18, 2016 11:48 pm

Hmmm.. What a shame..
Any topic to follow for when possible solution comes up?
Or just wait for next update?...

Thank's David for the site logo mod I just installed btw!
;)

/Jan

User avatar
3Di
Former Team Member
Posts: 14464
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: ACP Custom Profile Fields Error (3.0 migration)

Post by 3Di » Wed Oct 19, 2016 12:52 am

orre wrote:Hmmm.. What a shame..
Any topic to follow for when possible solution comes up?
Or just wait for next update?...
/Jan
if you dare you can apply this verified fix
https://github.com/phpbb/phpbb/pull/448 ... 4fbff34c69
you are then in your own though.

On a side note, I would like to stress the point that the script "modission_reset.php" it is obsolete and not to be used like an antibiotic, best to ask for support before to do that.

The MODission_reset's house is here (updated for 3.1.10 the same day it has been released):
http://3di.space/32/viewtopic.php?f=3&t=7 (modission_reset_3110.php)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
✒️ Black Friday 2019 @ The Studio ▪️◾️

orre
Registered User
Posts: 22
Joined: Fri Feb 25, 2011 8:19 pm
Name: Jan Orre

Re: ACP Custom Profile Fields Error (3.0 migration)

Post by orre » Wed Oct 19, 2016 10:24 am

Thanks a million! The fix works like a charm! :D

-I just installed the official "latest stable" version though?... :roll:

The migration was quite ruff to me, so I thought this error might have something to do with the old database..
The "modission_reset" has helped with a few errors. And yes I have used the updated "modission_reset_3110.php" version for the phpBB 3.1.10.
-Thanks for the input about not overdo! Board seem to work all fine now!

(But the [url] still doesn't work in the CPF. -Have I modded the 3.0 board to make it work before?...)

/Jan

User avatar
3Di
Former Team Member
Posts: 14464
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: 3.1.10 ACP Custom Profile Fields Error [Solved]

Post by 3Di » Fri Oct 21, 2016 5:58 am

Sorry but I feel a bit confused about your question, care to expand?
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
✒️ Black Friday 2019 @ The Studio ▪️◾️

User avatar
sysz
Registered User
Posts: 278
Joined: Mon Jan 30, 2012 11:36 pm
Location: Sweden, Helsingborg
Name: Kimmy Lindell Ekström
Contact:

Re: ACP Custom Profile Fields Error (3.0 migration)

Post by sysz » Sat Dec 03, 2016 11:53 am

3Di wrote:
orre wrote:Hmmm.. What a shame..
Any topic to follow for when possible solution comes up?
Or just wait for next update?...
/Jan
if you dare you can apply this verified fix
https://github.com/phpbb/phpbb/pull/448 ... 4fbff34c69
you are then in your own though.

On a side note, I would like to stress the point that the script "modission_reset.php" it is obsolete and not to be used like an antibiotic, best to ask for support before to do that.

The MODission_reset's house is here (updated for 3.1.10 the same day it has been released):
http://3di.space/32/viewtopic.php?f=3&t=7 (modission_reset_3110.php)
Here is the fix in file format for those of you who don't know how to fix your self and or just need a fast solution fix.
acp_profile.php
(38.29 KiB) Downloaded 77 times
Currently working on the community

orre
Registered User
Posts: 22
Joined: Fri Feb 25, 2011 8:19 pm
Name: Jan Orre

Re: 3.1.10 ACP Custom Profile Fields Error [Solved]

Post by orre » Mon Dec 05, 2016 5:27 am

@ 3Di. Sorry about that... :P It was just a side note:
Before migrating, I had a custom profile field with [url] tags. This doesn't seem to work any more.

/Orre

BioLogIn
Registered User
Posts: 172
Joined: Sun Jan 06, 2008 10:51 am

Re: ACP Custom Profile Fields Error (3.0 migration)

Post by BioLogIn » Tue Feb 14, 2017 12:39 pm

3Di wrote:
Wed Oct 19, 2016 12:52 am
orre wrote:Hmmm.. What a shame..
Any topic to follow for when possible solution comes up?
Or just wait for next update?...
/Jan
if you dare you can apply this verified fix
https://github.com/phpbb/phpbb/pull/448 ... 4fbff34c69
you are then in your own though.
Sadly, doesn't make any difference for me - the same mistake stays even after applying this diff...

Apparently, I've been inaccurate - I've had similar problems occurring during search index rebuild, and I've arrived here from tracker ticket and github pr where both bugs were discussed as one. However, the fix above applies only to CPF.

To fix the search index rebuild invalid form error, one needs to address similar issue at /includes/acp/acp_search.php on lines ~259-262.

upd: And at /acp/acp_search.php on lines ~60-63 to be able to adjust search engine settings.

Locked

Return to “[3.1.x] Support Forum”